SmartThings Community

[RELEASE] Honeywell Evohome Integration

honeywell
thermostat
climatecontrol
smartapp_hvac
dth_hvac

(Mitch Turner) #143

Hi - Thanks all done, i was obviously doing something so stupid. Thank you for your help, i love the integration.


(Mitch Turner) #144

Hi - Sorry to bother you again. It seems to have loaded onto Smarthings perfectly, apart from i cannot change the temperature, its basically just showing me what they are set at. If i select the up or down arrow it does not move the temp. Also states at the bottom of the temp Idle (Auto). Is there something I have missed?

Thanks for your help.


(Ben Seven) #145

Hi,

Thanks for this integration - like everyone else in this thread has said, it seems really great. Have had my first foray into the world of SmartThings this evening and it’s going well, however like Obextra it’s not currently working to set temperatures.

From the live logging I can see the following errors, latest message first:

9:49:35 PM: error The Snug: setHeatingSetpoint(): Error: Unable to set heating setpoint.
9:49:35 PM: error Evohome thermostat: setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request
9:49:35 PM: info Evohome thermostat: setHeatingSetpoint(): Zone ID: null, Setpoint: 18.0, Until: 2017-05-14T11:00:00Z
9:49:35 PM: debug Evohome thermostat: setHeatingSetpoint(): Zone ID: null, Setpoint: 18.0, Until: Sun May 14 11:00:00 UTC 2017
9:49:35 PM: info The Snug: setHeatingSetpoint(): Setting setpoint to: 18.0 until: Sun May 14 11:00:00 UTC 2017
9:49:35 PM: trace Got SetBinaryStateResponse = Error

This scans to me like there’s an API error? But I’m brand new to this world and don’t want to go messing with the app code and break it further!

Thanks and happy to test any fixes.

B


(Ben Seven) #146

Oh man am I stoked. I just fixed this myself :slight_smile:

I found this post: http://dirkgroenen.nl/projects/2016-01-15/honeywell-API-endpoints-documentation/ - if you scroll to the bottom, the second commenter mentions that there is a new API endpoint for Honeywell thermostats.

1. Open the SmartApp in the Smartthings developer web IDE, find line 125 and change the endpoint:

OLD LINE 125

atomicState.evohomeEndpoint = 'https://tccna.honeywell.com'

NEW LINE 125

atomicState.evohomeEndpoint = 'https://mytotalconnectcomfort.com/WebApi'

2. Press ‘Save’

3. Press ‘Publish > For Me’

After this, I reopened the Smart app on my device, and pressed the settings cog. I then pressed done (which I believe checks the authentication with Honeywell). Buoyed by this working, I then tried adjusting the heating in a room, which previously didn’t work for me, and now it does :slight_smile:

I will file this as a pull request to the github repo!


(Mitch Turner) #147

Not sure this will help, but wouldn’t work unless I selected all my modes. Under the the Smart app - My App - EvoHome connect - then set for specific mode - I selected them all and it seemed to allow me to change the temperature.

Not sure if this is the correct way but give it a try.


#148

I receive the following error java.lang.NullPointerException: Cannot get property ‘userId’ on null object @ line 684

Any hint, please?


#150

same error here. did you fix it?


(Richard James) #151

Help Please…

4:45:32 PM: error java.lang.NullPointerException @ line 1299
4:45:32 PM: debug Evohome (Connect): getCurrentSwitchpoint()
4:45:32 PM: debug Evohome (Connect): updateChildDevice(-1)
4:45:32 PM: debug Evohome (Connect): poll(-1)

Its been mentioned above in Dec '16 but i couldn’t see any comments on the fix. All devices are registered in the ST app but no temperatures or statuses are read.

Bump… I’m getting exactly the same error

Thanks for your hard work.


(Tobey Ljungberg) #152

Is this still working?

I’m thinking about getting an evohome kit but want to make sure this integration is still working fine.

The thread has gone a bit quiet.

Thanks


(Tobey Ljungberg) #153

Also is DHW supported also?


#154

hi. did you finally install this smart app? i receive the same error. thanks


#156

Did you found a fix for it?

I also get:
error java.lang.NullPointerException: Cannot get property ‘userId’ on null object @ line 684


#157

I fixed it. The app can’t extract the userid which is a number ######. Once you have it, you replace line 689 with ‘userId’: ‘######’. Ask HoneyWell for the user ID associated to your Evohome account. Good luck!


(michael w) #158

High would you be able to tell me can I operate this without having the main Honeywell controller an using just the evohome trv valve by themselves?
Just new to this side of things
Thanks


(michael w) #159

Hello could you tell me if I need the Honeywell stat controller or can I run the TRV s with the smart app and handler
Thanks


#161

Hi i cannot update the temp from Smartthings this is the error i get:

10:10:33 AM: error Livingroom Heating Zone (Evohome): setHeatingSetpoint(): Error: Unable to set heating setpoint.
10:10:33 AM: error Evohome (Connect): setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request


(Tom Green) #162

This is the magic step !! Thanks !!


(Fred) #163

Hi everyone, looking for some help. I’ve had this Evohome SmartApp installed for over a year and though I wasn’t using it to control my evohome I could see the change in status of each zone in Smartthings and recently I started using webcore to send me notifications when my zones start and stop heating. But I noticed last week I stopped receiving the notifications and when I checked my evohome zones in Smartthings they seem to have lost connection with my evohome system and are not displaying their correct current status. When i look in the IDE my thermostat devices haven’t had any events logged for 5 days so again points to something going wrong in the last week and I can’t figure out what.

I tried removing the SmartApp via the ST app and I get an error and via the IDE it says the app is in use by users so can’t even delete and try a reinstall. Anyone know what might be wrong and what I can do?

TIA


(Bryn) #164

Hi

Ive installed this but cant seem to get any control with it. It appears as a device but i have no buttons or interface for me to do anything. Can you please help and tell me what ive missed or is this now dead in the water?

Thanks


#165

Seems to have stopped working for me too after at least a year being rock solid.
Tried installing uninstalllling etc.
All zones show up but are yellow with ??? On them and no commands work.
Any insight @zcapr17?
This integration is much better than the beta official which hasn’t progressed in the same time.
Really hoping to get this working again!