SmartThings Community

[RELEASE] Honeywell Evohome Integration

honeywell
thermostat
climatecontrol
smartapp_hvac
dth_hvac

(Roy Donaldson) #41

I had to get UK support to remove it for me.


(codersaur) #42

@Joe-UK, any ideas what might be causing this? I haven’t been able to replicate it, but keen to fix it as there are several people with this issue.

To anyone struggling to remove a device, as a work-around, I’ve found in the past that if you change the device type in the IDE to something simple like a Simulated Switch, this usually allows you to remove it.


(Iain) #43

In case anyone missed it in another thread the official Evohome support was released prematurely along with some US Honeywell integrations and has been pulled again in order for them to finalise it.
Now coming ‘soon’ again, but apparently it will continue to work for anyone who installed it already.


(codersaur) #44

For anyone who grabbed the prematurely released version, how does it compare to the beta? Have they sorted out the device commands and/or added anything new?


(Gerry) #45

I still get the error i managed to delete the device handler but cannot delete the device any help please

No signature of method:
script1463057969790441918491.removeChildDevices() is applicable for
argument types: (java.util.ArrayList) values


(Gerry) #46

I also get this error trying to delete the smart app EVOHOME

This SmartApp can’t be deleted at this time because it is installed by one or more users


(Arnoud) #47

I was not able to get into the beta program anymore, so I cannot compare it to that version.

But this is how the thing looks with my Single Zone thermostat:


#48

Doesn’t look like it based on the previous post! Still pretty useless then I’m guessing.


(Myles Gray) #49

Is there an update with hot water zones support?


(Chris) #50

Just back from hol, I seen the official UK release email, deleted the Beta and tried the new app to find it doesn’t work with my multi-location setup. Then seen the later email saying it still wasn’t supported in UK.

I could scream- another hour+ lost messing about breaking the bits of Smartthings that do work- Smartapps deleted, 12 beta heating zones, etc.

PLEASE can we get a roadmap and more structured documentations of released features for UK. I’m really losing patience trying to second guess what to spending time on


#51

Just wondering what is not working in the UK compared to US. I am using the UK model and it is working for me


(Richard James) #52

Hi - I’ve just had a go at installing this and I’m trying to test it and get error in the web log:

java.lang.NullPointerException: Cannot invoke method poll() on null object @ line 400

The smartthings app just crashes. Any ideas what could be wrong? I’ve double checked all usernames and the password. I’m in the UK.

Thanks for taking the time to create this - it’s appreciated by all.

Richard


(Chris) #53

I simply don’t see all my locations- only one with a single zone stat comes up


#54

I dropped the official supported Evohome release as it has no documentation and you have only one central thermostat to rule them all and installed this great home made version.

Two feedbacks (as out of the box experience):

  1. When you launch the connect app the Windows temperature value is set to 5.0. This value is not accepted (maybe regional setting of the phone?) Instead I changed value to 5 and it is accepted
  2. Naming of the different zones. Each name starts with the customized name followed by “Heating zone” . The problem this way is that all the thermostats are listed across the device list as this list is alphabetically sorted. It might be better to name it Zone followed by customized name.

Issue?
I can see data being polled from the thermostat which is a good thing. But when I try to set a mode I can see following error in the event log:

error Woonkamer Heating Zone (Evohome): setThermostatMode(): Error: Unable to set thermostat mode.
info Woonkamer Heating Zone (Evohome): setThermostatMode(Mode: off, Until: -1)

The same if I try to lower temperature from the device (thing itself):
‎13‎:‎35‎:‎16: error Woonkamer Heating Zone (Evohome): setHeatingSetpoint(): Error: Unable to set heating setpoint.
‎13‎:‎35‎:‎16: info Woonkamer Heating Zone (Evohome): setHeatingSetpoint(): Setting setpoint to: 18.

I have looked at the code but not sure why the if statement is not working (maybe related to temp value that was not accepted at install?) and changed the log out to add some more parameters, the log now shows:
device.label:Woonkamer Heating Zone (Evohome) state.zoneId:null setpoint:18.5 untilRes:Thu May 26 20:30:00 UTC 2016: setHeatingSetpoint(): Error: Unable to set heating setpoint

Weird that state.zoneID = null


#55

Is this supposed to work in the UK?
Doesn’t work for me, I get error when I hit Done during install and this is in the logs (I deleted the actual token values):

2:32:07 PM: error Evohome (Connect): getEvohomeUserAccount(): Error: e.statusCode 400
2:32:07 PM: debug Evohome (Connect): manageSubscriptions()
2:32:06 PM: debug Evohome (Connect): authenticate(): New evohomeHeaders: [Authorization:bearer W0…, applicationId:b013aa26-9724-4dbd-8897-048b9aada249, Accept:application/json, application/xml, text/json, text/x-json, text/javascript, text/xml]
2:32:06 PM: debug Evohome (Connect): authenticate(): New evohomeAuth: [tokenLifetimePercentThreshold:50, expiresAt:1465223525472, tokenLifetime:3599, authToken:W0…, lastUpdated:1465219926472, refreshToken:rO_v-…]
2:32:06 PM: info Evohome (Connect): authenticate(): New Auth Token Expires At: Mon Jun 06 14:32:05 UTC 2016

Checked username and password a few times and are correct.

I also had the error caused by 5.0, probably should default to 5.


#56

@zcapr17 Server returns http 400 with this payload:

[{“code”:“UnsupportedClientVersion”,“message”:“Values provided by API aren’t supported by client or field filled by client is not supported.”}]


(codersaur) #57

Sounds like they’ve updated the API. I’ll take a look when I’m back in the country on Friday.


#58

So is this working with the UK honeywell connected thermostats? when I tried it earlier I increased the target temperature but it never seem to set.


(Kevin [Yorkshire UK]) #59

Does this now include the hot water functionality ? Just about to get my evoHome system next week and so keen to install this.

Have given up on the official version ever making it to release.

K


(Steve) #60

Does this still work for people?

I have managed to get it installed, reading the temps, but it wont let me set any set points, or change modes…

14‎:‎39‎:‎17: error Bathroom Heating Zone (Evohome): setHeatingSetpoint(): Error: Unable to set heating setpoint.
14‎:‎39‎:‎17: info Bathroom Heating Zone (Evohome): setHeatingSetpoint(): Setting setpoint to: 12.5 until: Wed Oct 05 19:00:00 UTC 2016

‎14‎:‎45‎:‎56: error Bathroom Heating Zone (Evohome): setThermostatMode(): Error: Unable to set thermostat mode.
14‎:‎45‎:‎55: info Bathroom Heating Zone (Evohome): setThermostatMode(Mode: custom, Until: -1)
‎14‎:‎45‎:‎52: error Bathroom Heating Zone (Evohome): setThermostatMode(): Error: Unable to set thermostat mode.
‎14‎:‎45‎:‎51: info Bathroom Heating Zone (Evohome): setThermostatMode(Mode: away, Until: -1)
‎14‎:‎45‎:‎48: error Bathroom Heating Zone (Evohome): setThermostatMode(): Error: Unable to set thermostat mode.
‎14‎:‎45‎:‎47: info Bathroom Heating Zone (Evohome): setThermostatMode(Mode: auto, Until: -1)
14‎:‎45‎:‎36: error java.lang.NumberFormatException: For input string: “null” @ line 810