SmartThings Community

[RELEASE] Honeywell Evohome Integration

honeywell
thermostat
climatecontrol
smartapp_hvac
dth_hvac

(Chris) #21

Excellent development!

I have a singlezone and a multizone registered at Honeywell as two separate locations- the official app only seen the single, your app brings in zones from both!

I don’t want the single zone (remote) in my home site so I’ve deleted that zone- I don’t know if some though is need to make sure “off” actions, etc only apply to one registered location.

I have DHW, happy to help and give a “test” zone if needed…


(codersaur) #22

Good to know multi-location installations are working! :slight_smile:

Note, at the moment, if you change any of the SmartApp settings, it will re-authenticate and recreate the zone you don’t want, so you would need to delete it again. However I plan to improve this in the future to allow locations/controllers/zones to be explicitly included or excluded.

Regarding mode actions (i.e. off, economy, dayOff, etc), these are applied to a controller, and hence all zones associated with that controller. Therefore, if you apply a mode to your home controller it shouldn’t affect your remote zone, which will be associated with a different controller.

Re hot water zones, I’m making good progress and should have an update in the next few days.


(Paul Ockenden) #23

Can someone using David’s code on Android please post post a screenshot of a zone, particularly the big tile at the top. It’s looking very different here on iOS and Android, but I don’t know whether that’s down to something dodgy at my end, or whether it affects all Android versions.

Ta.

P.


(Roy Donaldson) #24

No idea how to post a picture on here, but see if this works:

https://goo.gl/photos/eqxYKW57krzVoQGC9


(Paul Ockenden) #25

That’s great Roy - at least it shows that the problems aren’t just on my device!

P.


(codersaur) #26

LOL! Then it appears that multiTiles with type=“thermostat” are totally messed up on Android. I suggest you raise a support request to SmartThings about this.

It’s possible that removing the string type:"thermostat", might help…

I only have iOS myself, but if anyone with Android develops a cleaner tile layout, let me know and I’ll incorporate it into the code on GitHub.

Alternatively, if anyone wants to donate an Android phone… :grin:

Note, you can fix the question mark fairly easily by editing the device code, see discussion earlier in the thread.


(Paul Ockenden) #27

Thing is, the big tile looks fine in the room view.

It’s just b***ered when you click the zone

I might try to find some other ‘thermostat’ smart apps, and see how they behave. Although, thinking about it, it’s not really apps, is it…


(Chris) #28

Here we go…

Copying device handler raw gave temp as ?, copied “formatted” code from Chrome and working fine…


(Paul Ockenden) #29

I’ve been able to get the heating mode to show, but I can’t get rid of the unwanted buttons and the secondary humidity icon in the bottom left:


(Paul Ockenden) #30

Some people have suggested changing the big tile from Thermostat to Lighting. I tried that, but lost the background colours.


(codersaur) #31

It now says here:

Currently there is a parity issue between Android and iOS platforms in regard to how multiAttribute tiles work. There is currently work being done on the Android platform to address this. In the meantime, some things stated here about multiAttributeTiles may not work as expected on the Android platform.

For the time-being I suggest using type:"generic" on the multiTile for Android users. And changing key: "OPERATING_STATE" to key: "SECONDARY_CONTROL" on the tileAttribute. However the background colour will no longer update based on the operatingState.


(Paul Ockenden) #32

They’re not kidding, are they!

I wonder whether this is one of those ST “don’t hold your breath” things…


(Paul Ockenden) #33

Looks like the latest Android App update has fixed the problem of the up and down buttons and humidity icons appearing in the main tile. But I’m not seeing the status line either - although perhaps I messed around with the code! I need to do a refresh against the latest release.


(Roy Donaldson) #34

I’m trying to remove this app to have a play with the official one that was released to compare them, but I keep getting the message ‘An expected error has occurred’ whenever I try to remove the SmartApp, or the last heating zone.

Roy.


(codersaur) #35

@PailOckenden: hint taken. I’ll release an updated version with hot water support and a bunch of other stuff later this week.

@Roy_Donaldson: Failure to remove is usually down to other SmartApps being subscribed to the Evohome devices. The IDE will tell you if anything is using the devices. Note, there is no specific need to remove my SmartApp and devices, they will happily co-exist with the official ones.


(Roy Donaldson) #36

I get this error when trying to remove the last zone:

“14:25:35:
error
groovy.lang.MissingMethodException: No signature of
method: script1462882558681699476382.removeChildDevices() is applicable
for argument types: (java.util.ArrayList) values: [[Study Heating Zone
(Evohome)]] @ line 105”


#37

I tried to copy/paste the smart app (UK version does not support Github integration) and get following error:
No signature of method: script1462894237356116508522.metadata() is applicable for argument types: (script1462894237356116508522$_run_closure1) values: [script1462894237356116508522$_run_closure1@21b6aa07] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)


(Joe) #38

SmartThings is happy to say that we’ve released our Honeywell evohome integration via the Marketplace in the SmartThings app! We apologise for the lengthy wait for this integration! This was due to OAuth stability issues that would cause occasional disconnects, forcing a manual re-authorisation. Honeywell has recently made improvements to their API to correct for this. Please contact SmartThings support if you notice any issues with the Honeywell evohome integration


(Arnoud) #39

As I also said in another topic, the Honeywell Round Connected (I have the ‘Modulation’ version) works with the latest ST app now!

Oh, I see the thermostat is called Honeywell “Single Zone Thermostat” in English speaking parts of the world?


(Gerry) #40

I cannot remove the app any ideas I get the same error when trying to remove the Last room