[RELEASE] Honeywell Evohome Integration

just tried to get this working, but still getting the dreaded “checking…” . Maybe i have not installed it right, but have tried deleting all the devices. Hoping it works for others.

You have my word that this bloody thing was working on the outside card last night. They must have changed something again!

Hi outside cards works on iOS but not on android

Thanks again, @Andremain. Sadly enough, I still get the same error. Deleted the smartapp and the dth again, followed your instructions, but after reinstalling the smartapp, it still says network error, check your connection after typing in my usern and passw.
Screenshots look awesome, though, congrats!

That is strange. Did you get the latest ios app, as it is not available for android yet.

Too bad! I really hoped you would get it working this time :confused:

I think I have a problem with the smartapp itself. I didn’t even install the dth yet and already get the same error. The smartapp code was not updated now, right? github says it was updated “last month”.

I don’t understand what issues people had with the original Codesaur’s integration.
What problems did people experience?

My EvoHome integration has remained working all the way through from Classic to New apps on ios without any changes on my part.

I can still set target temperatures, and see actual temperatures. Can’t people just start from scratch with the original code? Or is there some kind of enhancements I’m missing out on?

What issues or enhancements made people start using modified code post Codesaur’s integrstion?
I’m in UK. Using UK purchased HR80’S the touch screen thermostat with separate Internet connection hub, and the EvoHome App. https://apps.apple.com/gb/app/total-connect-comfort-intl/id783653368

Are the problems for people with different hardware to me?

No. I did not change something lately. That should have worked btw

That is indeed strange as the api endpoint from the original app has been changed. So you should not jave been able to communicate with the api and should have gotten an error. As for the dashboard card, smartthings changed somethings which broke it.

Yes I have the latest iOS app

Where does the layout of the thermostat card come from, I have a cooling control and a fan control card.

I’m also using the original Codesaur integration in the new ST app. The only thing not working for me is the issue with the outside card permanently showing ‘Checking Status…’ (however this works when viewed via my SharpTools dashboard so not a big problem).

Beyond that it’s just formatting - the unnecessary Cooling Control and Fan Mode elements in the thermostat cards, and the fact the Mode options don’t match the Evohome quick actions (although this latter issue can be bypassed when using WebCore).

Being able to get a current HW temp readout is the key thing I’m missing.

1 Like

How do you get the hot water temp to display? Is there a DHW device handler?

Hey did the integration stop working yesterday?

No, the old integration continues to work as before without problem. Not sure if it’s relevant but I’m on Android and in the UK. The only other thing to note is that when I originally installed Codersaur’s webapp I had to make a couple of simple changes to links in the code - which are detailed somewhere near the beginning of this thread - which I seem to remember related to accessing a particular version of the Honeywell TCC app as the default wasn’t working for everybody.

As far as I know there is currently no way to query/display the HW temp. I think a device handler was in beta when this project went on hold, Paul Ockenden mentioned testing it back in Nov 17, but don’t think it was ever published which is a shame.

I can control the HW using virtual switches and Alexa - so I have a dashboard button that puts the water on for an hour if it’s needed outside the usual routine, and my Away routine turns it off - but not being able to display the temperature or use its current value in routines is frustrating.

Thanks. I know there is no DH for DHW but if you look at Andremain’s last picture there is Hot Water at 28 degrees C. I was wondering how Andremain achieved that but no response on here yet.

Hadn’t spotted that but would also be interested…

Yeah sorry about that! That is actually a virtual switch with alexa. Also i am actively working on fixing this integration. Howerver as i am not a developer, this could take a while…