[RELEASE] Honeywell Evohome Integration

Guys i did manage to get it to work (mostly) but the card or tile, which i don’t know what it is called always shows checking status. I tried modifing the device handler but nothing seemed to make any changes.
Did anyone manage to fix that?

Evohome will be getting a big firmware update in the next couple of months.

The first of 2 betas for this was released in the UK in Mar with the second last month. There are some interesting new smart features such as warm weather shutdown and cold weather boost.

Nice features but no Smartthings integration :frowning:

Afraid not. Still only the unofficial route but at least we know that they’re still actively developing it. There are a few of the developers active on another forum. I’ll ask the question about future plans but someone asked the same about HomeKit and didn’t get a response.

For anyone interested, here is a link with a modified code of Codersaur that kinda works with the new app. Yes the card in the dashboard is not working.

1 Like

Thanks a lot for your efforts with this. Should I just paste it over the previous versions of Smartapp and Device Handler?

I can’t see why that shouldn’t work.

1 Like

@Andremain, thanks!

The devices are working in ST, I can change temp etc, but it still shows the “cooling temperature” (which isn’t useful for evohome) and from the homepage of the ST app it shows “updating status…”.

Any suggestion on how to fix it?

No i am trying to learn how to use an api so that i can make it work, sinse no one else bothers to do it. It will take time though…


@Andremain, thanks for your effort!

I still couldn’t make it work. I’m getting an error message after entering my un and pw in the smartapp: there was an error while connecting, check your connection.
I’m using a US type Smartthings Hub in Europe, and my Evohome usern and passw are working fine on this site:
Any ideas?

Non to be honest. It should just work. The url you are trying to access is the same as the one i am using.

Too bad… thx anyways!

Maybe it has something to do with the authentication? There is EMEA region mentioned in the code. I am using a US type smartthings hub from Europe, maybe it recognizes me as a US user?

I don’t think so. I think all that matters is the evohome endpoint.

Hey, there was a mistake in the smartapp. Try removing it and manually installing both again.

I do have to say however that for me it now shows 0c temp and the state shows as heating always, even when off. Setting the temperature however, does work.

I think I must be misunderstanding something here.
I have Honeywell’s HR80 valves and Total Connect.

I have used Codersaur’s device handler and smart app for years. It all worked fine with Smartthings Classic and it all continues to work fine with the new Smartthings App. Temperature displays, temperature controls (+ & - buttons). There was one tiny display issue in the app which was easily resolved years ago.

What was the advantage to the modified code post Codersaur’s version? Was it additional functionality or some kind of fix?

Should I avoid the new code or is there additional functionality?

Thanks for your effort!
Deleted both the dth and the smartapp, reinstalled them from the github. Still get yet same error message after trying to login with the smartapp: there was an error during connection. Check your network connection and try again. Bad luck! :frowning:

Too bad! I really hope that this year evohome (TCC ) will be added to the european servers in Honeywell Home making us able to finally officially link it to ST

I have finally managed to get the integration working. please use my github page to get the integration running. First copy the smartapp to the ide, self publish it, open the smartthings app, go to smartapps, find the Evohome (Connect) app, open it, add your username and password and run it. Once done, a new device will appear inside smartthings. Then copy the evohome dht from my github page, and add a new device handler inside the ide. Then using the ide, change the evohome device that has been created to use the device handler you have just added. The integration should now work!

@cscsn giving you a shoutout. I hope you manage to get this working.

Also, proof that it works!