[RELEASE] Honeywell Evohome Integration

How about using a lux sensor with webcore with logic such as when screen & lights are out for more than 5 minutes in the early hours change the heatingSetpoint/scheduledSetpoint to 15 degrees?

can anyone help me.

I have installed the App and Device handler.
Updated the URLS
Updated the Auth scope

All devices added but I get the following error:

From the Device Handler

11:24:47 AM: error Bathroom Heating Zone (Evohome): setHeatingSetpoint(): Error: Unable to set heating setpoint.
11:24:47 AM: error Evohome (Honeywell): setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request

From the main app

1:24:47 AM: error Evohome (Honeywell): setHeatingSetpoint(): Error: groovyx.net.http.HttpResponseException: Bad Request

Does this not work with the new smartthings app? I installed and it is working, however on the homescreen of the app the rooms “checking status” and it doesnt display temperature. But when I tap on it I can edit temperature and stuff. Just that it doesnt show temp on home screen. Is this how it works on the new app. Do I have to use the classic app to make use of this smartapp?

Hi Did you get anywhere with this issue as I have the same issue?
Thanks

Thanks for the development.
After installing the smartapp, I can’t log in. It says network or server error. try again later. un and pw are correct. What am I doing wrong?

Recently (last week, the 10th April I think, based on data in infulxDB) I no longer see setpoint, optimisation etc getting logged to influx.
It still gets temperature through.

I notice in influx smart app settings that the evohome devices are no longer showing in the thermostats section of device selection. they are all still there as temerature sensors though.
Has anybody else seen this, is there a fix?

I had this a couple of weeks ago and it was due to the batteries being flat in a HR92 that I wasn’t using but which was still connected.

Thanks, I’ll check but do you mean one HR92 had falt battery and all stopped reporting?

Still no success. “error saving page” message on smartapp login attempt. I can’t see the devices.
Modified everything according to the instructions above (server address, emea login). I am in Europe using a US Smartthings V3 hub. Maybe that is the cause? Any ideas?

Not all. It was strange that a flat battery in one zone caused a couple of others to stop recording.

Is anyone seeing the following error when sending the command “Set Heating Point”: java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds:

It has started happening today.

Ian

I sent a Github chnage proposal. Hopefully we can have the changes integrated on Github. Kudo’s for change advise, it is working for me now.

Any way for this to show temperature on the New Smartthings app?

I’ve been happily using the Evohome integration for years, but have been tinkering recently with change of circumstances. What I’m trying to do is set 2 schedules on the Evohome controller, the “normal” one for when we are home, and the custom schedule when we are both out but not far away, and likely to be home soon. I cannot get Smartthings to resume “normal” schedule, either with a Webcore piston, or even using the button on the app (I know this applies to the system, not a specific zone, and that’s what I want it to do, the app shows updating and following schedule, but doesn’t update the setpoint). Even though I’d been using this integration for years, I don’t recall trying to use the resume function, so I don’t know if this has never worked for me, or a more recent issue. Does anyone use the resume command successfully, or have any ideas why this might not be working please?
Thanks for reading!

How about enabling Economy mode as you leave instead. I think you can enable economy mode for a temporary period of time and turn off/cancel economy on arrival home.

I know it’s not the same as switching in and out of a custom mode, but perhaps simpler to implement.

Hi Bill, thanks for your suggestion, I will take a look at that and see if it responds differently. I assume it would still be a resume command when we arrive home?