SmartThings Community

[RELEASE] Honeywell Evohome Integration

honeywell
thermostat
climatecontrol
smartapp_hvac
dth_hvac

(Bill) #186

Excellent.
Nothing wrong with the original code.
Some changes either from Smartthings or Honeywell seemed to upset things. Glad you’re up and running again.


(paulhorti@hotmail.com) #187

Good news. Now, has anyone seen a hot water integration for evohome?


(Paul Ockenden) #188

David did create a version with Hot Water support - I’m running a test version here.

Obviously I can’t release it - but maybe David could?

P.


#189

Thanks for the updates for how to fix the recent problems. I can confirm it’s working again for me also after reinstalling (albeit with the prior correction about updating the API endpoint). Hoping Codesaur is still supporting ST overall though, his DHs for Fibaro, Greenwave & Evohome are literally the only reason I continued with Smartthings. Samsung should put him on the Payroll!


#190

Thank you Paul, this was the missing piece for me. I have reinstalled everything from scratch before and didn’t work until I made a change in settings. It was enough to rename the smart app.


(David Jacobs) #191

My Evohome stopped working through this a little while ago. To get it back I followed Paulih method and all seemed to work as expected :grin: However I tried boost and suppress separately and get the following error "c6814da5-4aae-494d-9562-33867e76038f 3:50:56 PM: error java.lang.NumberFormatException: For input string: "null"
I do NOT have my ID on line 689 as suggested earlier in the forum. Could this be relevant, given other things work?
advice/help appreciated


(David Jacobs) #193

Resolved it. Seems line 689 is irrelevant. I had forgotten to check the settings in the individual devices. Since recopying it had lost “setpoint duration” .


#194

This works really well thanks v much


(Byteguy) #195

I’ve tried using Google home with evohome via this integration, but its doesn’t work. If I ask Google home what the temperature in a room is, it gives a “I’m afraid there was an error…” message.
The live logging in smartthings shows for "google"
fb6714c2-47e6-40a8-9be6-be511cbdcfa0 3:52:04 PM: error java.lang.NullPointerException: Cannot invoke method getFloatValue() on null object
fb6714c2-47e6-40a8-9be6-be511cbdcfa0 3:52:04 PM: debug queryDevice(e391c06e-c831-4638-adba-85e6093ddebb)

Anyone have any thoughts on what google home is trying to read and why its getting a null object from this?


(Adam Mills) #196

Anyone notice an Evohome update this morning (UK). I now have a new hot water on symbol and boost function. Not seen anything more. Anyone able to find release notes?


(Luca Avalle) #197

Solved the problem for me!
I also have included all the zones


#198

Hi, Sorry total nube here I’ve followed the guide and I’ve got as far as all 12 of my zones showing in SmartThings however no temperature is shown for any zone ?? The newer SmartThings app just shows checking status on each zone ?

Any help would be much appreciated, I can’t see why Smartthings dosnt officially support evohome !!


(Jonesyx) #199

Just want to say thanks and give a virtual high five to Codersaur for this ace work!

Does anyone have a copy of the Hot water handler?

Thanks
Mike


(Jakub Macoun) #200

I might be doing something wrong (I’m new to Smartthings) but this does not work for me. In logs, I see HTTP error 400 resulting in NullPointerException while authenticating. I guess that API URIs are outdated?


(David Jacobs) #201

There was a Honeywell change about 9 months ago that stopped it working but someone found a fix somewhere on here (youll have to hunt), think it was a simple change to some of the code. Ive just tested mine and it still works fine.


(Jakub Macoun) #202

Sadly, the changes I found in the topic are not enough. Changing endpoint and getting my userId was not enough, it’s still not working.
I found official Evohome API documentation and it does not fit to the SmartApp code at all.


(Sal Marano) #203

your are not doing anything wrong, the app is the issue along with ST inconsistency this is still a problem several times a week it disconnects from ST and you cannot control the thermostats. ST and Honeywell need to fix it.


(Jakub Macoun) #204

Well I actually managed to make it working by deleting everything and re-adding the device handler and SmartApp (with endpoint modification and userId adding). Still, as you said, this needs some serious work…would do it myself if I knew Groovy better.


(Bryn) #205

Ive finally got around to installing this again. On the face of it, its looking good. Shows my zones, shows the correct names and temperatures and updates as the zones update. However i have no control. I cant adjust anything from my smartthings app.
I may be really dumb and missed part of the set up but no buttons do anythig and i have no arrows next to my zone temperature to adjust it!
Thanks for help in advance


#206

Hello folks

Did this code ever get as far as having Hot Water added? I have this setup in three implementations and it works OK with the exception of being able to track and control hot water. This would be really really helpful to have.