[RELEASE] Honeywell Evohome 2020 Integration with new Smartthings app

So been a bit preoccupied with my new job. I installed the Hotwater handler and its not showing up. I am on v3.4 through out. even after changing settings for it to poll. is there a trick to it?

Strange. it should work… Do you have the hot water addon on your system?

Deleting and recreating solved it. Not sure why. Need to test out the features now.

Glad you worked it out

1 Like

Hi Andremain,

Thanks for this! Great work! I used the old one and have been a biy disappointed as it was not showing the temperature on the new smartthings app dashboard. Installed and all working fine. The only issue I find is that it takes a long time to update the set temperature on the app, if I change the temperature, for example from Alexa or the app. If I ask alexa to change the temp, it changes instantly on the Evohome app, but it takes a long time on Smartthings app. Interestingly, Alexa is linked to Evohome by smartthings, yet it doesnt change the temp on smartthings but does it instantly on the Evohome App!

1 Like

Thanks. I don’t think i will continue updating it though as the whole thing needs to be rewritten in node.js because this one will be dropped by smartthings

@Andremain thank you very much for your effort.

Unfortunately I run into an issue, and for me it dosen’t seem to work.

I will attach some logs/screenshots, maybe you can point me on the right path.

LOG:

9:10:08 PM: debug Evohome (Connect): poll(-1)
9:09:08 PM: debug Evohome (Connect): updateChildDevice(-1)
9:09:08 PM: info Evohome (Connect): getEvohomeSchedules(): Getting schedules for all zones.
9:09:08 PM: info Evohome (Connect): getEvohomeStatus(): Getting status for all zones.
9:09:08 PM: debug Evohome (Connect): getEvohomeStatus(-1)
9:09:08 PM: debug Evohome (Connect): poll(-1)
9:08:08 PM: debug Evohome (Connect): updateChildDevice(-1)
9:08:08 PM: info Evohome (Connect): getEvohomeSchedules(): Getting schedules for all zones.
9:08:08 PM: info Evohome (Connect): getEvohomeStatus(): Getting status for all zones.
9:08:08 PM: debug Evohome (Connect): getEvohomeStatus(-1)
9:08:08 PM: debug Evohome (Connect): poll(-1)
9:07:08 PM: debug Evohome (Connect): updateChildDevice(-1)
9:07:08 PM: info Evohome (Connect): getEvohomeSchedules(): Getting schedules for all zones.
9:07:08 PM: info Evohome (Connect): getEvohomeStatus(): Getting status for all zones.
9:07:08 PM: debug Evohome (Connect): getEvohomeStatus(-1)
9:07:08 PM: debug Evohome (Connect): poll(-1)

When I do login, I’m getting an error:

Any ideas what I have done wrong? As I’m not seeing my zones/thermostats in st app.

by the way, the login seems to work (I think) I quadruple checked the login creds.

and I’m getting this in logs

debug Evohome (Connect): getEvohomeStatus(-1)
debug Evohome (Connect): poll(-1)
info Evohome (Connect): manageAuth(): Auth Token is okay.
debug Evohome (Connect): manageAuth()
debug Evohome (Connect): updateChildDevice(-1)

and

9:43:36 PM: debug Evohome (Connect): manageSchedules()
9:43:36 PM: error java.lang.NullPointerException: Cannot get property ‘userId’ on null object @line 805 (getEvohomeConfig)
9:43:36 PM: info Evohome (Connect): getEvohomeConfig(): Getting configuration for all locations.
9:43:36 PM: debug Evohome (Connect): manageSchedules(): Re-scheduling manageAuth()
9:43:36 PM: debug Evohome (Connect): manageSchedules(): Re-scheduling poll()
9:43:36 PM: debug Evohome (Connect): manageSubscriptions()
9:43:36 PM: debug Evohome (Connect): authenticate(): New evohomeHeaders: [Accept:application/json, application/xml, text/json, text/x-json, text/javascript, text/xml, Authorization:bearer looong-token, applicationId:some-id]

Hello @Kowalski. Sorry to see that you are having issues. Make sure you are using the latest version of the integration as the one before it had a bug where if you did not have hot water installed, installation would fail.

I have the latest one, I mean I’ve just discovered this topic 3 hours ago :slight_smile:

Oh ok then. Did you correctly added the app and dth and published them?



I guess so, I just don’t see anything in ST app.
but in logs it seems to do something (as I showed above)

LE:

in logs seems to give me token, and stuff… so somehow it connects to them…

Wait did you performed the original setup? Did it create your devices?

If so did you read the original post? You need add some values inside the app and the devices to able to work properly.

It dosen’t create my devices…
I’m at:

The devices will be added to smartthings. You need to go to each zone (device) tap the 3 dots and tap settings. Under duration type 60, boost 22 and suppress 15. At the until option select your preference and go back to the device.

If you have a hot water device. Open it tap the 3 dots, settings for the duration type 60 and the at the until option select your preference and go back to the device. You are now ready to use the integration.

I also assume tha you went to the favorites tapped the + add smartapp scoll to the bottom and try to login.

Yes, that’s where I have the above logs from.

If you are using a credential manager, try to type them in this time. Also i assume you are the uk right?

I’m from Romania, but I can login to UK without an issue.

No I don’t use credential manager

I don’t know why you are getting this error. Maybe you are missing something from the installation. Please delete the app and dth and install it again with my instructions above. Or maybe the latest smartthings update messed something up.

I have deleted and recreated the whole setup 3 times, as I thought I might missed something.

But unfortunately it seems that someone changed something somewhere, it may be smart things, with the latest updates, or maybe something on Honeywell side.

If you guys gonna fix this, please give me a tag to try it again.

I’m aware that a new update/fix of this implementation may never happen, but I’m hoping that you guys will find some spare time to fix it.

1 Like

@Philip_Street1 how are you.

If i remember correctly you are a developer. Any chance you could help me as i am not a developer to make an evohome integration using the new smartapp connector integration.