[RELEASE] Honeywell / Ademco Vista 20P Integration

are we able to use the keyswitch functionality with the EVL like konnected can do? i think its just a programmable output

A couple of new questions after playing around over the weekend.

  1. I deleted and reinstalled the Honeywell app within Smartthings, and re-ran discovery a few times. On one of the runs, it added 100+ unused sensors to smartthings (that I ended up deleting manually because I was getting errors with the delete option). Has anyone else seen this?

  2. At some point, I had a good install and my 18 sensors actually initialized (meaning they showed correct status instead of “checking”. That happened only once. Things like water sensors, smoke sensors, C02, which are harder to trip, are showing "checking’. Any thoughts on why it would initialize on one of my discovery runs, and not the others? Is there any way to force initalization?

  3. What is the integration with Smart Things Home Monitor supposed to do? Most of the time it has done nothing for me. Most recently, my SmartThings IDE logs indicated that it was going to update status in STHM, but it didn’t actually do it. It shows nothing about it in the server.log What is the expected behavior (when I check the option in the Honewell app), and what is it doing for most people? Is it supposed to be a one way sync (from Evnvisalink to STHM, or bi-driectional from STHM back to Envisalink)?

  4. I ended up creating 3 virtual buttons to include in my Sharptools dashboard (ARM AWAY, ARM STAY, and DISARM). I created 2 webcore scripts to handle sycing the 3 buttons to Envisalink; (one to handle when i press the buttons on the sharptools dashboard another to handle when I use the alarm keypad). Do I need these buttons/pistons if I am using Smart Things Home Monitor? From the experience here, Is Smartthings Home Monitor more trouble than its worth right now?

Thanks @Nathancu. I got alarmserver running last night. I was able to integrate the Node-Red PIN UI flow without any issue. However, I dont know which option I should use to integrate the honeywell alarmserver with Smartthings. It seems there are a lot of different smartapps and device handlers (like the most recent direct connect option). I dont know which ones would be compatible with the honewell version of alarmserver. Are they server dependent? Do you know? I posted a similar message on the alarmserver forum, so hopefully someone has the answer. I’d prefer to stick with stnp, but I’m also looking for a solution that will allow multiple clients to talk to my envisalink 4 (both smartthings and a node-red PIN GUI)

Regarding STNP, i did see some very strange behavior from the smartapp over the weekend (like creating a bunch of unused sensors). I have a different post with a number of questions in this forum.

Doug

1 Like

Never seen this happen. The only thing I’ve seen similar to this was when I had auto-discovery turned on while entering programming on the Vista panel. I ended up with a handful of false zones added to ST.

You shouldn’t need to repeatedly run discovery though, unless you’re having issues where not all of your zone devices are being created. I’ve seen that happen before, and I think it was because there were so many zones that the smartapp timed out. If you’re having that issue (I don’t know that 18 zones would be enough to hit the time out), I would put only the tough to trip zones in the config file, then use the auto-discovery to add the doors/windows when tripped.

There’s nothing in the code to initialize the values, so I don’t think it should be happening. The sensor DTHs need something like this added to them to force a value when they’re created:

def installed() {
  sendEvent (name: "contact", value: "closed")
}

It’s a relic from the old app. The new app broke this functionality.

This is probably possible. I don’t think STNP checks for the IP address where commands are coming from - it just checks for the right authcode. If you take a look at the smartapp code, the sendCommand method should have everything you need to build the http request. Uncomment the log line to see the path being passed to that method.

On your latest post, I think the other integration you were looking at is the one specific to DSC alarm panels. There may be others out there for the Vista panel but this is the one that most use. There’s also an Envisalink skill for Alexa, but I haven’t explored that option to know what it gets you.

Anything based on Groovy code (including this integration) likely will be obsolete by the end of the year, so the development that @TAustin has done on getting a Pi to work as a direct connected device is the direction that integrations like this need to be headed. His work has been on the DSC panel, so I don’t think it will work on your Vista panel without additional coding. I’m planning to look at what he’s done once work slows down for me in a few weeks.

1 Like

Theres a lot there to unpack that’s not specific to this particular build of Alarmserver, so to keep the thread on topic, Shoot me a DM - we’ll go through your scenario and I’ll pop a recap note into my post later if we come to any revelations the world should know. :slight_smile:

@philh30 ,

Funny you mentioned the Envisalink Alexa integration. I didn’t menition it before, but I had Alexa loaded on my phone (but never really used it). During the discovery run that had 100+ devices added to Smartthings, Alexa was popping up messages right and left during discovery, saying it discovered new zones. I wasnt’ sure if Alexa was the cause of the dormant zone, or if it was an effect of something wrong in discovery. However, I deleted Alexa on my subsequent runs, and it never happened again. I never manually installed an Envisalink skill in Alexa, and didn’ know one existed. But, I’m inclined to think it Alexa may have been at least partially responsible for the problem.

Yes, I saw the stuff @TAustin was doing, and it looked interesting. Glad to hear its on your things to look at, in terms of a similar approach for STNP.

Thanks for the tip on the HTTP call. I try that.

Hey Phil, I uncommented the log line for send command, as well as a few other log lines for headers and body, etc in the smartapp. The best I was able to get in the IDE was the Hex base 64 equivalent of what was already being logged to the IDE.

I did see the following entry in the server.log the following:

[2021-02-10T21:54:57.115Z] [stnp] ::ffff:192.168.1.25 GET /plugins/envisalink/disarm

(192.168.1.25 is my smartthings hub)

So I tried a simple http request from my Pi
http://192.168.1.28:8080/plugins/envisalink/disarm

Which logged this entry in server.log

[2021-02-10T22:45:25.888Z] [stnp] ::ffff:192.168.1.28 GET /plugins/envisalink/disarm

Promising, except I get back this…

[2021-02-10T22:45:25.888Z] [stnp] ::ffff:192.168.1.28 GET /plugins/envisalink/disarm
[2021-02-10T22:45:25.888Z] [stnp] Authentication error

Not sure if this is happening because it is expecting the GET to be coming from the smartthings hub IP, or if I need to somehow pass the Authentication string?

Thoughts?

If I can get through the authentication, I would just need to change the Envisalink plugin to accept an optional PIN parameter (otherwise read it from the config file as it is already doing)

That’s the correct path to hit, but t’s failing because you need to include the authCode (which you set in the STNP config.json) in the http request headers. I’ve never used Node-Red, but based on Set a request header : Node-RED you need to do something like the following:

msg.headers['stnp-auth'] = 'Your authCode';

It should just pull your PIN from the config.json once it gets past the basic authentication.

1 Like

Anyone have sensors that aren’t updating recently? The past week or so a lot of door sensors are not updating in smartthings. I even have a glass break sensor that is stuck open right now. I have had to open doors a few times to get them to update. I rebooted my pi and my smartthings hub and it’s still happening. This happened a few months ago too earlier in this thread.

Maybe this is due to some issues with server side processing with smartthings?

Anyone else?

Hi Phil,

Thanks again for your help. Adding stnp-auth to the header allowed me to bypass smartthings and execute the STNP fuction directly from a web-page.

My vision is to have a few hyperlink buttons (arm away, arm stay, disarm) on my sharptools dashboard that launch a PIN UI (that node-red screen). Then have the PIN UI call the stnp envisalink plugin (passing the PIN as an optional parameter).

This would mean some modification to the Envisalink plugin to pass in the PIN as optional (similar to how alarmserver is working now). In the short-term, I would be using that Node-Red PIN UI, but i can also envision future smartthings device handlers that are PIN enabled, like smart locks.

I’m not a developer, and not familliar with the tools, or syntax to make the change and debug. How could the PIN be passed into the envisalink plugin?. Would that require passing it as a parameter, or could it somehow be added to the header like the stnp-auth is in the header? If it is in the header, how do i access it from inside the code in the envisalink plugin function (eg disarm)?

I’m envisioning very simple logic, like "if PIN parameter is Null then look up PIN from Config file, else set PIN= Pin Parameter). If that could be added to the armstay, armaway, disarm, etc functions, it opens up a lot of possibilites on the front end.

Thoughts? In my case, I would be using the PIN UI inside my network only. Any concerns? Do you think others would see value in something like this?

Doug

1 Like

I had that a few weeks back but there were overall issues with ST at the time. I haven’t paid much attention recently, but just checked and a window shows open that’s definitely closed.

When you included the authCode in your Node-Red call, did it disarm your panel? I think the way the STNP Envisalink plugin is written, it shouldn’t need you to pass the PIN so long as it’s in the config.json.

every now and then my sensors will get out of sync. when checking the logs i’ll see a bunch of errors. usually a ST hub reboot will resolve the issue, at least for awhile.

Agreed. This is happening a lot more often than it did in the past. Anyone else having this issue? It seems to be doors more than anything…multiple doors and different types of sensors (sliding door and swing door).

HI group so i have the Alarm Decoder AD2Pi and have been using their ST app but since classic went away that has been broken.
Is this app updated to work with the new app or is there an alternative?

it does work but is no longer supported by the project creator (see latest edit in 1st post). others have taken the lead in updating things. afaik it’s still the best option to hook up a Vista system short of changing to konnected.

1 Like

Thanks to @philh30 for the direction to fix this stuck sensor.

I found that the values needed for the smoke DTH were ‘smoke’ and ‘clear’ . Tried ‘closed’ in the simulator and it looked good, but when published, it didn’t do the job.

After updating the DTH, update the sensor, changing the device type to contact or motion, save and then change back to smoke… The sensor should be closed/clear…

I switched from the AD2Pi and have enjoyed the envisalink with this code base. I liked the buttons for arm and disarm from the main panel, so I took the liberty to make some mods and added the buttons. Also I find the separate devices buttons make adding tests for armed in automation routines like webCore more intuitive. If interested, I can share the code.
Also, I enabled setting the contact state to closed during install, for contacts only.

please share, that irked me as well that i had to go cycle all 25 windows. prehaps add a button to setting to clear all contacts…

Anyone else just hate the Honeywell/Vista panel beeping for the Away exit delay and the re-enter alarm delay? They’re so harsh and give me anxiety when I hear them. I’m considering just never using Away mode and just sticking with Stay for the silent exit delay, but can’t do much to change the alarm delay for reentry.

Wondering if there are any keypads people use that are more pleasant. I have a voice keypad and a basic one. I imagine both could have to be replaced since they both sound the same.

The Entry/Exit beeping is configurable per keypad (at least on my Vista 20p). Find your programming guide and lookup “Keypad Programming Fields”. I turned it off on the keypad closest to the door but left it on the backdoor keypad so it was less loud when leaving.

In addition, if you push a number on the keypad after the beeping has started, it will mute for something like 10 seconds. That way you can get on the other side of the door and then hear the beeping continue so you know the system is still arming.

2 Likes