[RELEASE] Honeywell / Ademco Vista 20P Integration

Here is the error message I’m getting: java.lang.NullPointerException: Cannot get property ‘localIP’ on null object @line 340 (getNotifyAddress)

Any ideas?

For those of you having issues with the new app saying that the hub is not working or hub is missing or “Oops an error occurred installing the app, please try to re-install”.

I modified the app originally made by redloro and then later modified by philh30.

This update should fix those issues (java.lang.NullPointerException: Cannot get property ‘localIP’ on null object @line 340 (getNotifyAddress)).

To Install:

  1. Go to My SmartApps

  2. Click New SmartApp

  3. Click From Code

  4. Copy code from jrod-smartthings

  5. Paste to From Code Section in your Smartthings IDE

  6. Click create (Make sure you publish)

  7. Go to Your Phone and Open Smartthings

  8. Go to SmartApps

  9. You should see Honeywell Security

  10. Click on it and hope it works

***Disclaimer: This code is only tested on my device and my alarm system. I am not responsible for any wrongdoing or any damages.

I deleted the original redloro-smartthings and any other. The only one I have installed in My SmartApps is: jrod-smartthings : Honeywell Security

Let me know if this fixes your issues. If not, please provide an error log so I can work with you to fix it.

Jrod,

Thank you for your work on this. I’m going to try it very soon and excited to see a fix. I have a question:
I assume that we should keep/ (install if not already installed) the original Redlaro 4 Device Handlers? This change you made is only just modifying the smart app part?

Thanks again.

Yes the changes I made only reference the smartapp. I used philh30 device handlers and partition.

So, I no longer have anything by redloro, just the updated changes
(*Credits: since this is possible due to his work)

This is my setup:

  1. Smart App: jrod-smartthings
    jrod-smartthings

  2. Partiton: Philh30 honeywell-partition.src
    honeywell-partition.src

  3. Device Handers: Philh30
    honeywell-zone-contact.src
    honeywell-zone-motion.src
    honeywell-zone-smoke.src

1 Like

So I have had this running off a raspberry pi and EVL4 for a few years and it worked flawlessly with the old smartthings app.

I deleted the redloro smartapp on the ide site and replaced with the jrod and updated all the device handlers per jrod.

I deleted the honeywell security app off my phone and then reintsalled it. When i click to add the honeywell smartapp and to set it up nothing changes in the my home section and no zones are there. I am typing in the static IP addresses for the pi server and evl4 module and the passwords. I put “user” in the password field for the envisalink.

Its been years since I did this whole process and Im not sure what Im missing here. Should I have rebooted the raspberry pi and the hub?

Thanks for any guidance, John

Found the issue in live logging which I didn’t know existed.
I switched to jrod modified app but had too go back and change the namespace in the device handlers to match “jrod-smartthings”

Still shows alarm in standby with no ability to arm or disarm in the new smartthings app but at least i can see the sensors and usee them.

9:47:20 AM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Honeywell Partition’ in namespace ‘jrod-smartthings’ not found. @line 273 (doCall)

There shouldn’t be an issue with the namespaces. However, it’s possible depending on your device.
The easiest way to fix it is to just change the namespace on the jrod-smartthings App to verify if the namespace makes a difference, which it might. Any device handlers you changed make sure to change them back to redloro-smartthings.

Try This:
Use a text editor and download the code for jrod-smartthings.
Use Find and Replace to change 5 entries:

  1. FInd jrod-smartthings
  2. Replace with redloro-smartthings
  3. Go to your IDE.
  4. Open the code editor for jrod-smartthings app.
  5. Select all code and delete it. Use the code you modified and copy and paste to your IDE on the jrod-smartthings app you should already have.

Let me know if that fixes it.

I have the same issues that jdmst71 is having. I had to rename all the references to jrod-smarrthings to redlaro-smartthings in the smart app as per the guidance above and after doing that smartthings picked up all the honeywell devices and can read the open and closed status of those devices but just like jdmst71 I cant arm or disarm the panel and the state of the panel says standby. Any word how we can fix this? I would love to trigger actions in the event the alarm goes off but cant do that if i cant get the status. thanks!!! im excited to get this honeywell alarm with envisalink integratedback and smartthings working correctly.

Look at your live log. See if there is any errors. The new app doesn’t let us integrate with Smartthings Home Monitor.

  1. Look for Honeywell Security in your devices.
  2. Click the gear icon and options to arm and disarm should show up.

The device “Honeywell security” doesn’t show up in my device list. it’s only populating window/door sensors , glass break devices and fire alarms which are all reporting the correct status (super excited to at least see the devices showing and reporting current status). In addition to that I also have a device called “Security Panel” and when I click on this device it has a label that shows “standby”. I assume that I’m missing the “Honeywell Security” device that would let me control the panel and report the status of the alarms. Any idea how I can get honeywell security to show up? live logging doesn’t seem to be reporting any errors.

I recommend deleting everything and restarting.
I changed the code on Smart App: jrod-smartthings
jrod-smartthings to reflect the original namespace. Delete the 3 device handlers and 1 partition and 1 smartapp.
Then, re-add them. Maybe that will fix your issue. I tried with my setup and I was able to get everything back and have it working.

Jrod I deleted everything and used your new file along with philh30 device handlers. Works the same as I had yesterday and I still don’t have a gear icon for the security panel in the new smartthings app but every zone and smoke and motion detector still shows up in my devices. In the old smartthings app for the security panel it works fine. I have away stay instant disarm trigger 1 trigger 2 chime and bypass listed. I can arm and disarm in that app but nothing in the new one. I’m assuming this is Samsung still messing with the app and coding?

Everything is working great for me now with the new app. I’m able to arm or disarm with virtual switches and create routines all via the device called ‘security panel’ . I think it worked differently before with the original red laro app with additional buttons to allow arming and disarming (no virtual switch needed)and that is what confused me. … but I figured it all out and everything works amazing and very happy. Thanks for the work on this!!!

I think my system is operating OK and that it’s the virtual switches I’m missing. Is there a post or link to help me set that up?

Since this works perfect in the old samsung app without additional switches do we think Samsung will eventually get this new app working in a similar manner to the old one?

I’m having the same issue with the Security Panel device. It just shows Partition Status as a cloud with strikethrough line and the same for Memo. The contact and motion sensors are updating fine but the controller doesn’t do anything. Did you find a fix?

1 Like

knock on wood, but since migrating and the new firmware i’ve not had any disconnects with node talking to smartthings…