[RELEASE] Honeywell / Ademco Vista 20P Integration

Update your redloro app with the code from @phil30 github.

I updated the device handlers and the smartapp to @phil30 version since being forced to migrate to the new app.

I can still arm/disarm the honeywell partition in the old app, but in the new app it shows offline for alarm type and shows “standby” for button. I am unable to arm/disarm and nothing shows up for history.

My motion sensors and door sensors report fine in the new app.

Not sure what is going on…what did I miss?

I had the biggest issues migrating to the new app as well. I had to modify the code to make it work.

Have you checked your logs?

  1. On your phone, Click on SmartApps -> Honeywell Security
  2. Enter all your info and don’t discover devices.
  3. Press done and check your live logging on the ide.

Do you see any errors?

Okay, you only need to install phil’s DH. The rest need to be redloro’s version.

Start over with redloro’s setup and discover your devices. Once you do that, install phil’s DH and select it. That’s all you need to do. Scroll up and you’ll see some of the screenshots that I posted for doing this.

philh30’s SmartApp is 2 years old and not current with redloro’s. I wouldn’t use that. It’s only his partition DH that was modified to work in the new app, which you should use (after sensors are properly set up)

i think the key is naming phil’s DH to something different than redloro’s, and then making sure you select it for the Partition device in the IDE.

Correct me if I am wrong, but Philh30 Honeywell Partition is 2 years old but the last commit date was on August 21, 2020.

Redloro Honeywell Partition last commit date was on July 29, 2017.

The newest version is Philh30.

This is the way I have it.
In Device handlers on my ide I have Philh30 honeywell partition with my custom changes since it kept giving me a code error on the live logging. That I have it named as “redloro-smartthings : Honeywell Partition2”.

Then I also have Redloro Honeywell partition named as “redloro-smartthings : Honeywell Partition”.

I then have also in my device handlers:

  • redloro-smartthings : Honeywell Zone Contact
  • redloro-smartthings : Honeywell Zone Motion
  • redloro-smartthings : Honeywell Zone Smoke

These 3^ are also from Philh30 since they have been updated on 2019. Redloro last update was on 2016.

In my SmartApps I have “redloro-smartthings : Honeywell Security”. This is also from Philh30 as the last update was on Mar. 1, 2019 versus Redloro which was last updated on Jan. 29, 2018.

[Philh30 Honeywell SmartApp]
(https://github.com/philh30/smartthings-1/blob/master/smartapps/redloro-smartthings/honeywell-security.src/honeywell-security.groovy)

[Redloro Honeywell SmartApp]
(https://github.com/redloro/smartthings/blob/master/smartapps/redloro-smartthings/honeywell-security.src/honeywell-security.groovy)

So, in my setup I have everything from Philh30. The only thing I have from redloro is the device handler.

Not sure if it’s the correct way but works for me. The only thing that’s not working for me is the Alexa routines. That is part of another topic and seems everyone is having the same issues with every contact sensor not just this integration.

1 Like

I’m currently runing redloro’s code, but it doesn’t work well with the new SM app. i havn’t migrated yet.
so does philh30 app with redloro device handlers the way to go?

is there a way to add a new sensor without reload discovering zones? i added a new device but it didn’t work, same as the others.

Appreciate all the info you’ve provided on this thread! Did you ever figure out why the STHM buttons don’t work consistently and if there is a fix for this? I do like using those buttons for a quick and easy why of manually arming/disarming my alarm w/o going to a keypad. Other than this I was able to get everything working perfectly, which was my last hurdle for leaving the classic app. Thanks again!!

redloro app and redloro zone device handlers (contact/smoke/motion). The phil30 device handler is for the partition only.

It’s pretty consistent. You have to integrate them with webcore, that’s all. You also have to make (6) other automations that include arm stay, arm away, and disarm buttons as well. Webcore keeps the buttons and the STHM in sync with the partition status of the alarm.

It’s been awhile since I was here and I also just migrated to the new app.

I tried going into SmartApps->Honeywell Security.

If I try to enter my AUTH code and save, I see the message “Something went wrong. Please try to install the SmartApp again”.

Do I need to delete and reinstall from scratch?

Following: I’m getting the same problem? any word on how to fix?

I added the new DTH and renamed it so I could distinguish between the two. (I was still getting the same error when I did not change the name).

Then I selected the new DTH for the Honeywell Security device, but I am not seeing the new screen.

I included some screen shots. Any ideas what I could be doing wrong?

I switched DTH back and forth and now I get the following screenshot. My alarm type doesn’t seem to show anything.

Don’t rename it. Doing so causes issues if I recall.

Not sure what’s causing vashwood’s issues, but I renamed Phil’s DTH and it’s working fine on my end.

I ended up deleting Phil’s DTH and created a new one without renaming. And I just restarted my mode server and removed the batteries and powered down my hub. Seems to be working now.

Thanks for the tip

Ugh. I’m having the same problem you had, in ST new app, device honeywell security only shows “Alarm type” (cloud with strikethrough icon) and “Button” Standby. I am using the DTH for partition from Philh30 and other DTHs from redloro (github repos). Added device Honeywell partition with device type from phil. Unplugged STH, rebooted rasp pi, restarted Node server. Device on iOS app still just shows 2 things I mentioned above. Any thoughts?

(Also, when I try to add the redloro smartapp, I get a message “Oops and error occurred installing the app, please try to re-install”)
So, with respect to the smartapp error, I was trying to install using the new ios app. In examining the debug messages and the developer documentation, it seems the new hub/app have changed the way configuration screens are coded. It seems that the variable type “hub” is no longer valid, so the configuration section and enumeration of hub objects fails in the new app. When I ran the smartapp install on the classic app it worked. That said, I’m not able to get any decent status on the honeywell device, but I will have to try the webcore workaround at some point. PITA.

where do i find phil30’s Device handler. i see a smart app in github, not a DH…

@RottenMutt