SmartThings Community

[RELEASE] Honeywell / Ademco Vista 20P Integration

honeywell
dth_security
smartapp_security
project_security
alarmdecoder

(Scott Herchenbach) #946

I don’t know why it’s DSC other than that’s the name of the variable in the DH.

Here’s the piston example:

I did not have to restart the server.


#947

Awesome. I assume you had to type in “alarm” in the variable?

Also, just curious how you test your alarm without sending a signal out to the monitoring company or hearing that siren go off…


(Scott Herchenbach) #948

I typed in alarm in the variable. You can also check for other status. If you open the DH, you can see all the options.

The only way to test is by triggering the alarm. I use alarm relay for monitoring, and I have to call them ahead of time to let them know I’m testing. They will put my system in “test mode” for as long as I ask them to. The alarm still goes off, but the cops don’t show up. Hope this helps.


#949

Yes, extremely helpful. Unless I missed a post somewhere, up until this point I haven’t seen a solution for this outside SHM, so this is really good…thanks!


(Ryan ) #950

would you be able to help with this. I want to connect my Visa20p panel to smart things. I have an envisalink4 connected already. I want to run the smartthings Node on Windows machine but not sure how to get everything talking with each other. My main issue is im not a programmer so when im reading the .JS coed I see IP’s and ports but not sure where I should input ip’s in from my devices


(Edward Francisco) #951

Hi Folks…

This question may have already been ask.

I have everything working as advertised. Is there a way to tell Node Proxy to use the WiFi interface instead of the Ethernet interface on a Raspberry Pi?

Thanks


(Kenneth Pocius) #952

Hello. I think there may be an issue with the serialport version. I’m trying an AD2USB install. I was having an install issue with a bunch of errors saying that the link to the serialport v5.5.0 was bad. I look at another redloro thread for the Russound and saw someone had a similar issue. The suggested fix there was to manually install serialport in the project folder and to remove the install request from the package.json. It worked for me.


(Kenneth Pocius) #953

So I continue to struggle with getting this running on the Pi. I had it running fine on the windows machine, but no luck with the Pi. I’m able to get STNP up and running on the Pi, and I can see the events as they occur. I can’t get the SmartApp to discover, create the zones and/or create the devices. I thought the issue was the Hue-bridge running on the Pi, but I’ve since reflashed the Pi (reinstalled the OS) and reinstalled everything. So I’m at a loss.

I’ve reinstalled the SmartApp several times, thinking there could be an issue there. Still nothing.

Any help troubleshooting why the discovery isn’t working?

Thanks!


(Kenneth Pocius) #954

I also have an Envisalink, and I am able to get that running in the STNP. Same story as with the AD2USB - I can see the events with the server running and I can see the SmartApp call into the server and I see “panel discovery”, but there is no device creation. I reused the config.json file from when I had it running successfully on the windows machine so the zones are already created in that file. So the SmartApp isn’t creating devices.

So to summarize - both the AD2USB and Envisalink are themselves running fine (at least they read the panel and report events); the server on the Pi works with both (not at the same time, I run them separately) and I can see the events (e.g., zone faults as I walk around); the SmartApp calls into both and I see “Completed Panel Discovery” on both. Me thinks there’s something with the SmartApp.

There are no other SmartApps that I can think of which would interfere with this SmartApp, and there’s nothing else running on the Pi (I reinstalled the OS on the Pi to clear out any hidden processes)

I’ve uninstalled and reinstalled the SmartApp several times.

This is a real headscratcher.


#955

As follow-up to anyone who wants to use WebCoRE with this integration, I was able to get it to work perfectly using “dscpartition is” rather than “dscpartition changes to.”

My integration with the Vista20P integration and SHM never worked great (as I mentioned previously, bypassing a sensor would cause false SHM activations). With this “new” set-up, I longer have to worry about that and clearing out SHM false alarms.


#956

This is interesting. Can you share more details on your use of WebCoRE with Vista20P/SHM? I have EVL4 with Vista20P but haven’t looked at SHM in the recent past because I couldn’t find a good entry/exit delay solution that last time I tried this.


#957

Theherks has a great example (except, at least for me, I had to use the “is” instead of “changed to.”)

Your intrusion status (e.g. “alarm”) can be used to activate lights, make your Amazon Echos speak, send you email/text notification, etc. To use the speak portion, you’ll need to check out Echo Speaks, done by Tonesto7.

SHM is not needed.


#958

Thanks, I’ll have to read up on the example and echo speaks.


(Mark H) #959

Hey Eric! Would you mind sharing what code you used in your command lines on crontab? I am kind of learning as I go and just can’t figure out how to auto load and run on reboot or loss of power. Thanks in advance!


#960

Anyone have a WebCoRE sample that shows alarm status in one of the dashboards(SmartTiles, ActionTiles, Housepanel, etc)? I was able to get a basic WebCoRE piston for “alarm” intrusion status to work fine using Theherks example above with tweak of “is” instead of “changed to” that smartie highlighted. I’d like to get a tile in my dashboard that would display Vista 20P panel status of “Armed”, “Stay”, “Instant” or “Away” directly instead of SHM. Even similar samples would be helpful as I try to adapt it to my dashboard needs.