SmartThings Community

[RELEASE] Honeywell / Ademco Vista 20P Integration

honeywell
dth_security
smartapp_security
project_security
alarmdecoder

#926

@mike240se thanks for answering your own questions and you are most welcome!


(mike) #927

I had some trouble getting forever working on freebsd jail in freenas. it wouldnt install and work properly using NPM for some reason.

However pm2 works AMAZING! Highly recommended for people having trouble getting the proxy to run as a daemon on linux or freebsd:


(Kenneth Pocius) #928

OK - I need help. I had this running on a windows machine just fine - it was awesome! However, I couldn’t get it to stay as a service and I wanted to start playing with a Pi. So I started to set up on a Pi. I am using the AD2USB setup, and I have it working on the Pi. It seems to be running fine on the Pi. I can watch the events as they roll in (e.g., motion sensors, etc.) When I enter all the proper variables in the SmartApp and hit “Save”, I can see the request come into the STNP and I see “Completed Panel Discovery”. However, it won’t create the things/devices/zones. I run a Hue Bridge on the Pi too, so I tried changing the port to 9000 as suggested above, but no joy.

Seems like there is some issue in the after the panel discovery request, because that seems to start but the things/devices/zones aren’t created.

By the way, I’m running the STNP in PM2 - it works great and was really east to set up. I can reboot the Pi and the server fires right back up - no problem.


#929

@Kpocius does the Hue Bridge have a smartapp that runs on ST? If so, remove/unregister the SmartApp and everything should work fine.

This is a well know issue with ST… network device IPs are effectively reserved for one SmartApp/DH… so if you try running more than one SmartApp/DH against the same device IP, it will not work unless the Smart App/DH has taken this into consideration. All the STNP stuff is built to play nicely with others; but most other SmartApps do not play so nicely and they end up clobbering all the inbound messages that are intended for others.


#930

I’ve been using this for quite a long time and it’s rock-solid; I love it (Redloro is amazing).

It completely opened up a “dumb” alarm system into something that can integrate with other automation, which is awesome.

The only two things I haven’t figured, first, what theherks asked previously with WebCoRE (still haven’t figured out alarm triggers, but armed/disarmed is no problem).

And second, I have SHM connected to activate lights, etc. when the alarm triggers (SHM has no problem seeing this). The issue is if I bypass a sensor and arm the system, when I return, SHM thinks there’s an active alarm (there isn’t, the alarm is turned off prior to entering). And it has nothing to do with having a delay entry/exit, as I arm/disarm outside the location.

Other than that, everything is awesome.


(Randy Brandt) #931

I have also found Redloro’s work to be great - appreciate it! I have encountered an issue however. After right at 3 minutes, the Envisalink 4 connection times out. All previous calls to arm and disarm from smartthings works fine, but if i hang out for a bit i can see any calls beyond 3 minutes drops a “disconnected” error to the log. If i try again, the connection resets and it works. Has anyone else encountered this?
Thanks!


(Kenneth Pocius) #932

Thanks for the reply. There is no SmartApp for the Hue Bridge, at least not that I see:


Do you think any of these could cause an issue?


(Kenneth Pocius) #933

Must be something with the Pi. I reattached the AD2USB to the windows machine, fired up the server, changed the variables in the SmartApp and hit save - dance party. Everything works.

I’m thinking it’s the HA-Bridge .jar server thats running on the Pi. I have no idea how to uninstall, so I’ll reflash the Pi and start fresh.

Thanks again for this - it’s incredible to make a dumb panel smart.


(Ryan ) #934

I was reading this post and was wondering if anyone can shine some light on this subject or has anything new to try. I currently have a vista 20p panel with Envisalink 4. I would like to have SmartThings talk with panel so I can use the wireless sensors to automate my home and also us it as a normal security system. I was looking at going the ADT SmartThings route but was reading that some IRSensors are garbage. If anyone has some really simple step by step ways of intergrading the two would be appropriate
Thanks in advance


(Mcneillr) #935

Using Redloro’s Proxy you can use all of your Alarm devices as sensors in smartthings


(Ryan ) #936

This looks great but since I’m not really a programmer I’m running into some difficulties. I was trying to get node server to start but having issues. What I really need is a step by step guide (even more detail then what is listed in post). I wanted to run the SmartThings proxy in a windows environment and if I get it working maybe then a raspberry pi I’m looking for help as my wife wants the security system up and I don’t feel like getting a whole new since a vista 20p panel is still a great system


(Mcneillr) #937

I run it on a VMware windows environment, set up of the proxy is the hardest part, but once it is setup, it is near flawless. Redloro supports frequently within the group. It is worth the effort


(Ryan ) #938

That’s good to know dumb question is it free and since it’s a VM I wouldn’t need to have my pc running all the time. Would you have any steps on how to go about creating this


(Mcneillr) #939

I own VMware workstation, I run a Plex/Json server on 24 hours in a VMware instance on my personal workstation. You can get the json server for free, and all of redloros files are available in github


(Ryan ) #940

I think I need some hand holding on this. I’ll have to research and make sure I’m putting the correct ip addresses in the correct places and getting the ports correct too. Redloro does have a video link but he puts node on a PI and says somethings like you already know how to code everything so I get a little lost in some spots


(Ryan ) #941

I’m having the same issue with this as welll. I was getting the same messages as you were. Is it possible that we didn’t set something up correctly or post something to the wrong place


#942

Heh, it’s been almost a year since I posted that. I can’t even remember anymore what I did to make it work, but it’s worked fine this whole year. Read through the thread - I may have posted what I did? I’m not at a pc right now - I’ll look later when I can.


(Mcneillr) #943

Can’t help with the PI, make sure you know your zones and define them in the config file. Make sure your pi has a fixed IP , Smartthings needs a fixed IP also

This e-mail is intended solely for the person or entity to which it is addressed and may contain confidential and/or privileged information. Any review, dissemination, copying, printing or other use of this e-mail by persons or entities other than the addressee is prohibited. If you have received this e-mail in error, please contact the sender immediately and delete the material from any computer.


(Scott Herchenbach) #944

Smartie,
I added the following code to the partition DH between “capability” and “command”
attribute “dscpartition”, “String”
attribute “panelStatus”, “String”

I then set up webcore with the following:
if Honeywell Security’s dscpartition changes to alarm…

This worked well. From there, I was able to trigger other smartthings like lights and echos.

@redloro, it would be great if you could add this to the code for everyone…


#945

Interesting, if can get this to work, I could in turn remove the sensors from SHM and just use WebCoRE, which would resolve my false alarms trips when I bypass a certain zone (as indicated earlier).

Do you know why it’s dscpartition when we are using Honeywell, not DSC?

Would you mind posting the code and the piston example so I can take a look, please?

I assume once I update the DH, I should restart the server?

Update: I checked my DH and it has that code already (although in reverse order). When I try to use the dscpartition changes to, WebCoRE doesn’t pre-populate the alarm word. Is this something you have to manually type in?