SmartThings Community

[RELEASE] Honeywell / Ademco Vista 20P Integration

honeywell
dth_security
smartapp_security
project_security
alarmdecoder

(Dave) #863

Woohoo!!! I finally got everything to work, and looks like my issue was unique compared to all the other posts. For those that run into this issue with a Honeywell Vista 15p + EVL 4 + QNAP Container / Docker image, here were the root cause issues that led to me not being able to see any of the sensors in my Things, but still being able to arm/disarm the alarm.

  1. I’m using a QNAP NAS with a Docker Node.js image via ContainerStation. It was actually pretty easy to set this up, but initially I had the new container using a Host network mode, which shares the IP address with the main QNAP NAS itself. QNAP uses port 8800 for its’ web UI so I thought that if I had my STNP using port 8888 it should totally be fine. However, in looking at the logs I noticed I didn’t see any body messages showing anything about the partitions or zones, so I guessed that it may have been due to some traffic loss somewhere. I ended up changing the networking mode on the container to Bridge and set it up with a different static IP address from the main QNAP one, and as soon as that happened I updated the smartapp with the new IP and started seeing more messages show up in the ST Live Logs for partition and zone recognition.
  2. My alarm system was giving a “SYSTEM LO BAT” and “READY TO ARM” message over and over since I didn’t have a backup battery connected up to the Vista 15p panel. Once I finally was able to see partition and zone messages in the ST Live Logs (after completing the previous step) I could see these messages getting intermingled with those errors, I figured the error messages might be interfering with the discovery / initialization of the SmartApp, and that there wasn’t any message filtering going on there. I ended up changing my config.json to set the type back to “discovery”, restarted the node.js server to take that config, rebooted my EVL-4 as I noticed that it suppresses those error messages at the beginning after a reboot, and then ran the SmartApp discovery one more time. Luckily, that did the trick and the SmartApp was able to discover the partition and the zones after that, and successfully added them to Things.

Looking forward to not debugging this anymore and just enjoying a functional system :wink:


(Eric Vasilisin) #864

And this is why I love this Honeywell integration…


(jason) #865

@evasilisin You have any details to share for how you got that?


(Eric Vasilisin) #866

I will… give me until tomorrow night, I’m trying to fix it up a bit… animate door opening instead of green and red dots…


(jason) #867

Nice. Looks really cool.

On a side note. Anyone have any help or ideas for my comment above to why my things (contacts and motion) are not showing open if my alarm is armed (to home or stay). I can’t figure out why it works when disarmed but not armed.


(Eric Vasilisin) #868

So @jmfrankie, your alarm isn’t activated when you open a contact under armed or stay ?


(jason) #869

When my alarm is disarmed I can open doors and walk past motion sensors and see them opening in smartthings app as normal, but when I arm my alarm and do the same thing opening doors and walking past motion, nothing happens as I’m looking at my smartthings.


(Eric Vasilisin) #870

Weird… it doesn’t trigger the alarm either ?


(jason) #871

My alarm system still triggers the alarm and I can arm and disarm from smartthings no problem. The alarm panel itself still functions normally, but just doesn’t show on smartthings app.

Both screenshots below are taken when I have my garage door open. One alarm on and one with alarm off.



(Manny) #872

Is there any way to read the current alarm status? I’d like to be able to use the alarm keyfobs to arm the system and then the hub will put SHM into away mode when the status of the alarm changes to armed away. Same with change SHM to disarmed when disarming via the key fob. I’m trying to see if there is away to do it from CoRE.

Thanks in advance.

Update: I think I’ll go with the solution described below using relays as output devices which tie into zwave contact sensors that have an external input.

Update 2: I realized this morning that the SHM state is already mirroring my alarm system’s state. I armed stay the system on the keypad and SHM changed to Stay mode. Duh! It’s because of the node server synching it through.

Now I would like to figure out how to trigger a routine based on SHM state…


( Cosmo) #873

I have been using this method for 1.5 years. It works nearly flawlessly. Literally one time over the entire time I’ve been using it did I get it out of sync between the relay trips and the actual system condition.

I’d highly recommend it


(Manny) #874

Thanks for the feedback! That’s good to know that the relay method is reliable.


(Eric Vasilisin) #875

I’ve also only ever had one issue with it… And it was Spectrums fault. They took my modem/router without me being home. You MUST switch to new router while old one is still in place, or it’s a pain to get EnvisaLink back to factory to setup on new router. That’s only because it has a static IP, or at least it should be, and if new router is 192.168.1.?? and old one was like 192.168.0.?? Then you’re going to have to short out the board to get envisalink back lol


(Manny) #876

I set my router to give the EVL4 a static IP lease and kept the EVL4 itself configured for DHCP. I actually reserved an IP address for it on my router before plugging it in so that I’ll know what IP it was going to get. I heard about this particular issue on their forums.

By the way, using a web CoRE piston and 3 virtual switches, 1 routine (along with my already existing ones), and an additional trigger for my away/night/home routine I was able to accomplish what I wanted. My Ademco/Honeywell keyfob’s “away” button puts the alarm into away mode, which puts SHM into away mode. The CoRE piston monitors changes in the shm status variable and turns on the appropriate virtual switch (which would be triggered by relay in the other project). The away/night/home routines are activated when their appropriate virtual switches are turned on. The home routine is linked to the disarm function on the keyfob as well. The keyfob’s stay button arms the system in stay mode which just turns on the alarm in “instant stay” and nothing else, SHM status of course reflecting this mode as well.

I went a step further and used the SHM stay mode with a conditional so that if my house is in “night” mode (which is simply after the sun goes down) it goes into my “bedtime” mode which is the mode the turns off my lights and HVAC on my main floor (all bedrooms are upstairs) as well as locking doors. This bedtime routine runs on a schedule a bit past our bedtime in case we forget to run it manually.

The way I did this works for my particular needs although I probably could do it more elegantly. I didn’t want to buy any additional hardware. I am just happy to make this integration work. These forums are full of smart people so thank you all!

It’s nice that simply setting the alarm like we did before all this home automation, using our old school alarm keypad and keyfobs, now actually kicks off a lot of automation that I have complete control of. This helped with the WAF (wife approval factor).


(Matt S) #877

Having a very similar issue George, ever get it resolved?


(Eric Vasilisin) #878

@evoryder… is STNP stopping, or is the EnvisaLink stopping? If its STNP, I had same issue and resolved with crontab AND forever mixed. Haven’t had an issue since. Reboots server on power outage, or mishap, every time. Prior to cron and Forever, it crapped out on me randomly. And was VERY irritating


(George) #879

I was able to get it fixed with Redloros help, but when I added some devices and the garage door trigger from the alarm I ended up breaking the forever again and wasnt able to figure it out. So I put the Pi on a battery backup, stared it manually and problem solved… I have no linux skills and Im glad the setup instrructions were good enough for me to follow and get working. The startup stuff was not as definitive and after a week of googling, breaking, and rebuilding it I gave up. Its all working and if it goes down ill just login and start it again manually and keep my sanity.


(Manny) #882

Is there any way to toggle the chime on/off via a separate virtual switch and have that virtual switch reflect the on/off status of the chime? I see that the chime command in the “honeywell partition” device handler:

 def chime() {
   parent.sendCommandPlugin('/chime');
 }

Thanks


#883

Anyone unable to get into the Eyez-on app? Seems totally down.


(Manny) #884

I rarely use the app but I have it installed on my S8. Just tried to open it but all I get is the orange EyezOn logo. The website isn’t working either.

I just got my envisalink 4 about a month ago and ditched my monitoring contract and panel for my own panel to implement this integration. I got everything working the way I wanted with smartthings and the panel integrated pretty tightly. Hopefully it’s just a brief outage. I guess that with this integration since the traffic between the panel and smartthings is local it doesn’t matter much if the company goes under. Is that right? I use SHM, but the text alerts directly from eyezon are nice to have as a backup in case my linux machine isn’t working.