SmartThings Community

[RELEASE] Honeywell / Ademco Vista 20P Integration

honeywell
dth_security
smartapp_security
project_security
alarmdecoder

(Eric Vasilisin) #819

For anyone interested…


(Steve Shankman) #820

Hi everyone,
I had this working really well on my raspberry pi. However, suddenly today my smartthings app no longer reports any changes in the sensors on the system. I see all the doors and windows and motion sensors, but smartthings doesn’t know when i open the door or activate the motion sensor. I see the activity in the terminal window, so the script is working and talking to the envisalink. I also see activity in the smartthings live log, so I know it’s seeing the activity. However, the app on my phone does not show anything happening. I’ve tried going to the honeywell alarm smartapp and saving again, which prompts a new discovery event. I’ve tried rebooting and unplugging the hub.

Thanks!


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #821

Question… did you by chance add any additional integrations via node proxies? or is this the only node server you have


(Steve Shankman) #822

I didn’t change anything. At one time in the past I tried putting the dash plugin but then the server wouldn’t start so I removed it.


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #823

i only ask because i added the google assistant relay and it prevented the alarm smart app from receiving responses from the node server.

Is there anything in live logging?


(Steve Shankman) #824

Thanks for answering. Yes, live logging works and updates with door open
and close.


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #825

did you by chance rename any of the devices that the smart app created?
like “door” to “front door” etc.
sometimes when you rename devices the smart app loses them and then the partition updates dont get passed from the smart app to the devices listed in smartthings


(Steve Shankman) #826

No, not that I know of. But wouldn’t rediscovering the devices fix that?


#827

@Evasilisin could you share what you had to do to get your Raspberry Pi to run the proxy server on boot?


(Eric Vasilisin) #828

Yeah… I’ll share when I am home. But it’s in autoastart and ypu have to copy and edit restart.me to home/pi.

By edit I mean cd before forever is executed in the restart.me


#829

Is there a way to see the Alarm status in WebCore? I can see the Smart Home Monitor status, but I’d like to be able to see the status of the actual alarm in WebCore.


(Steve Shankman) #831

It started working again, with no changes made on my end. Strange! Thanks for the help!


#832

I found this in the WebCore forum:

I edited the Device Handler per the link and that exposed the dscpartition attribute to WebCore. Is there a better way to get at that? If not, is there any chance this attribute could be exposed in Github for all?


(Eric Vasilisin) #833

@tx_mjs Hey man, sorry, I forgot about you asking… So, copy restart.me to home/pi, then edit it so it looks like the picture below. Once you edit it, point autostart to it… @./restart.me and it will automatically start the server on reboot.


(Eric Vasilisin) #834

Obviously cd to wherever you have server.js located…


#835

Thanks for restart code info, looks straight forward.


(Eric Vasilisin) #836

If that doesn’t work for some reason, run it using cron I stead of autostart. But autostart worked for me.


(Tom) #837

This is awesome, I have it all working on a RPi3.

I would like to use curl on my lan from another device/service to access the various arming states/endpoints on ST Node Proxy: away, stay, and instant.

How would I accomplish this? What is the construct for authentication and sending the command I want to perform when using cURL?


(Matt) #838

@webfixnow Do you have this working with a AD2Pi? I am asking because I have this working with a Pi3 and AD2Pi but the issue that I am getting is that the door contacts keep randomly saying they are opening in the ST but the alarm panel never reports anything. Not sure why I am getting these alerts.


(Matt) #839

Did you get the Pi3 and AD2Pi working?