[RELEASE] HomeSeer Wall Dimmer HS-WD200

I changed them to “dimmer switch” and they worked fine. Any devices that were in a scene showing as “unknown action” showed the correct action and I could edit. They were available to be added as actions as well.

Then I went beck and changed them to the HS-wd200 device, restarted my app, and it showed the devices but with the message “unknown action” and I could not see these devices in the list to perform an action in scenes or automations.

Add, saved, published - didn’t fix it

Then swapped a device back to dimmer then back to your handler just in case and that didn’t fix it either.

Interestingly…the devices perform the actions I set when they were dimmer devices In the scene. So even after I made the. The wd200 device and it says “unknown action” - when I run the scene the light turn on and dim to the level I set.

So at least I have a workaround…but more than happy to debug this if it helps fix a bug in the handler…

I just created a virtual device using that handler and it’s working as expected with Scenes and Automations using the Android app.

When I first tried to create a new Automations in the iOS app only 1 of my devices was listed and I saw the same “unknown action” message in the Automation I created earlier using the dimmer.

That phone has been powered off for a while so I left it open on the dashboard screen for a little while and when I checked Automations it showed most of my devices. I then left it on the dashboard screen a little longer and I was able to see all my devices in Automations and that “unknown action” message was gone.

Long story short, this is most likely a caching issue for custom handlers and leaving the mobile app open on the dashboard screen might solve it.
It couldn’t hurt to toggle the dimmer from the dashboard screen while waiting.

Yea - I just went back into the iOS app and it’s now working when it wasn’t before. Strange behavior but it works once I waited a while

Thanks for your help!

1 Like