[RELEASE] HomeSeer Dimmer and Switch (HS-WD100+ / HS-WS100+) Device Handlers

before you send it back try

MANUAL RESET - To be used only in the event that the network primary controller is lost or otherwise inoperable.)
(1) Turn switch on by tapping the top of the paddle once.
(2) Quickly tap top of the paddle 3 times.
(3) Quickly tap bottom of paddle 3 times.
(4) If light turns off, switch is reset. If not, repeat manual reset.

Amazing device handler! Wanted to thank you for hard work and making all these advanced options available to the community.

Is there a way to mess around with how the LED indicators on the switch work? I’m used to my GE dimmers that have a little night light LED that comes on when the lights are switched off. I would like the lowest indicator LED on the HomeSeer to stay lit when lights go off…is that possible?

Thanks!

Do these switches do double tap just like ge where it does not automatically trigger the light that it is hard wired to?

Similar but more… You can single tap (the hard wired control) double, and triple tap and finally press & hold for the final button control. Basically this switch is like an 8-button controller combined with a smart switch. There is a new button controller smartapp by @stephack will post soon that works like a charm for configuring. I have been beta testing it and it makes my Button Controller Plus smartapp obsolete. :slight_smile:

Can someone please confirm that i have setup this device handler properly

Thank you!

@Darwin Just a quick update that I am no longer recommending my own smartapp for your excellent device handler. I have changed from using my own Button Controller Plus and instead I am highly recommending to now use @stephack Advanced Button Controller smartapp! Yes it really is that much better that I switched to ABC. :smiley:
[BETA] Advanced Button Controller (ABC)
It is faster to setup and so much more intuitive to use and it covers the latest firmware capabilities for button 7 & 8 control.

1 Like

Anybody try installing the ZWP branded versions of these switches? I just bought two of the WS100+ in-wall switches because I love the instant status feature and the reasonable price point. They appear to be the same as the HomeSeer (but we all know how looks can be deceiving). I installed both units recently using @Darwin’s awesome device handler and @stephack’s fantastic ABC smartapp. I got one of the WS100’s working perfectly this evening, but the other one is still behaving oddly.

When I use the iOS app to “push” button 7 or button 8, everything works great. OTOH, if I physically tap the paddle (up or down), the hub shows nothing and no events are logged. But I do get a ‘click’ from the device, and the LED changes as expected. Note that I have no load connected to the switch as I am using the device strictly as a scene controller. If I then press the refresh button in the iOS app (which in theory shouldn’t be needed since this product is instant status), the iOS app correctly indicates a state change from on to off in the case of single tap off (and vice versa), but the “last tap” indicator tile in the lower left of the “Right Now” view does not change . As a result, the ABC app does not fire based on the button 7 or button 8 rules I have set.

I’m guessing I have a defective device and will try to exchange it soon. But curious if anyone else has seen this problem or has any idea of what might be going on?

Look at what is associated with the Switch to see if all of the devices associated exist.

These switches are touchy about devices existing that are associated.

Forgive the ignorance, but how does one check to see what devices are associated with a thing?

If the device instantly (-ish) reports its change in status to the hub, and the hub can then fire rules based on the change in status, then why would anything else be required? Perhaps I don’t understand what is meant by “associated”.

@Darwin, I’m not sure you ever got a response on this, but I’m struggling with the same aspect of your awesome DTH. When I use buttons 7 & 8 from the iOS app, all is good. When I do the same physically, the button “clicks”, but the hub doesn’t see it, the tile doesn’t update, I don’t get the “tap ^” or “tap v” in the lower left, and nothing shows up in the logs. I have no load connected to the device (WS-100) because I’m just using it as a scene controller.

Any ideas? I’m desperate for some help. I’ve even bought additional units to see if I had a defective device, but that didn’t solve it.

@MLUCK, am I reading this correctly from your post in the ABC thread that you are only experiencing the issue with one of your installations? [quote=“MLUCK, post:22, topic:90188”]
I just tried setting up a second WS100+ device and it worked like a charm (both the DTH and your smartapp) regardless of whether the on/off was triggered by the iOS app or a physical tap
[/quote]

Is it only the installation that doesn’t have the load connected, that you are experiencing the issues with? It may be that the central scene notifications aren’t sent by the switch unless a load is connected, but that would be a little surprising to me. Do double and triple tap work for you?

I now have 3 WS100’s installed. To be clear, the problematic behavior only applies with buttons 7 & 8 via physical taps. Doing the same via the iOS app now works after I discovered/resolved an earlier unrelated problem.

Among the 3 units, the behavior has been maddenly hard to pin down. Here’s the painful blow-by-blow:
#1: installed the first and had the above problem
#2: bought and installed second unit to confirm it wasn’t a defect with the device itself. I installed #2 in the same location that #1 had been (not that it should matter since it’s only connected to power and neutral), and it showed the same bad behavior
#1: then I excluded and reinstalled the first unit in a different location and it surprisingly worked. Huh? Weird. Whether single tapping up or down, on the app or the paddle switch itself, I saw normal events in the logs and the ABC smartapp fired as expected.
#2: I went back to this switch, having made no further changes to it, and it too had begun functioning correctly. So now I’m thinking whatever the ST
ghost was, I must be past the problem.
#3: so then I install the third unit in a third location and get the same bad/silent behavior upon physical single taps, 7 & 8. I factory-reset, excluded and re-included. No dice. I waited a couple days and did a rain dance. Still nothing.

All other buttons work fine, both physically and from the app. And units 1 & 2 still work like 90% of the time physically and near 100% virtually.

As you can probably tell, I’m stymied.

In the devices configure(), refresh(), updated(),… ask the device to send you the report of what is associated with it.

  zwave.associationV2.associationGet(groupingIdentifier: 1)

Some devices have “associated” devices, and the devices receive updates/etc. If one of the associated members no longer exists then errors happen. Those errors can cause all sorts of undefined behavior (meaning, the devices do not respond reliably).
You will need to add a function to display the association report. Something like this:

def zwaveEvent(physicalgraph.zwave.commands.associationv2.AssociationReport cmd) {
cmd.nodeId.each {
       log.debug ("AssociationReport("${it}")
     }
 }

@MLUCK, can you PM me live logging output from the IDE of a couple of physical single tap presses?

Just a heads up @Darwin. The live logging in ST has been suspect as of late(for me and a few others at least) . It sometimes does not show logs that worked 100% previously. I personally don’t feel like I can rely on it for troubleshooting anymore.
The IDE in general has been a bit unstable for many.
FYI :frowning:

Yep, will do when I get home tonight.

Hi! Is it possible to have a led indicator on on the Dimmers when off?? I see it on the Switch but not on the dimmer. Thanks!

Hello all,

I cannot seem to get the device handler to control the HS WD100+ that I installed. The switch functions normally with the physical paddle control. I added the ABC button controller smart app to my smartthings hub, also added the device handler in this post. I then manually added the device in the web portal, as shown below. The dimmer shows up in my smartthings app as a device. When I try to turn the lights on or off, it gets stuck showing “turning off” or “turning on”. None of the controls in the device handler end up controlling functions on the smart switch.

I feel like I’m missing a crucial step in pairing the device to my smartthings hub and therefore cannot control the device from my app. Any help would be greatly appreciated as I’m relatively new to the platform. Thank you!

Thinking of getting some of these switches- what is the typical lag time between a double tap and then the corresponding z-wave light being controlled to turn on since it’s not a local control?

Mine are about 1 second. It’s not the end of the world, especially with the dimmers because with the ramp up, it seems more acceptable. I wish ST would start allowing more local device handlers and SmartApps!