SmartThings Community

[RELEASE] HomeSeer Dimmer and Switch (HS-WD100+ / HS-WS100+) Device Handlers

dth_lighting

(Matthew Desario) #54

*** Dalec *** I’d love your 2 cents on this thing too as it seems you’re a relative expert on this. Happy to VenMo you for the assistance getting it set up properly.


(Dale C) #55

Yes you can have SmartThings operate the 3-way control in a similar fashion. Do you want dimming or just on-off 3-way operation? Dimming will bring in a more complex programming solution.

As far as I know the HomeSeer switches are not directly designed to be used in 3-way or 4-way standalone operation so if you use a hub (HomeSeer or SmartThings) you can make them operate indirectly in 3-way as long as the home automation hub is operational.

A disadvantage is the latency of the “secondary” switches when you want the 3-way operation versus standalone control. Personal preference will determine if latency is acceptable or not but it is not a bother for most once they get used to how it operates versus the instantaneous operation of the original hardwired switches

An advantage is you don’t have to use HomeSeer switches in the secondary switch locations, any hub compatible switch or button device could be used to signal you want the lights on from the secondary location and triggering the primary location of the HomeSeer HD100+ And there are lots of variations to 3-way 4-way once you get into SmartThings because you are only limited by programming now.

For example I do a 4-way setup in my master bedroom using a HD-100+ as the wall switch entering the room, controlling bedside smart bulbs on each side of the bed and a ceiling fan light. The HD-100+ isn’t even wired to a load per se because I wanted individual control of each light so instead I use its multitap “smarts” and indication readout. When I single tap UP;I turn on both bedside smart lamp bulbs, and the ceiling fan bulbs to 50% level and vice versa to shut down. Double & triple tapping controls the ceiling fan speeds and lights At each bedside I have wireless Minimotes that provide the “4-way” function. One button acts like the wall switch to toggle all lights, button 2 will only control the adjacent bedside lamp on-off or low dim; button 3 controls the opposite bedside lamp, button 4 the ceiling fan light. etc with press&hold functions of the minimote.

I just give you the example to let you know that thinking in a traditional 3-way and 4-way will limit you and the potential to take full advantage of Smartthings.


(Matthew Desario) #56

I really would like dimming as well. I could live with the latency because
right now it takes about 3 seconds for them to dim down anyway, so an extra
3 seconds would be fine. I’m mainly swapping out all the old Lutron
switches because they didn’t work with the new LED bulbs that we installed
to be green as possible. So I went with the Homeseer but my electrician
ran into this issue.

Is it correct to tell my electrician that he should wire the “dummy” HD100+
to ‘nothing.’ Eg, install it with the power but don’t connect the traveler
light or load to it, and turn it into a powered Z-wave extender/Z-wave
device that only communicates via wireless to the Smart Things, and via the
SmartThings to the other Z-wave Dimmer that is hardwired. Is that correct?

Anyway if I did that to one of them, you could help me program one and
train me? I would be ecstatic to pay you whatever you ask for your help.
I’ve got $600 of dimmers sitting around in a box for the last 2 months
because I got stuck and the companion switches have been out of stock.

MD


(Dale C) #57

On the little bit you have said so far “yes” you are correct you will wire only one HD100 as the local standalone switch and install all the others in as powered only with no real switch loads, but why don’t you PM me with the details of layout of the house and where all the switches are located and what lights they currently operate so I recommend the optimum installation. The more details the better so I can advise your electrician correctly. Also what you currently already have purchased including the LED bulbs.


(Patrick B) #58

Hi everyone - I’m a total newbie to home automation and SmartThings.

I have a number of HS-WD100+ dimmers installed in my house and I have no clue how to add them as a device in SmartThings. I’ve been looking online and in the forum but can’t find anything?

I’ve tried adding a thing in the mobile app then clicking on my dimmer switch but nothing shows up. Is there something I physically need to do on the dimmer switch to get my hub to see it? I’ve added the device handlers and the button controller + smartapp to my account. I just can’t add any of the dimmers to my hub.

Plz help! Thanks!


(Dale C) #59

try this. it helped me a lot when I first started. You need to add the custom device handler for the switch.


(Patrick B) #60

Thanks @dalec!

I’m a big dumb animal. Apparently the one switch I’ve been trying to get connected for hours is the only one in my house that isn’t working. All of the other switches in my house are found when I go into the app to add a thing. It’s strange that the dimmer functionality works for this one switch and the companion switch works too… so I have no clue why it just won’t be found by ST. Maybe I’ll have to send this one back to homeseer


(Dale C) #61

before you send it back try

MANUAL RESET - To be used only in the event that the network primary controller is lost or otherwise inoperable.)
(1) Turn switch on by tapping the top of the paddle once.
(2) Quickly tap top of the paddle 3 times.
(3) Quickly tap bottom of paddle 3 times.
(4) If light turns off, switch is reset. If not, repeat manual reset.


(Sparq) #62

Amazing device handler! Wanted to thank you for hard work and making all these advanced options available to the community.

Is there a way to mess around with how the LED indicators on the switch work? I’m used to my GE dimmers that have a little night light LED that comes on when the lights are switched off. I would like the lowest indicator LED on the HomeSeer to stay lit when lights go off…is that possible?

Thanks!


#63

Do these switches do double tap just like ge where it does not automatically trigger the light that it is hard wired to?


(Dale C) #64

Similar but more… You can single tap (the hard wired control) double, and triple tap and finally press & hold for the final button control. Basically this switch is like an 8-button controller combined with a smart switch. There is a new button controller smartapp by @stephack will post soon that works like a charm for configuring. I have been beta testing it and it makes my Button Controller Plus smartapp obsolete. :slight_smile:


(Gino) #65

Can someone please confirm that i have setup this device handler properly

Thank you!


(Dale C) #66

@Darwin Just a quick update that I am no longer recommending my own smartapp for your excellent device handler. I have changed from using my own Button Controller Plus and instead I am highly recommending to now use @stephack Advanced Button Controller smartapp! Yes it really is that much better that I switched to ABC. :smiley:
[BETA] Advanced Button Controller (ABC)
It is faster to setup and so much more intuitive to use and it covers the latest firmware capabilities for button 7 & 8 control.


(Mark) #67

Anybody try installing the ZWP branded versions of these switches? I just bought two of the WS100+ in-wall switches because I love the instant status feature and the reasonable price point. They appear to be the same as the HomeSeer (but we all know how looks can be deceiving). I installed both units recently using @Darwin’s awesome device handler and @stephack’s fantastic ABC smartapp. I got one of the WS100’s working perfectly this evening, but the other one is still behaving oddly.

When I use the iOS app to “push” button 7 or button 8, everything works great. OTOH, if I physically tap the paddle (up or down), the hub shows nothing and no events are logged. But I do get a ‘click’ from the device, and the LED changes as expected. Note that I have no load connected to the switch as I am using the device strictly as a scene controller. If I then press the refresh button in the iOS app (which in theory shouldn’t be needed since this product is instant status), the iOS app correctly indicates a state change from on to off in the case of single tap off (and vice versa), but the “last tap” indicator tile in the lower left of the “Right Now” view does not change . As a result, the ABC app does not fire based on the button 7 or button 8 rules I have set.

I’m guessing I have a defective device and will try to exchange it soon. But curious if anyone else has seen this problem or has any idea of what might be going on?


(Brian Aker) #68

Look at what is associated with the Switch to see if all of the devices associated exist.

These switches are touchy about devices existing that are associated.


(Mark) #69

Forgive the ignorance, but how does one check to see what devices are associated with a thing?

If the device instantly (-ish) reports its change in status to the hub, and the hub can then fire rules based on the change in status, then why would anything else be required? Perhaps I don’t understand what is meant by “associated”.


(Mark) #70

@Darwin, I’m not sure you ever got a response on this, but I’m struggling with the same aspect of your awesome DTH. When I use buttons 7 & 8 from the iOS app, all is good. When I do the same physically, the button “clicks”, but the hub doesn’t see it, the tile doesn’t update, I don’t get the “tap ^” or “tap v” in the lower left, and nothing shows up in the logs. I have no load connected to the device (WS-100) because I’m just using it as a scene controller.

Any ideas? I’m desperate for some help. I’ve even bought additional units to see if I had a defective device, but that didn’t solve it.


#71

@MLUCK, am I reading this correctly from your post in the ABC thread that you are only experiencing the issue with one of your installations? [quote=“MLUCK, post:22, topic:90188”]
I just tried setting up a second WS100+ device and it worked like a charm (both the DTH and your smartapp) regardless of whether the on/off was triggered by the iOS app or a physical tap
[/quote]

Is it only the installation that doesn’t have the load connected, that you are experiencing the issues with? It may be that the central scene notifications aren’t sent by the switch unless a load is connected, but that would be a little surprising to me. Do double and triple tap work for you?


(Mark) #72

I now have 3 WS100’s installed. To be clear, the problematic behavior only applies with buttons 7 & 8 via physical taps. Doing the same via the iOS app now works after I discovered/resolved an earlier unrelated problem.

Among the 3 units, the behavior has been maddenly hard to pin down. Here’s the painful blow-by-blow:
#1: installed the first and had the above problem
#2: bought and installed second unit to confirm it wasn’t a defect with the device itself. I installed #2 in the same location that #1 had been (not that it should matter since it’s only connected to power and neutral), and it showed the same bad behavior
#1: then I excluded and reinstalled the first unit in a different location and it surprisingly worked. Huh? Weird. Whether single tapping up or down, on the app or the paddle switch itself, I saw normal events in the logs and the ABC smartapp fired as expected.
#2: I went back to this switch, having made no further changes to it, and it too had begun functioning correctly. So now I’m thinking whatever the ST
ghost was, I must be past the problem.
#3: so then I install the third unit in a third location and get the same bad/silent behavior upon physical single taps, 7 & 8. I factory-reset, excluded and re-included. No dice. I waited a couple days and did a rain dance. Still nothing.

All other buttons work fine, both physically and from the app. And units 1 & 2 still work like 90% of the time physically and near 100% virtually.

As you can probably tell, I’m stymied.


(Brian Aker) #73

In the devices configure(), refresh(), updated(),… ask the device to send you the report of what is associated with it.

  zwave.associationV2.associationGet(groupingIdentifier: 1)

Some devices have “associated” devices, and the devices receive updates/etc. If one of the associated members no longer exists then errors happen. Those errors can cause all sorts of undefined behavior (meaning, the devices do not respond reliably).
You will need to add a function to display the association report. Something like this:

def zwaveEvent(physicalgraph.zwave.commands.associationv2.AssociationReport cmd) {
cmd.nodeId.each {
       log.debug ("AssociationReport("${it}")
     }
 }