[RELEASE] - Hive (Connect) V3.0 (British Gas Hive)

dth_lighting
dth_pocketsocket
uk
smartapp_hvac
dth_hvac

(Steve ) #102

Did you manage to get it working?
Just had a look at my device ID to see if it was maybe the save for everyone but it’s about a 24 digit mix of numbers and letters.
Have you tried looking at the catchall see if anything appears in there?
Only thing I can think of is getting a copy of the classic app Android trying to add it through there.


#103

Got hold of classic app. New app won’t allow anything except SmartThings native kit. Works with classic.


(Ben Lee) #104

For this winter I’ve decided to try out the “ready by” feature of Hive (So like Nest it aims to be at the temperature set point instead of starting to heat when the set point is passed).

Does anyone else use this, just interested to note that when this is on the SmartThings info logs the thermostat as “idle” but the Hive App & Website can report the unit as heating.

Not a big issues but it is messing with my logging (so I can see how long the boiler was active!).

Curious if anyone has noticed this too?


(Alex Lee) #105

I don’t have Ready By enabled on my Hive account yet. Apparently rollout is ongoing. It must be a new mode that’s coming through in the API which is not in the code of the device handler. As soon as I can investigate I can hopefully make the small tweak required.


(Matthew Johns) #106

deleted I hadn’t tried the obvious.


(Alex Lee) #107

Device Handlers updated to v3.1. It’s an attempt to start compatibility with the New Smartthings app. It’s a very basic integration so stick to the ST classic app for best functionality.


(Aesgarth) #108

Is it possible to cancel a boost command from webcore? I have a virtual switch that sets the heating to boost for 30 minutes then switches itself off, and I’d like to be able to stop the boost if manually switched off. Is that possible?

Edit: Never mind, the set to auto command does it.


(Matt) #109

Hi guys,

How on earth did you get hive bulbs to work direct with ST?

I’ve spent hours on this today. I have the Smartthings classic app, and Hive gu10 bulbs.
I carried out the following:

Put the app into “find things”
Switched on GU10’s, which flash once to show they are in pairing.
But then, ST doesnt’ find them at all.
Tried manual add, but that’s pointless as they aren’t listed anywhere.

I’ve looked at the Zigbee stuff but can’t quite get my head around it. I’m logged into the Smartthings web API (see attached) in order to attempt to manually add, but this is where I am getting lost.

I don’t think that the Hive bulbs are registering on the Network and further to this I don’t know what the hive Zigbee ID is?

What should I be putting into the “Network ID” box and also the “Zigbee ID” box? Where would I find this information? And do the other settings look ok?


(James) #110

Hi I don’t know if a recent Hive hub firmware update has changed something but i can no longer add new hive devices.

Added new device to my hive hub, they work fine.
Go into smartthings hive connect app, they appear under devices, select to add. go to save and get “name cannot be null”. They appear to have been added when you go back into the
connect app devices, but they will not appear in the smartthings app of things.

I have a new rgb bulb (cant get to work), but also have old white tuneable bulb that i had to removed as it was playing up in hive itself. i have readded to hive (working ok) but this wont work any longer in smartthings (this was previously in smartthings and did previously work). I deleted the device in smartthings but it wont re-add even though it is in the hive connect device list.

So in summary one old device and one new device unable to add even though in connect app device list.

Any help - Thanks.


(Edelmiro Rivera) #111

So is there some way of getting around having to the use euro server for this? I ask because my hub is on the USA server and if I place the code for connect and the heater on the EU server it doesn’t show up in my smartapps. If I install it as anm app on the US er4ver, it logs in but that’s it. I can’t ever get my thermostat to show up in the devices. I’m logged in successfully and have the token In the logs, but then I always get a 401 not authorized error when it searches for devices. Ideas?


(David McNae) #112

Hi, wicked guide, so simple to follow thank you! Have done everything you say and all seems fine, just my 2 Stats do not appear under things as I thought they would? Any ideas? Have shut down the app and opened again but still no joy.


(Danny Hathaway) #113

Hello I love the app, is there anyway I can have the smartthings device auto refresh? as once I change with the hive itself the smart app sees no change unless I hit refresh?


(Alex Lee) #114

There is a 10 minute refresh rate built into the app. This is to make sure we’re not overloading the Hive APIs.


(Adam) #115

Hey @Alyc100, note sure when it was introduced, but Hive allow you to group multiple bulbs now into a group and control as one, which is perfect for me as I have 6 bulbs in my hallway and I just want them to show as one device. In hive, this works great. Previously I have set up a virtual switch in Smartthings to control all 6 hive bulbs which works well, but I still have the 6 bulbs showing which is annoying. With the new Hive grouping, this shows up as another bulb in the Hive connect app, and I can add it as a device, which in my mind, I should then be able to de-select the 6 bulbs as showing in Smartthings and just use this one “grouped” light. I can do this, but sadly the grouped light doesn’t do anything, it doesn’t control the equivalent light in Hive and control the lights, it just basically does nothing, so must be some special type. Any chance you could have a look at this? Would be awesome to not have all bulbs listed and I can dump the virtual switch…


(Pauldsmith1986) #116

Hi, I am a complete novice to this. I have managed to as my Hive to ST. Is it possible to integrate Hive with ActionTiles?Thanks


(Steve ) #117

Yeah.
Once hives added to SmartThings just authorize it within the Action Tiles and then you can add it as a tile then.


(Pauldsmith1986) #118

@Steveuk23, Hive appears in My Smartapps but I can’t authorize it. Am I missing a step…sorry for all the questions :slight_smile:


(Pauldsmith1986) #119

I can only add one screenshot in a post.


(Steve ) #120

Is your Hive showing up in your list of things as a Thermostat ?
That first screenshot is of the smartapp.


(Pauldsmith1986) #121

Managed to resolve the issue, an error on my part. Although, I am only seeing my Downstairs Hive and not my Upstairs, despite the Hive (Connect) showing 2 devices.