[RELEASE] - Hive (Connect) V3.0 (British Gas Hive)

@jedlinbenwell have you got the latest version? You should be running v3.1.1b?

Would someone else mind telling me what the update time looks like? When I change a stat using either the Hive app or the actual stat it takes about 5 minutes to update in the ST app. Is that the expected time? Thanks.

Yes. There is a 5 minute poll to prevent too many calls to the Hive API

1 Like

Great, thanks for confirming! :slight_smile: Paul

Quick question here.

I have a 3 zone heating system, in one of the zones I have two Hive stats (each in a different room), the corresponding boiler switches are wired in parallel to a single heating zone, this means that I can turn the zone on or off using either of the two thermostats. The rooms in which the stats are located also have TRV’s in them (hive).

This allows me to use either room independently of the other and only heat one room at a time.

I want to simplify the configuration, to do that I want the TRV’s in each room to ‘follow’ the stat. I intend to do that with WebCore but initial testing has not successful.

Both Stats and TRV(s) are Off when not in use.
Both the Stat and the TRV are setup with a 24x7 schedule of 21 degrees C

Therefore, if I turn the Stat from ‘Off’ to ‘Schedule’ it goes from 7C (protect) to 21C.

What I want to do is get the TRV to follow the Thermostat’s mode. @Alyc100 this should be straightforward right? I would simply use the following logic:

If stat changes to ‘Schedule’ change the TRV to ‘Schedule’
If stat changes to ‘Off’ change the TRV to ‘Off’

Sound correct?

Quick edit here. I’ve set this up and the logic looks fine. For some reason WebCore is not changing the thermostatmode to Auto as requested. I’ve created a simple test to prove this (see below. The routine runs but the TRV never updates from Off?

Screenshot 2020-11-05 at 14.41.55|365x500

Yet another edit. Nothing I do in Webcore seems to affect the TRV. Any ideas?

Every time when i try change TRV it just don`t do nothing, but when i press on hive thermostat it changes temperature normal.

debug Executing ‘refresh’
debug Executing ‘poll’
debug Executing ‘setHeatingSetpoint with temp 25’
debug Executing ‘refresh’
debug Executing ‘setHeatingSetpoint with temp 23’
debug Executing ‘refresh’
debug Executing ‘poll’
debug Executing ‘setHeatingSetpoint with temp 23’

Would someone be able to do me huge favour and see if they can change the TRV heating setpoint using WebCore? I can’t get WebCore to update the TRV whatever I do.

Basic piston as follows:

If time = 18:47
Then set heating setpoint to 25 with TRV

Log:

+1ms	╔Received event [Sutton Windmill].time = 1604861040000 with a delay of -892ms

+74ms ║RunTime Analysis CS > 18ms > PS > 39ms > PE > 17ms > CE
+76ms ║Runtime (37088 bytes) successfully initialized in 39ms (v0.3.110.20191009) (74ms)
+77ms ║╔Execution stage started
+84ms ║║Comparison (time) 67439190 happens_daily_at (time) 67440000 = true (1ms)
+85ms ║║Time restriction check passed
+86ms ║║Cancelling condition #2’s schedules…
+87ms ║║Condition #2 evaluated true (5ms)
+88ms ║║Cancelling statement #2’s schedules…
+91ms ║║Requesting time schedule wake up at Mon, Nov 9 2020 @ 6:44:00 PM GMT
+93ms ║║Cancelling condition #1’s schedules…
+94ms ║║Condition group #1 evaluated true (state changed) (12ms)
+96ms ║║Cancelling statement #3’s schedules…
+4751ms ║║Executed physical command [TRV Mill Ground Hive TRV].setHeatingSetpoint([25.0]) (4650ms)
+4752ms ║║Executed [TRV Mill Ground Hive TRV].setHeatingSetpoint (4652ms)
+4776ms ║║Executed physical command [TRV Mill Ground Hive TRV].setCoolingSetpoint([25.0]) (21ms)
+4777ms ║║Executed [TRV Mill Ground Hive TRV].setCoolingSetpoint (22ms)
+4779ms ║╚Execution stage complete. (4702ms)
+4780ms ║Setting up scheduled job for Mon, Nov 9 2020 @ 6:44:00 PM GMT (in 86396.112s)
+4788ms ╚Event processed successfully (4787ms)

Is it just me? The piston runs but the TRV never updates.

Thanks.

Hive appear to have forced two step verification on me. My hive app on my android phone wouldn’t open without enabling it. Now when I try to connect via smartthings i get error 500 and recieve a text but of course I have no where to put it in your smartapp. Any suggestions or am I just being an idiot?

I’m an iOS user but if you open the app and then select account you can turn off 2FA.

https://community.hivehome.com/s/question/0D55I00000UcnaiSAB/how-to-stop-my-phone-app-asking-me-to-set-up-two-factor-authentication

I was being an idiot and looking on my hive website account and not my phone app, thank you for your response, much appreciated.

I have a custom monitor setup to alert me if temperatures in the house go below zero or above 30, very occasionally I get the message that the Hive heating reports a temperature of “null”. Any idea what causes that, it didnt use to happen in the older version?

Shout for some help…

Do you have a Hive Connect installed, a Hive TRV and 10 minutes? Would you mind seeing if you can change the heating set point of your TRV using webcore for me? I’ve tried several times but it’s not functional. Would seriously appreciate someone telling me it’s not my config.

Thanks.

I managed to capture it happening:

Seriously struggling to get this working again. It seemed to have disappeared from my Smartthings App however now trying to get it to work all I seem to get is authentication errors when entering my Hive Username and Password.

Keeping getting error 403 “forbidden”

Anyone else having this issue or is it just me? Using the latest version 3.1.1b

Edit: Deleted everything and re-installed it and it works again. Looks like some funky stuff is happening on Github which is what was causing the issues.

Thanks, working a treat. I assume boost is labelled as ‘emergency’?

Anyway to buy the dev a beer?

Evening all,

I see that the Hive integration has stopped working again, seems like they’ve moved the API’s behind AWS SSO login.

Is there a future where this works?

same here. thought I was going mad.
updated everything. and still getting error 403 message forbidden on sign in.

Same here, this seems to be occurring to often of late…
Anyone have any ideas on a solution?

Nope. I believe the Home Assistant Community has resolved this, but it was more than a URL change like last time.

Bit out of my comfort zone there!