[RELEASE] Heatit Thermostat (Z Wave with Under Floor Heating)

Hi guys!

I have pushed a new version of the DTH.

If you get sync incomplete, there is a mismatch between a value it tries to sync and expected value. I solved this by setting the parameter to the expected value (located in the hub logs)

Best regards,


1 Like


I haven’t figured out how to do this yet. The problem is that the temperature and mode are located in two different tileAttributes.

I found one post suggesting to add the states to the temperature, but this caused a lot of problems.

Best regards,


Hm Thanks Jone but still got the same error. Tried to delete the device and reinstall it, same issue. Checked the logs while it tried to sync - here is the error message:

08:36:42: error java.lang.NullPointerException: Cannot invoke method startsWith() on null object @line 998 (encap)


Hi Christian!

I experienced the same issue last week.

I had to remove the device from the z-wave network, reset it, and then rejoin. This worked fine. However, I am also experiencing issues with syncing the parameters from the app to the device, and when I get som spare time, I will try to figure out why this is happening.

I read that this was also happening to the Fibaro switches, so it might (I’m guessing) be related to an update to the ST hub?

Best regards,


Thanks Mate
I’ll try to remove it completely as you describe!

Regarding Fibaro I have none in my setup but this could be true. Something has happened - I also have issues with all my “sunrise” automations not firing as they should - sad after 1 1/2 year with very stable setup…




I have updated the code. Still have some issues with syncing, but fixed other issues

Best regards,


Thanks a lot for your work on this! Does the Power Metering work with this DH?


I’m considering getting a smartthings hub to control heatit thermostats. Is it integration in This thread stable, or would futurehome be recommended at a higher price?

Will try to link it to Tibber, so it has to be one of the two options.

If you already have HeatIt thermostats it depends on the version you have. I have the V1 and it works reliably through WebCore automations, but heating control through Alexa doesn’t work 100% as the DTH timesout.

Thanks. Don’t have thermostats, are there issues with the V2 thermostats?

The V2 Thermostats need a different DTH to work with SmartThings - if you haven’t invested in the HeatIt thermostats I would advise against it. I’ve spent a lot of money on these (and the cable to update the firmware) only to find them not to work reliably with SmartThings, partly due to the manufacturer not releasing any kind of DTH with their hardware. I’ve also found HeatIt support very poor - I emailed them over a year ago for a copy of some firmware and never received any reply.

What issues are you facing with the thermostat and ST when you say they aren’t working reliably?

When I use Alexa to control the thermostats something in the DTH causes the request to time out and for Alexa to respond with “something went wrong”, even though the Thermostat does actually heat to the desired temperature. My workaround at the moment is to create a virtual thermostat and sync it’s status using WebCoRe, but it would be good if I could control it directly.

It may be related to a combination of issues. We discovered an issue with the EU platform causing timeouts, the ST staff is looking into it and also working with heatit to enhance the st integration and bring out some additional features.

1 Like

Sounds promising (although this thread is over 3 years old - and I don’t remember Thermofloor ever releasing an official DTH)

Thanks for the info,

1 Like

hello. I bought the dh for z-trm2fx. The layout is great, but its keeps loosing connection eash 2 days. any solution?

Haven’t seen any issues here. Try bring your hub closer or add a repeater between the hub and the thermostat.
It could also be an issue with the hub, see this topic about the upcoming hub firmware which addresses something related to lost z-wave connections.

Hi, you can find the official DTH here:

We will have more heatit product integrations coming in the near future

1 Like

Here’s another one for Z-Water

I adressed the problem to Thermo-floor and they sent a new one. Now everything is working :slight_smile:

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.