[RELEASE] Hank One/Four Button Scene Controller

Thank you!

A bit of an update and a simple workaround that I just came across by accident. I have a couple SmartButtons and those should be able to locally process commands for the lights, and they weren’t. (The Quad button can’t locally process, so it does have to have a connection to the cloud to function.) Long story, and I have another post about it, but here’s what I found. If you go to the icon for the quad button, it only shows the one button. But if you set up an automation where the Quad button triggers an action, it lets you specify which of the four buttons to use.

Hello! I have EU version of Aeotec NanoMote Quad. On the back side of case it says:

Model: ZWA003-C (868.32MHz)

in IDE I see

prod:0002

so I guess you handler could be extended with:

fingerprint mfr:“0371”, prod:“0002”, model:“0003”, deviceJoinName: “Aeotec NanoMote Quad”// ZWA003-C

to recognize this device. After pairing without this change I have ended up with some generic button device.

Edit: interestingly enough “generic button device” is “Z-Wave Multi Button” that supports EU version of Z-Wave Multi Button: https://github.com/SmartThingsCommunity/SmartThingsPublic/blob/master/devicetypes/smartthings/zwave-multi-button.src/zwave-multi-button.groovy#L30

You can manually change the “Type” field to my handler in the IDE, but when I have a moment I’ll add the EU fingerprint. Make sure you save the settings in the classic app and wake the device up after switching to my handler.

The button/battery functionality will work with the generic handler, but it doesn’t expose any of the settings in the classic app.

1 Like

This one does.

The events are being generated basically the same and SmartThings frequently breaks and fixes things so it’s possible the problem has been fixed since it was originally reported with my handler…

@krlaframboise @JDRoberts

I’m running three Aeotec NanoMote Quads with Kevin’s DTH, Initial Release 1.0 (05/26/2018). I am upgrading from ST Classic to ST New 3.0.
Questions:

  1. Do I need to upgrade the DTH to Kevin’s 1.0.1 (07/19/2019)?
  2. How do I upgrade a DTH? In the IDE, I clicked “Device Type Settings / Update” and the IDE says “Updated SmartDevice” right away, but the DTH did not change - it is still on 1.0. Can I paste the new code over the old code? Do I need to remove the device, update the DTH, re-add the device? I cannot find anything on how to update DTH code.
  3. Before upgrading to ST 3.0, I think I was able to run Routines from the NanoMotes. Now that Routines are deprecated and I only have Scenes, how can I run Scenes from the NanoMotes?

Thanks!

Those devices work fine with the built-in handlers so change the type field in the IDE to one of those. It will probably be called something like z-wave button.

Kevin, I installed DTH “Z-Wave Multi Button” per advice from Aeotec Tech Support. As others have pointed out, the Device in the IDE (under “Current States”) shows numberOfButtons = 4, but when using it in ST New 3.0, it only shows two buttons and Battery. There is no access to Buttons 3 or 4.

Curiously, the DTH in the IDE shows supportedButtonValues = Pushed and Held. But in ST New 3.0 under Automations, it shows Pressed, Double Pressed, and Held.

Is there any way to get access to Buttons 3 & 4?

@krlaframboise

After a lot of hours and good help from Aeotec support, I finally got all three NanoMotes working on my hub. The keys were 1) removing the two custom DTHs I had previously installed; 2) putting the controller into Exclusion mode and removing the three devices; 3) completely re-installing the devices. Even so, two of the three received the correct “Z-Wave Multi-Button” type and one received the incorrect Z-Wave Generic type. I had to go back to Exclusion mode, remove the device, and re-install it from scratch. I was unable to just change the DTH to Multi-Button - that did not change from one button to four buttons. A complete re-installation finally got the correct DTH type installed on the third NanoMote.

This was excruciating.

@krlaframboise

Spoke too soon. All the buttons on each of the three NanoMotes shows “Standby.” I cannot find a way to activate the buttons and get them out of standby. See attached pics.

Hi all
I’m new to this SmartThings setup, and have read as much as I can here to try set up my new NanoMote Quad ZWA003-C without any success.

I have created the custom device handler as per Aeotec’s website (https://aeotec.freshdesk.com/support/solutions/articles/6000197023-nanomote-quad-with-smartthings-hub) and everything is published to my ST (v3). I’ve gone as far as definite what Button 1 should do when pressed, however, when pushing, nothing happens. And probably for the below reason:

Catch is, no matter what I try to do to pair the 4-button remote, it flashes blue (which the ST hub flashes green) while trying to use ST’s switch choice as well, but nothing. I assumed that adding a custom device handler might ‘auto detect’ it and show it or pair it, but I am probably assuming incorrectly…?

For the life of me, i have no idea how to pair this thing. If anyone could advise it would be appreciated.

Kind Regards
Dean

I’m pretty sure standby is the expected state of the buttons in the new mobile app.

The exclusion instructions should be in the manual, but it wouldn’t hurt to also factory reset it.

The new mobile app is still messed up and the searching feature during inclusion doesn’t look for z-wave devices with the v3 hub unless you choose a manufacturer’s device or the generic z-wave device option.

Have you tried installing it with the classic mobile app?

After inclusion you might have to manually wake up the device for it to display the correct number of buttons. To manually wake it up, hold the button down until the led turns green.

I forgot to mention that after excluding it and starting inclusion mode on the hub with either that z-wave option mentioned above or the add device screen in the classic mobile app, you need to push the button twice quickly to put the device into inclusion mode which will cause the LED to blink rapidly until it’s successfully joined.

I emailed w Aeotec support today and you are right. You can watch the NanoMote in the mobile app while you click a button. The button briefly changes to “Pressed” or “Held” then reverts to “Standby.”

Turns out two of my NanoMotes worked fine after reassociating them (after removing the custom DTHs). The one I was struggling with last night was visible in the IDE and in the app, but events were not logging.

I removed it from the network, reassociated it a third time, and finally got it going.

Aeotec support advised (as do the docs) to move the NanoMote close to the hub. I did that, too.

So now all three NanoMotes are programmed and working correctly.

What an ordeal.

Thank you for confirming that everything works as expected with the built-in DTH.

This DTH doesn’t provide any additional functionality so I’ve marked the topic as obsolete.

If you open the device in the IDE, what does the “Type” field show? I’m not sure if the Hank fingerprints have been added to the built-in handler so I’ll add that name to the obsolete message.

The Type field = “Z-Wave Multi Button”

1 Like

@JDRoberts

Some other tips from Aeotec re NanoMotes:

  1. The IDE “Raw Description” field lists all information that was passed to SmartThings. If you have control problems after pairing the device, look for missing integration information which is indicated by “0000” or “00” values. If you see those, it is likely something in pairing failed.

  2. The IDE “Type” field. If you see “Z-Wave Generic Device” instead of “Z-Wave Multi Button” you know pairing failed.

  3. Be sure to move the NanoMote to within 10 feet of the SmartThings before pairing. After pairing, you can move the NanoMote to their its final location. This helps quite a bit with pairing and ensuring all information gets passed between the NanoMote and Hub.

2 Likes

This and not waking the device up after changing DTHs are the most common reasons for the device to show the wrong number of buttons and you’re only option when that information doesn’t populate is to remove the device and join it again.

I’ve seen that happen multiple times in a row with other devices, but rebooting the hub usually solves it.