[RELEASE] Hank One/Four Button Scene Controller

What do you mean by “same button configuration”?

Every button device will use the same button numbers…

What SmartApp are you using with those buttons?

FYI, if you’re using the Button Controller app you need to install a new instance of it for each device.

That’s the problem – I want to use the same button numbers on different NanoMotes to control different lights. Example:

I have two NanoMotes in the master bedroom.

  • The center button #4 on my remote should toggle my nightstand light on and off.

  • The center button #4 on my wife’s remote should toggle her nightstand light on and off.

  • There is no need to set the living room “Watch TV” Routine on these remotes.

I have a third NanoMote in the Living Room.

  • There is no need to control the master bedroom lights with this remote.

  • A press of center Button #4 on this remote should activate the “Watch TV” Routine.

  • A hold of center Button #4 should turn the living room lights back on bright.

In other words, I want each NanoMote to be separately programmable. They are useless to me if they all have identical functions assigned to the buttons.

Are you installing button controller from the marketplace for each remote? You should end up with one button controller instance per device in your automation list.

1 Like

Yes, I’m using the Button Controller SmartApp

Like @Automated_House said, you have to install the app 3 times, one for each NanoMote.

Thanks. That worked. I never would have figured that out and don’t recall reading that in documentation anywhere.

Now I have three “Button Controller” SmartApps installed, all with the same name. Too bad you can’t rename the SmartApp – I have to click into each one to see which NanoMote it is controlling. Now that they are all set up, it isn’t a big deal. Just a slight complication to maintenance ce down the road.

Thanks again.

I used this device handler but used Webcore to program the remote instead. Seems to work more reliably than ABC and much more customization. I was able to create custom commands for a z-wave shutter controller and send these through WebCore when a button is pushed on the remote. Thanks alot!

Thank you! Bought two of these today and this DTH worked right out of the digital box!

2 Likes
  • Aeotec NanoMote One (ZWA003-A)
  • Aeotec NanoMote Quad (ZWA004-A)

ZWA003-A is the NanoMote Quad per the unit I ordered/received today.

Can that be why it only shows that it has one button in IDE? Event log though does show all 4 being actuated. I cannot configure buttons 2-4 in ST Classic. I have it set to your DTH.

Save the settings and then wake the device up. When you save the settings it should log a message explaining how to wake it up.

I ended up setting to to use the Aeon Wallmote DTH, that enabled the 4buttons. Setting it back to Aeotech Nanomote and it kept them.

Did saving the settings and waking it up not work or had you already done that before I posted?

I didn’t get to try your method. I’d already got it operating the other way before I saw your post this morning.

Glad to hear you’re all set.

This handler works with the 1 button model and the 4 button model so it uses the manufacturer information to determine which model it is. The manufacturer report sometimes fails to get reported during inclusion which is why it’s not aware it’s the 4 button model, but it should request the report the next time it wakes up and fix the number of buttons attribute.

Thank you for DTH. I ran into the problem after installation, old smartthings app I use didn’t show an option for push or held button in smartapps and seemed to assign action randomly. Looking into the code I saw that capability “Holdable Button” was missing from the code. After adding it to DTH everything was fixed. I recommend adding it to the guthub code.

Which apps were you using because I’ve written handlers for several button devices and I’ve always just used “Button”. (Hubitat apps require Holdable Button for the held command, but their button implementation is completley different.)

Holdable button has also been deprecated and is not listed as a capability in the new documentation

I’m having the 4 button issue also, however it won’t update in the new app. In the classic app, as well as my SmartThings IDE, it does show as 4 button.

On the current app, it only shows one button, and does not give any options to define even what that button does, and under the log, no matter what button was pushed, it just say button pushed, instead of which one.

It looks like the new mobile app requires additional meta data and it also uses the new attribute “supportedButtonValues” so I just released a new version that has those things.

Unfortunately that doesn’t solve the problem of the button number not being displayed in the Activity History or the inability to set actions within the device details for a specific button number.

That functionality doesn’t appear to work in any of the built-in handlers either so I’m assuming ST doesn’t support it, but you can still assign actions for each button using the built-in SmartApps like Smart Lighting and Button Controller.

If you know of a built-in handler that supports assigning actions for each button within the device details of the new mobile app and/or displays the button number in the Activity History, let me know.

1 Like

Hi,

When using Webcore, double-tapping is not a configurable option. I can only configure ‘pressed’ or ‘held’.

For buttons, as opposed to only four (I have the quad), WebCore shows 32 buttons available for configuring.

Does everyone else see this in WebCore, or is there something different about my instance?

The device doesn’t support double-tapping because that’s what it uses for inclusion/exclusion.

1 Like