[RELEASE] Greenwave PowerNode 6

Hi @Alwas,

I was working with @saosinx88 on a DTH, and no matter what I did in the DTH, his device always polled every 6 minutes. I don’t actually have one of these devices to test with, but you’re more than welcome to take these DTH’s I tried:

This one is what we were trying to use (only the parent DTH was modified). It’s been a couple weeks since we tested, and I can’t remember all the changes we made:
https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/copycat73/greenwave-powernode-6.src/greenwave-powernode-6.groovy

This one was based off of the Zooz device. Again, I can’t recall all the changes that were made, so the code may be a bit sloppy:

Mine was behind a fridge and didn’t want to start messing around with it. @Smartphi’s Frakenstein appears to work well, on/off like before, and now the 6th end plug works, which is quite masterful! So I’m happy with that, will monitor for a few days. Tried yours @johnconstantelo and it only came up as a generic “Switch” single device, the children weren’t created. Still had to use Z-Wave tweaker to get rid of the LED flashing every 60 seconds.
It’s hard working on a DTH if you don’t have the device in front of you, @saosinx88 i think you should send one to Mr Constantelo :crazy_face: I’m also stuck with 6 orphan devices I’m unable to delete at all now, need support to delete them for me.

I offered haha

Yeah, I can’t remember all the changes that were made because there were so many and I was focused on trying to nail down specific issues one at a time. I tested with a “virtual device” and also had orphaned child switches, but I was able to eventually delete them in the IDE after a while.

I ran into a problem not being able to force remove it as well, but had to go into IDE, delete all the child devices first, and then I could delete the parent.

1 Like

I think the way to go is first delete all children manually, then exclude the parent device, turn on exclude and tap the switch, THEN the parent finally disappears. It’s not the easiest device to work with in the world! But any future work should be based on Frankenstein, he’s added the sixth plug, and deleted the defunct USB child devices. Power reporting must be possible because one of the 4 original Greenwave parameters has per cent of power report.

Good tip @johnconstantelo, never heard of that one before, wait a few hours then you’ll be able to delete Z-Wave devices! :+1:

Now, none of the child devices are joining upon inclusion. Odd…

exclude the parent again. when adding, the parent comes first don’t click save until the children appear.

I’ve deleted and done it 3 times with this new Frankenstein DTH and the Zooz power strip child being the only ones available… Never finds the child.

I would replace that Zooz child dth, with the Frankenstein child dth posted above…

If there was a raw way of copying that, I would haha I’ll try on desktop.

1 Like

just a quick update, correction:

the main switch does in fact turn all the child switches on/off but you need to go into the main devices settings/cog wheel in the smartthings mobile app and choose 500 or greater in the 'Main Switch Outlet Delay" user options.

*disabled = no delay but this results in commands not executing

snippet:
input “mainSwitchDelay”, “enum”,
title: “Main Switch Outlet Delay:”,
defaultValue: “0”,
required: false,
options:mainSwitchDelayOptions

or edit line 213 defaultValue: “0” change to “500” , save, publish in graph ide

1 Like

Great find! Looks like it’ll turn the power of all the child devices off, but not on. Very intriguing.

It works for all Children on too tested., try increasing delay to 1 second. Other than that could be cloud SmartThings delay or Mesh gremlins .

Not sure if anyone will see this as its an old thread. However seems to be the most current.

GreenWave 6 port switch.

I added the parent and child DTH which worked great in ST. I have the 6 ports and the master. They all function independently, and the master. However in the current ST app does not show the current “port status” they always look “ON”, when you click on the tile itself it and go into the screen where it shows power meter, it lets you toggle the device connected to the port on or off.

From the main screen in ST while they all show “on”, it does turn a port off (but the icon never changes) with a tap, but it wont turn it back on with a tap, you have to go into the port itself to turn it back on.

Does this make any sense?

Thanks!

SmartThings Version 1.6.51-435

Actually after watching it for a few hours, its just extremely slow to catch up, can range from minutes to hours, to never.

Hi all. I had a PowerNode 6 that I tested with ST Classic and it worked great but now in the new ST ecosystem these aren’t working. I’m using the DTH and child DTH that were posted on June 2 by @Smartphi.

The parent and its children all show up, but on new ST, the children are all gray with no control ability. In ST classic I can control them however my understanding is ST is killing classic soon plus I’ve already migrated my system to the new ecosystem.

Anyone experience this?

Josh

Yes, same thing here. Very frustrating.

Hi Everybody,

Yes, here is the same issues.
Does anybody tried to updated the child device handlers?

Does anybody has a solutions for this issue?

Thanks

Yes I do!

I found a clue in the following conversation thread:

[RELEASE] Zooz Power Strip VER 2.0

The relevant post is:

[[RELEASE] Zooz Power Strip VER 2.0

Wherein the author of the Zooz DTH on which the Greenwave PowerNode 6 DTH is based can be seen to have written

Nope…

I believe the issue is that you joined the device prior to 8/16/2020 and the only way you’re going to solve the problem with the child devices not working in the new mobile app is to delete them and save the settings so that when they’re re-created they won’t have a componentName or componentLabel.

Update: That’s based on the assumption that you’re getting a network error when you attempt to control the child devices in the new mobile app…

in response to a user witnessing nearly the identical problem with his Zooz as we are with our GreenWaves.

So in an aha! moment, I went to the IDE Device Handler page, edited GreenWave PowerNode 6 Zooz Frankenstein VER 2.0

(not sure if this link will work for non-me users, but in either case it’s the Greenwave/Frankenstein DTH parent, NOT the child)

searched for lines containing componentName or componentLabel, and commented them out, as thus:

Blockquote>

[
completedSetup: true,
isComponent: false,
label: “{device.displayName}-CH{endPoint}”
// componentLabel: “CH {endPoint}", // componentName: "CH{endPoint}”
]

Then, I had to Exclude and re-Include the GreenWave device, but once that was done the master device plus all the individual outlets all appeared and once again were controllable, and accurately indicated status, from both the overview and the details screens.

1 Like