[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

#165

any idea as to why it says "you can now visit http://your.ip.address:port in a browser or send POST requests to it? instead of listing my IP?

when I try and go to my IP address it says “cannot GET”


(Greg) #166

Seems my ReadMe didn’t push with the latest version.

Check out the updated readme here:


#167

when i put the IP address of the pi followed by 3000 and assistant i’m greeted with a screen that says “cannot GET / assistant”


(Greg) #168

I’m not sure what you’re trying to do here?
Sounds like you’re trying to open it in a browser? You need to send POST requests to the IP and Port


#169

so I tried to leverage webcore to test. i used ifconfig to determine my ip addresses, netgear router so it’s 10.x.x.x but it didn’t work. Also tried the other IP address 127.0.0.1 but wasn’t surprised that didn’t work. Not really sure what I’ve done wrong


(Greg) #170

You need the IP and port of the machine relay is running on.

WebCore looks OK.

Have you tried disabling silent start in the config to check it announces ok?


#171

I’m also unable to get Webcore to trigger AR. I’m running AR v2.1.1 on Windows 7 and can successfully trigger an announcement using Postman.

(This is a piston just for testing. I am triggering it manually.)


(Greg) #172

change your variable Command to have a lower case C, i.e.
string command = "the rain in spain"


#173

Thank you so much, it’s working now.


#174

The curl command shared in this thread didn’t work for me on Windows 7 command line because of issues with quotes. Replacing the apostrophe with quotation-mark, and putting a slash before other quotation-marks makes it work.

so convert this:
'{"command":"hello world", "user":"johndoe", "broadcast":"true"}'
to this:
"{\"command\":\"hello world\", \"user\":\"johndoe\", \"broadcast\":\"true\"}"

The full command then is:
curl -d "{\"command\":\"hello world\", \"user\":\"johndoe\", \"broadcast\":\"true\"}" -H "Content-Type: application/json" -X POST http://192.168.1.99:12345/assistant


#175

so when I change the config and disable silent start, i indeed hear the broadcast across all of my devices. yet the webcore step still isn’t broadcasting. i have the IP set to the same thing I do in the config file, so I’m at a loss why this isn’t working.


(Rob Whapham) #176

I see some mention earlier in this post that this won’t install properly with node v10; is that true? Does it require v8 to install and run? Thanks.


(Greg) #177

Share your piston?


#178


(Greg) #179

That’s odd. Are you 100% sure the piston is triggering?


#180

set up full logging in webcore and here’s the log

+1ms ╔Received event [Front Door Sensor].contact = open with a delay of 188ms
+71ms ║RunTime Analysis CS > 13ms > PS > 48ms > PE > 9ms > CE
+73ms ║Runtime (38714 bytes) successfully initialized in 48ms (v0.3.108.20180906) (71ms)
+75ms ║╔Execution stage started
+85ms ║║Comparison (enum) open changes_to (string) open = true (1ms)
+87ms ║║Cancelling condition #4’s schedules…
+88ms ║║Condition #4 evaluated true (7ms)
+89ms ║║Cancelling condition #1’s schedules…
+90ms ║║Condition group #1 evaluated true (state changed) (10ms)
+93ms ║║Cancelling statement #12’s schedules…
+118ms ║║Sending internal web request to: 10.0.0.74:3000/assistant
+121ms ║║Executed virtual command httpRequest (18ms)
+122ms ║║Requesting a wake up for Thu, Oct 18 2018 @ 5:07:15 PM EDT (in 20.0s)
+128ms ║╚Execution stage complete. (53ms)
+129ms ║Setting up scheduled job for Thu, Oct 18 2018 @ 5:07:15 PM EDT (in 19.994s)
+139ms ╚Event processed successfully (139ms)

(Greg) #181

Hmm.
Can you import this piston and see what happens?


#182

I wish to clarify one aspect of the JSON return. If I use POSTMAN to send a ‘Custom Broadcast - No User’ with content such as “The quick brown fox jumps over the lazy dog”, I get a typical JSON return of -

“audio”: “http://10.1.1.4:3000/audio?v=53”,
“success”: true

I also get the voice response from Google Home successfully.

When I navigate to http://10.1.1.4:3000/audio?v=53, the browser will play the message -

“Ok, broadcasting now”

I was anticipating this audio file would be the original broadcast message “The quick brown fox jumps over the lazy dog”?

Is my mindset in error?


(Greg) #183

Yes. The audio response is what you would hear from Assistant if you asked it the question.
If you asked how tall is the empire state building, then that audio file would contain the audio with the response to the question


#184

Thanks. I can see now “command only” with the question elicits the appropriate audio file. I think I had “Converse” or “Broadcast” in the mix.

One more thing. If I ask the weather, i’m getting degrees Fahrenheit. My localisation is set to Celsius in the Google Home app. Is there somewhere I need to set it in the relay?