[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(Mohit Sud) #124

has anyone solved the issue where the Google Home speaker does not say anything, but otherwise it states Conversation Complete


(Aesgarth) #125

For me, the solution to that was to turn off IPv6 on my router.


(Joe Lawson) #126

I guess this is the issue I’m having as well. I checked and IPV6 is not enabled on my router so not sure that is my problem. If anyone finds a solution please let me know as it appears I’m having this same issue.


#127

@Kees_de_Kraker - The Google Assistant API does not support turning on the microphone for any device other than the one from which the request was issued, for security/privacy reasons.

@joetlawson, @Mohit_Sud - If IPv6 is not the culprit, you need to make sure that whatever device you’re using to run the relay (e.g. RPi) and your Google Home devices are on the same subnet. Also, you need to ensure that the account associated with the relay is linked to the devices in question. You can test this in the Google Assistant on Android devices by typing e.g. “broadcast testing testing 1 2 3”.


(Mohit Sud) #128

@mpaik - Thanks for the feedback. I suspect my issue is different sub nets…I’ll correct this today and try it out and report back.


(Mohit Sud) #129

@mpaik - I tried the same subnet but it did not resolve the issue. Do you have any other suggestions? I am 100% sure the same google accounts are used.


#130

And the oauth file you downloaded is definitely for a project using the Assistant SDK? What are you getting from the console when you try to run relay? Are you getting a good response from your json command?


(Kees De Kraker) #131

Thanks for the quick reply.
It does make sense not to be able to initiate listening from security perspective.


#132

And you have verified that the accounts are “linked” with the GH devices?


#133

Everything works, but preset.
I see some previous error reports about preset. How did you fix the issue?

Literally, everything else works, but preset. Broadcast, converse, all works.
However, whenever I send something as preset, server seems to receive nothing.
Nothing happens when I send preset.

Any thoughts?

Server is running on Raspberry Pi 3B+.
I had a clean installation. (after many trials and finally using v8.12.0 of node…)


(Eric) #134

It is the verbose in your command the wakeup command is wake up and dinner should be dinner time.


#135

Thank you for the reply.

That makes sense, but it is still a surprise to me.

Where did you get the correct preset commands?

These are the ones posted in Assistant Relay github which do not work.

Available Commands

  • wakeup
  • breakfast
  • lunch
  • dinner
  • timetoleave
  • arrivedhome
  • ontheway
  • movietime
  • tvtime
  • bedtime

(Eric) #136

Trial and error and https://support.google.com/googlehome/answer/7531913


(Greg) #137

Those are the commands you can send directly using the broadcast parameter.

I’ve built in functionality to AR that means you can use them without having to faff with the broadcast stuff.

They should work and I did test them. Will take a look tomorrow


(Mohammad Subhan) #138

Hello, I am using this on windows. I do hear the initial audio from GH, I even here audio if I do this:

curl -d ‘{“command”:“hello world”, “user”:“goku”, “broadcast”:“true”}’ -H “Content-Type: application/json” -X POST http://192.168.170.1:3000/assistant

But for some reason, i cannot hear any audio from the webcore, nor do I see any new messages in google activity from webcore.
I am not sure what am i doing wrong. Oh and also, I am using google wifi so I also looked into the setting and ipv6 is disabled.
Any help is appreciated. Thanks.


#139

Yeah, I am seeing the same thing now. I’ve moved to the beta branch of Cast-Web-API. It now support broadcasts using a ST device instead of JSON requests.


(Joe Lawson) #140

They are on the same subnet I had this all functioning with v1 with no issues. I just downloaded the same authentication key for the version 1 project. I heard GH announce it was setup and running but no other audio comes through even though the console confirmed it received the command.


#141

Can you share your rest of the magic words to trigger other preset messages?

“wake up”
“dinner time”


#142

If I understood you correctly, should we send those preset commands as broadcast to trigger preset messages, not using “preset”?

So, use
{“command”: “wakeup”, “broadcast”: “True”, “user”: “john doe”}
not
{“preset”: “wakeup”, “user”: “john doe”}?

I don’t think broadcasting worked, but please confirm.


(Eric) #143

The only other one I use is. arrived home