SmartThings Community

[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(Aesgarth) #62

Yes, broadcasts are showing up in my activity…

### Search and Assistant

#### Said [broadcast WebCore test broadcast](https://www.google.com/search? q=broadcast+WebCore+test+broadcast)

Ok.

Broadcasting now.

Details•Assistant

(Greg) #63

OK, that means it isn’t an issue with Assistant Relay.

Do you have IPv6 enabled? There seems to be an issue. I would suggest checking here: https://github.com/endoplasmic/google-assistant/issues/52


(Steve) #65

I reinstalled Raspbian and everything and got it to work-ish. Commands are being received by assistant relay. They are showing up in ‘my activity’. I’m in the exact same boat as Aesgarth. No audio is happening. I tried disabling IPv6 in my router config to no avail.


(Steve) #66

Should this be connected to my google home network and process the same commands in the same way?
Please tell me if this is the expected behavior OR if these mean that it isn’t setup correctly:
For example, I tried to use it to launch a routine I have setup in the Google Home app. “Showtime” (which lowers my projector screen and turns my av systems on etc). If I say this into my phone it works. If I speak it to any Google Home in my house it works. If I send this command through the relay the response is something about the Showtime cable network. ; ) My “Showtime” routine simply turns on a virtual smartthings switch called “showtime”. The command “turn on showtime” doesn’t work through the relay either. However, IFTTT triggers do seem to work. Also, commands such as “volume 30 on front room” don’t work either. It’s not sure what to do with that. And as posted above, I don’t get any broadcast audio through the relay.

Thank you so much!


#67

Yes, I get that error too. Just ignore it and continue with the verification. It will work.


(Greg) #68

The relay needs to be on the same network as your Google home devices. The SDK it uses doesn’t support routines etc yet, although I’m not sure why you’d want this when you can trigger those devices to perform actions directly from webcore


(Aesgarth) #69

Thanks! turning off IPv6 fixed it!


(Steve) #70

Mainly I wanted to be able to control the gh volumes from webcore, but it looks like cast-web can help me do that. I also wanted to be able to send a command like “play (music from google play) on (speaker group)” from webcore. Is there a way to accomplish that? (It could be an obvious duh type of answer… hahahah)

As far as this working, no luck so far.
So the minis were on the 5 ghz network. The chromecast audio parts of the minis were on the 2.4 ghz network with the raspberry pi running assistant-relay. I changed all the minis over to the 2.4 ghz network too. I also disabled DHCP (IPv6) from the WAN setup on on router setup.
Still no audio. Huh.

curl -d ‘{“command”:“hello world”, “user”:“homie”, “broadcast”:“true”}’ -H “Content-Type: application/json” -X POST http://192.168.0.14:3000/assistant

relay result:

Received command broadcast hello world
User specified was homie
Conversation Complete

Any more suggestions? I’m not a quitter but I’m new to this lol, so I’ve no idea what else to try. You all are awesome thank you so much.


(Aesgarth) #71

Did you reset the relay after changing router settings? I didn’t immediately and it didn’t work but still reported like yours did… Restarting it fixed the problem…

I also disabled IPv6 on the lan side…


#72

There is a way to do this but it requires creating multiple Google accounts, authorizing those for relay and then registering those accounts on specific GH devices. For example, if I create a google account named ryansofficeghmini@gmail and register that account only to my office device, I can then create a second dummy relay user called office. I would then use that user when issuing the command to relay and it would only play on my office device, since that’s the only one that is registered to that account. There are detailed instructions out there if you really wanna try it but in the end it’s not really worth it, IMHO.


(MacTechGenius) #73

Just upgraded from V1 so it appears to be working according to the output. But my google homes don’t say “Hello World”. Any tips please?


#74

Have you tried disabling IPv6 on your router? If not, do so, then reboot your GH devices and your Relay device and try again.


(Greg) #75

I’d also suggest checking your OAuth file and redownloading it. You might have the wrong one or an old version


(MacTechGenius) #76

Does this have to be disabled? I have some services (nextcloud) that I am hosting on IPV6.


#77

No…but that is the only way that I got mine to work. I have a netgear router and when I had IPv6 enabled it appeared that each of my devices (2 GH’s and RPi) were on a different network than my relay device. I don’t know whether this is an issue with the Assistant SDK or Raspbian. I’ve also tried playing around with the different modes I have available on my router for IPv6 (ie. passthrough, DHCP, etc). So far none of them have shown to be compatible with Relay. If you go to myactivity.google.com and you see your Broadcasts there even though you hear nothing from your speakers, then its a good chance that’s your problem. If you don’t see the broadcasts in your activity then it’s probably an authorization problem. Only way to be sure is to give it a shot and see what happens.


(Ryan Murphy) #78

Does anyone have this pushed to Docker Hub yet? I’d like to run off my Synology NAS since I already have some processes running through that.


(MacTechGenius) #79

I see it on my activity…so it looks like IPV6 is the culprit. Too bad I can’t disable it. Hopefully google will fix this soon


(Peter) #80

Hey guys, I’m a bit stumped here and I was hoping that you may be able to help. I’ve got everything up and running and I am able to setup and get running the relay (confirmed by response on GH). But I cannot post a broadcast through postman or webCoRE. All equipment is on the same router and I have disabled all firewalls on this windows 10 machine as well as opened ports. Something tells me the web service is not running properly but I’m not sure how to troubleshoot from here. Any advice is really appreciated! Thank you!


(Greg) #81

Anymore information? Any errors, log of what the console says?

The console should tell you it’s running, and you should be able to hear an audible output on first launch


(Peter) #82

Thanks for responding, Greg. Yes, the console is up and running and I receive audible output from GH on first launch. When I try http://10.0.0.3:3000/customBroadcast?text=test with postman, I receive a status: 404 not found - Cannot POST /customBroadcast. If you could point me to which logs you’re referring to, I would be happy to have a look.

Thanks again