SmartThings Community

[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome
#456

If I properly understand what you are doing here, this is not your hub ip address you should be using but your mac ip address since you’ve installed assistant-relay on your mac.

(DJAC) #457

I agree . How people have not done this sooner is baffling. Are you guys actually ok with breaking immersion. I have sent this thrice.

(Christian Terp) #458

What do you mean - who is AR?

(Eric) #459

AR stands for assistant-relay.

(Dan Eccher) #460

Agreed, I realized that and switched it. Now it works, sort of. When I execute it I can see “Hello World” on the mac within the relay, but nothing happens on my Google hubs and Minis. I tried specifying a command “turn on the front porch light” and the same thing. Displays in the relay on the Mac, but nothing happens on the Google devices. Am I missing something?

(Dan) #461

Try disabling IPv6 on your router. It is know to conflict with Google Assistant Relay.

(Dan Eccher) #462

Thank you. I disabled IP v6 on my modem/router, my SmartThings WiFi, and my computers. No improvement.

(Dan) #463

What version of “node” are you running? It needs to be v8.x, which I am guessing you’re running as you wouldn’t get as far as you have already, I think…

(Dan Eccher) #464

I made sure it was the exact version in the video.

(Ice Bear) #465

Sorry to pop in here … Got this working over the weekend. Super sweet and solid. I know his has been talked about previously, but has anyone been able to get commands to work to play things like Spotify? Or any work arounds to do some sort of routine with those commands built in and then call the routine via an AR command?

1 Like
(Ice Bear) #466

I searched this thread for the other posts of similar issues, and went bonkers wondering if I dreamed it – its actually reported on the issue tracker:

#467

Hey guys! Anyone know how to change the name it says when the broadcast goes out?

(cp) #468

I finally installed and got the relay running after I uninstalled nodejs v10 and installed nodejs v8.11. when I send a test command from postman I get a reply from my PI saying it is quiet hours. If I comment the after hours bits within the function and rerun the relay I get an error returned to postman after I send the command. Also, when I run the relay on the screen it shows it is running successfully and awaiting a command but I do not hear my home speaker mention the relay is running…I do have that bit set to true within the config file. Any ideas?

(Dan) #469

Disabled IPv6 on your home network’s router. That usually fixes it.

(cp) #470

Thanks Dan I’ll give that a go and see what happens. BTW when I registered my device (rasp PI) with Google IOT I identified it as a speaker as I didn’t see a better choice. What did you identify your device as?

(Dan) #471

It has been quite a while, so I don’t recall specifically. However, I did write up some notes for myself to help me recall all of the steps required to get this up and running. You can take a look at my guide in my GitHub repository. Note: The Groovy Driver code in this repository is tested to work with Hubitat. I have never tried it on SmartThings. However, the MS Word document is really all about setting up the Raspberry Pi side of things. This guide may help answer your questions regarding the process to set up Assistant-Relay v2 on a RPi.

#472

In your Google Account, change the first name to whatever you want it to say

(MacTechGenius) #473

Can we use google home to trigger Nest from Home and Away? Now that Nest is abandoning their API this might be the loophole…

(Eran Salomon) #475

I switched from Ver. 1 to 2 and used a different computer for this - I turned off the other computer that was running the ver. 1. The relay seems to be running with no issues but I’m unable to discover it in the Smartthings app for some reason - I give it more than 10 minutes to search with no success - any idea why? I did remove the old ver. 1 relay before started the discovery

(Dan) #476

There is no way to ‘discover’ the assistant relay within SmartThings. In fact, Greg Hesp no longer even supports a DTH for SmartThings, IIRC. The expectation these days is that all calls to assistant-relay will be handled within something like webCoRE using http POST calls.