SmartThings Community

[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome
#413

I have been having the same issue over the past few days I thought I broke something when I switched router but I guess not

(Dan) #414

Try disabling IPv6 on your new router… This is a known issue that prevents the assistant-relay from working properly.

(Mickey Miller) #415

Hey, the post after that mentioned IPv6 was the issue. I’m not sure if my router( eero ) software updated and enabled this or what, but I haven’t messed with those settings in a long time. That being said, disabling it fixed the issue.

Thanks so much @ogiewon !

1 Like
#416

Thanks @ogiewon I believe thatis my issue with my new router IPv6 is enabled but for some reason I’m not able to disable it I will have to figure that out once I do I’m sure Assistant relay will be back online

1 Like
(DJAC) #417

I am hating this… Why is it taking so long. Is there no word yet

(Christian Terp) #418

Is it possible to make it broadcast in other language than English?

#419

Yup, mine is broadcasting in Canadian French. Can’t remember what I tweaked tho in the settings.

#420

Sorry to be that guy but could someone point me to the latest and greatest windows install instructions?

I had version 1 running on my PC a long time ago but previous install methods are not successful. I already have node.js running for Cast-API and Harmony-API.

(Dan) #421

What version of NodeJS are you currently running? Google Assistant Relay seems to only work with NodeJS v8. Newer versions appear to be incompatible.

#422

Thanks, things snowballed since my last post so I’ve uninstalled everything node.js related and installed a fresh version (v8). At one point before I saw your post I upgraded to 10 and didn’t find a downgrade path. AR is running humming along happily, now its time to go back and install everything else :dizzy_face:

I know I’ll probably have to do this again so a note for future me:

  1. DL/install Node.js v8

  2. DL/install git for windows

  3. DL/unzip AR

  4. Enter command: “npm install [AR directory]”

  5. Follow config steps: https://github.com/greghesp/assistant-relay#configuration

  6. Create .bat file that contains “npm run start”

  7. Make Task Scheduler launch .bat file at startup.
    —Start in: [AR directory]

1 Like
#424

I have been using Assistant Relay successfully for some time (thanks Greg Hesp).

I have one particular ‘keep alive’ function that sends an Assistant Relay command silently to a device every 20 seconds. My problem is that, sometimes, the command is announced throughout the house over the Google Homes - “Incoming broadcast…Turn on VoxLox”.

It happens regularly when the home automation system is rebooted; other-times it happens with no apparent catalyst.

{“command”:“Turn on VoxLox”,“converse”:“false”,“user”:“me”}

Also tried -

{“command”:“Turn on VoxLox”}
{“command”:“Turn on VoxLox”,“user”:“me”}

I assume some part of the POST message is truncated and becomes a broadcast instead of a command. Can you give any guidance on how to stop this?

(Greg) #425

Can you try adding broadcast : false to your request?

#426

My setup - Google Assistant Relay running on a Raspberry Pi; home automation system by Loxone (sends POST commands).

Yes, I’ve now tried -

{“command”:“Turn on VoxLox”,“broadcast”: false}

I get the correct ‘silent’ command activation (every 20 seconds) for a few minutes after modifying the POST command (which also requires rebooting the Loxone home automation system). Then a single broadcast announcement happens. Then continued ‘silent’ command activation (every 20 seconds) ongoing.

It’s like the command is cached somewhere from the reboot process…and then finds it’s way out as a broadcast later.

(Craig McFarlane) #427

Hello. I am looking at installing this. Is there a way to broadcast or send audio to a single google home device?. I have fridge contact sensors for example and dont really fancy waking the Mrs up in the middle of the night because i left the fridge door open for more than a minute.

I was able to do this with Alexa but have moved over to Google Home.

Thanks in advance.

(Greg) #428

Not directly.

The only way would be to create a new Google account, link it to only the device you want to use, and then pass that user along with the request

(Craig McFarlane) #429

Thanks for the reply. Am I able to have my main google account and also this alert account assigned to the same device at the same time?

(Greg) #430

You can only send the request as one user at a time. If your main account has all devices linked, then your announcement will go to all devices.

(Craig McFarlane) #431

Thanks. I guess what I am asking is this.

I have 5 google home devices all running under account1

Can I create another account say account 2 and assign that also to one of the 5 google home devices?

So in effect 1 device will have two accounts assigned to them and four devices the single account.

I will then use account2 to do the announcing?

Or am I getting this all wrong? Don’t want to buy another google home just to announce stuff.

Thanks in advance.

(Greg) #432

Ah, yes thats correct. You can have many accounts assigned to several devices

(Craig McFarlane) #433

Brilliant. Thank you.