SmartThings Community

[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(brayton) #306

if this is the first time you are running it you’ll need to do
$ npm install
then
$ npm run start


(Joseph) #307

Yeah, I did everything in the guide.


(Dan) #308

Does anyone know the proper commands to use ‘pm2’ to run assistant-relay v2 on a Raspberry Pi? I have been using pm2 for months with my assistant-relay v1 instance. I have a brand new RPi and I’d like to migrate to v2, but I would prefer to continue using pm2 to run assistant-relay on startup of the Pi. So far, I am not having any luck.

UPDATE: I figured it out.

From within the assistant-relay directory

pm2 start server/app.js --name "assistant-relay-v2"
pm2 save


(DJAC) #309

Does yours also so ’ assistant relay is broadcasting… It sais… .’
Did you find a workaround?


(Dan) #310

Yes, Google changed something recently which adds the “Broadcast from ‘username’, …” there is nothing that can currently be done about it at this time.


(DJAC) #311

@ogiewon Thanks for the response. I think Google did it on purpose since its way too specific as if they didn’t wanna make this a
Seamless integration of which it felt like…
Hope this doesn’t last


(Joseph) #312

I get a bunch of errors on npm install


(Dan) #313

You can try the steps outlined in my personal notes I took during my recent successful installation of Google Assistant Relay v2.0 on my RPi 3B+. You’ll need to be able to download a view a MS Word Document.

https://github.com/ogiewon/Hubitat/blob/master/Drivers/google-home-assistant-relay-v2.src/RaspberryPi-Assistant-Relay_v2.docx

Note: Ignore the Hubitat-specific Device Driver in the same GitHub repository. It will not run on SmartThings without some edits. Most ST users seem to be using webCoRE to make the httpPost calls. I like the simplicity of a Device to handle that work for me.


(Naseem Rahman) #314

So there is no way to disable username?


(Dan) #315

Not until Google changes their end.


(Joseph C Thomas) #316

@ogiewon

Whoo hoo! I followed your instructions, and it’s now working!

Thanks for taking the time to create such detailed instructions. These are the goto setup instructions for the Raspberry Pi: https://github.com/ogiewon/Hubitat/blob/master/Drivers/google-home-assistant-relay-v2.src/RaspberryPi-Assistant-Relay_v2.docx


(Dan) #317

Glad to hear those instructions are helping others. Most of what is in there is just a compilation of best practices I gleaned by reading through this entire thread, as well as the previous v1 thread. Most of the credit is owed to @ghesp and @Ryan780. Ryan’s Github instructions are where I learned most of the details.


(Ram) #318

Wow, this should be the one everyone should be referring for the setup and it should be linked on the top.


(Dan) #319

Thanks for the kind words. However, I am really not planning on actively maintaining this document as I really created it for myself to be able to recreate my Raspberry Pi should it fail, or I decide to upgrade it. It should also be converted to something a little more web friendly versus a MS Word document.


(DJAC) #320

is there any way to tell Google about this constant announcing of the sender ‘sender Broadcasting’ It is really annoying and not really needed.
By the way. Great work.


#321

Is there any way to change the language of the voice used (i.e. the accent)? Right now I have the American voice (whilst I live in England…) but changing language to “en-GB” doesn’t seem to change anything.


#322

Not sure this has anything to do with the relay

Just read this
https://support.google.com/googlehome/forum/AAAAXWcshA0-tCyTm_Hkbo/?hl=en

Looks like we are not alone


#323

See the issue I’m having is that my Google Home Mini speaks in British English, but if I play the audio file that the relay makes, it’s in American English.


(Greg) #324

I’m having the same issue so you guys aren’t alone. I’d suggest sending some feedback from the Google home app asking them to make the “new broadcast from” message optional


#325

So I managed to fix the problem of language not changing in the audio files. I edited the conversations.js file in the google-assistant node-module folder and changed “en-US” to “en-GB”. It looks like the config.js for the relay isn’t changing the language properly.