[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(Ram) #246

I need the help from the experts for sure. I did reinstall from scratch and even started from Rasbian and installed the node.js version 8.12.0 with assistant-relay v2.1.1.

I got the message Assistant Relay is now setup and running for ram.

Getting the below error If I try to access using http://localhost:3000 or using the ip
This site can’t be reached
localhost refused to connect.

I would really appreciate if you could help me to resolve this issue. I don’t know what went wrong twice.


#247

How can this be used with SHM or other smartapps that cant sent POST requests? Didn’t v0.1 have a device handler that created a device in ST, can that be used with v2?

Also is there a way to better sync the speaker output together, when I issue a broadcast the message is echoed thoughout my house. Each speaker is not playing the message at the exact same time.


(J) #248

I get the error:
Cannot find module ‘google assistant’

Install had some errors too.

Using node.js on a windows box.


(Brigidino) #249

Hi folks, do you think is possible to run the node.js code under a free online service?
I do not like to use another device such raspberry


(Brigidino) #250

i’m triyng too, it is very painfull. At th moment it is not running as well


#251

Interesting developments are occurring with the Google Broadcast feature -

“The Broadcast feature for smart speakers and Smart Displays will now be more of a two way street than a simple broadcast. When you’re out and sending a broadcast users listening to it will be able to respond.”


(Sean Carter) #252

Anyone know if you can run this on android using Dory - node.js / javascript?

Trying to install it and getting the same issue as above can not find module google-assistant.

Any help would be greatly appreciated.


(Greg) #253

Wont work. It needs to be Windows or Unix based platforms


(Sean Carter) #254

Dang… had an old phone i wanted to use as a relay / smarthome controller


(Ram) #255

@ghesp, I have some update.

I just ran the command forever start server/app.js and looks like the server is running but got the below message.
warn: --minUptime not set. Defaulting to: 1000ms
warn: --spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms
info: Forever processing file: server/app.js

When I access my local host I’m getting the message “Dude, chill, it’s quiet time!”

I did change the time values to start as 25 and end as 25 didn’t work then tried 0 and 0 didn’t help
“muteStartup”: true,
“quietHours”: {
“start”: 25,
“end”: 25
},

chiiltime


(Ram) #256

If I make changes to the quietHours then how do I publish the changes? It looks like it is not taking it.


(Ram) #257

My assistant relay is working now.

I had to get rid of the quiet hours logic by commending out the code from app.js.

// if (global.config.quietHours !== undefined && (global.config.quietHours.start <= now || global.config.quietHours.end >= now)) {
// console.log('Got a command during quiet hours (start: ’ + global.config.quietHours.start + ', end: ’ + global.config.quietHours.end + ’ now: ’ + now + ‘). Ignoring.’);
// res.status(420).send(“Dude, chill, it’s quiet time!”);
// return;
// }


#258

The syncing is supposed to be fixed in later releases of Google Assistant.
As for sending broadcasts from SHM, there’s no way to do that natively but you can use a Virtual switch and “alert with lights” to turn on that switch. You can then respond to that virtual switch from something like webCoRE.