[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(Greg) #225

I’m not really sure why its failing on that.

If you see here:

It’s referring to that config file being missing, however it’s in the release as you can see. Just check you have those files?


(molano) #226

Hello, Trying to make this running in a docker env. Pretty far already, but I now get the following error when I try to authenticate my user.
name.json in /secrets folder is fine. I got the link for the authentication in my terminal, but after that it crashes so no opportunity to paste the key…

(node:18) UnhandledPromiseRejectionWarning: Error: Exited with code 3
    at ChildProcess.cp.once.code (/usr/src/relay/node_modules/opn/index.js:84:13)
    at Object.onceWrapper (events.js:317:30)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:915:16)
    at Socket.stream.socket.on (internal/child_process.js:336:11)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at Pipe._handle.close [as _onclose] (net.js:561:12)
(node:18) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:18) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Hope somebody knows how to solve this.

Thanks


(Jonathan Rider) #227

I have the files it is referring to, which is why it is puzzling me!

Did another clean install. I get the text saying ‘Assistant Relay is running for Jonathan’ but no actual announcement.

Then when I try to start it in pm2 so it stays on after a reboot, I get those errors.


(Jonathan Rider) #228

I’ve completely reset my Pi and started from scratch. Getting a different error now, but I don’t think it’s anything you can fix…

image


(Rob Whapham) #229

@Jonathan_Rider, you’ll have to use node v8. It looks like the output shows reference to node v10.12. I had the same issue and, AFAIK, Assistant Relay will not work with v10.


(Jonathan Rider) #231

Ignore me, it’s working!


#232

I’m running into a similar issue as a few others today. The quiet hours don’t seem to be working correctly. Setting both to 0 or 25 doesn’t disable them.

This is seriously a cool piece of software btw :slight_smile: I’ve been having a blast setting different alerts up!


(Greg) #233

Setting both to 25 should work, as it’s just getting the current hour in a 24hr format and comparing them. Since there’s no 25th hour it shows skip right past.

Make sure you restart the relay if you change config


(Steve ) #234

So I was having some problems so have done a clean install of 2.1.1

All set up fine, but now I also have the problem with quiet hours and no matter what I set the options to it always reports back as being quiet time (and I am restarting AR each time - it reports the ‘right’ restrictions be they start 0 end 1, start 25 end 25 and even tried some negative numbers). So right now I cannot get anything to trigger, odd!


(Greg) #235

I have a feeling there’s a logic bug with the quiet hours. Try setting them to a negative figure for now?

I’m currently rewriting the configuration so there’s a web UI for everything. Should ease the setup


#236

After doing some more fiddling around with the hours, I am having the same experience as Snacker. Basically setting to both to 0 or 25 or a combination of both doesn’t do anything and it just stays stuck in quiet hours even after a restart. I also tried setting quiet hours to a close time (to my current time) to try to get it “unstuck” out of quiet hours mode. Didn’t work. It finally stopped being in quiet mode after setting the hours to 23 and 1 in the config…not sure what’s going on here but it doesn’t appear to be working as intended. I only installed all of this yesterday (clean install on debian) if that helps at all.

edit* Setting them both to -1 put it into quiet mode again.


(DJAC) #237

Regarding having the script run on start up.
You said

‘Easiest thing is to add the command to start the script to the rc.local file. This will launch every time’

Please can you give a detailed explanation on how to do this.

Have no clue where to find this or what to type.


(Greg) #238

How strange.

I’ve completely rewritten the code anyway for quiet hours, so it’ll be in an upcoming release


(Kyle Salling) #239

I have tried this install in multiple ways and still not getting it to work. I have disabled ipv6 on my network and not getting the confirmation voice message. Also, I noticed when I am in the API dashboard under Google Assistant is says: Requests 1 Errors 1 Errors 100%

Although in the cmd line it shows conversation complete and does not throw any errors. Does anyone have any insight?


(Kyle Salling) #240

If I go to “My Activity” in my Google Home app I can see where the broadcast was sent but it never comes across my speaker.


(Greg) #241

I’m sure this is related to the same bug on Google’s side everyone else was having.
Have you tried disabling ipv6 on your router


(Eric) #242

My relay stopped working this morning. It is showing up on google but not broadcasting.

(EDIT started working again with no intervention on my part)


(Kyle Salling) #243

Yes I have disabled stateful and stateless dhcpv6 on my cable modem/ router and my wireless hubs are in bridge mode. The router did a reboot after changing the setting. Is there anything else I need to do to fully disable ipv6? The only thing I can think of is drop the IP reservations for all the connected devices and let them get new assignments from the dhcp server as they reconnect. Alternatively I could also take my wireless hubs out of bridge mode and let my smart things wifi hubs run the dhcp. Thanks in advance for any additional ideas you may have.


(Ram) #244

Hi Guys, I’m new to Raspbian and easy on me. I just got the pi 3 B+ and setting up one by one.

I’m running node.js version 8.

I was in the process of setting up the Assistant relay and running the program. After the setup and ran the command npm run start and got the following message but my connection is getting refused and not sure why it is…

Assistant Relay is now setup and running for ram

You can now visit http://192.168.XX.XX:3000 in a browser, or send POST requests to it

This is what I passed on the terminal:
curl -d ‘{“command”:“hello world”, “user”:“ram”, “broadcast”:“true”}’ -H “Content-Type: application/json” -X POST http://192.168.XX.XX:3000/assistant

This is the error when I try to send the message.
curl: (7) Failed to connect to 192.168.XX.XX port 3000: Connection refused

I have changed the port to other values 3350 and 445 but didn’t work either. Any help would be much appreciated.


(DJAC) #245

Sorry, I am still trying to figure what is the difference vetween V1 and V2 .
Is it stability. Are there more command fuctions?

So far, version 1 is working flawlessly. so if i dont have to upgrade then i will leave it for now