[Release] Google Assistant Relay V2.0 - Google Home Audio Notifications!

tts
requires_server
googleassistant
googlehome

(Nuno Martins) #205

Is there any docker image for this?


#206

i’m finding that i have to go into node.js and restart assistant relay. Is there a way to run this forever? what would the command be?


(Steve ) #207

Can you share any more details on this. I have set up a simple piston to post the command ‘stream [camera] on kitchen display’, but nothing happens on my home hub. If I simply speak it then all fine.

Command I am passing is: post request to [ip] with JSON {command, user, converse}

Terminal output suggests everything is triggering fine.

S


#208

Steve…

Sorry, but I’m not yet using Webcore to control the camera. I’ll be doing so soon.

Have you tried terminal command without Webcore to see if that works?

$ curl -d ‘{“command”:“Stream [your camera name] on [your chromecast device name]”, “user”:“[your username]”, “converse”:“true”}’ -H “Content-Type: application/json” -X POST http://[your IP]:[your port]/assistant


(Steve ) #209

Yeah, no joy. I just get the URL link to the audio response saying “sorry I’m not sure how to help with that”.

I may be missing the point as to the capabilities of this, but essentially if the action from a command is to say something, all is good, eg “what time is it”. However if the action is to do something, like stream a camera or turn a light off then it doesn’t work. Same outcome from curl, postman or webcore. I am assuming I must have failed to configure something somewhere!


#210

I’ve followed this link and it keeps Assistant Relay running continuously (and after reboot).


#211

Sorry Steve. I don’t know what the problem can be. It is very weird that some commands work for you and others do not.

@ghesp Have you seen this behavior before? Any ideas?


(Greg) #212

Does the account you setup AR with have access to the Nest cameras?


#213

when I attempt to test via windows 7 cmd, i’m getting a return of Dude chill it’s quiet hours
my config looks like this:

“port”: “3000”,
“muteStartup”: true,
“quietHours”: {
“start”: 0,
“end”: 0
},


(Greg) #214

What time did you test it?


#215

around 8:30am


(Steve ) #216

I had issues with 0 and 0 not stopping the quiet hours blocker. Changed both to 25 and worked fine.


(Greg) #217

How strange. Yes, change to 25/25 or something higher than 24 and it should work


(Eric) #218

I had the same issue I just removed the whole quiethours section from the config as a workaround.


(Rob Whapham) #219

I’ve tried both the script in the v1 and v2 RPiStartup folders but am having a bit of difficulty because I need to use nvm to start AR with the proper version of node (10 is my system default, but AR needs to use 8). Forgive me if this is an easy thing, but I’m new to node and definitely nvm. If someone could point me in the right direction for either using forever or installing a systemctl service that can lauch AR using a specific node version, I’d appreciate it. Thanks.

UPDATE: FWIW, I’ve created an .nvmrc file in the AR root directory, and all will work fine if I run ‘nvm exec npm start’; but that’s the part I’m having trouble adopting to either the ‘forever’ or ‘systemctl’ methods.


(Steve ) #220

Gahh, you’re a genius! I was specifying a user I set up to broadcast to a single unit, which of course has not linked all other devices to it. I switched it to the main user and all works fine!

(just news broadcasts to solve now!! :wink: )


#221

I had no success with either the v1 or v2 RPiStartup folders. The first line of the instructions in the link gets you a different variation -

  1. wget https://raw.githubusercontent.com/ryancasler/assistant-relay/master/RPiStartup/relay.service

You enable the relay.service using system.ctl.

The third line of relay.service is -

ExecStart=/usr/bin/npm start

I don’t know enough about nvm, but perhaps try editing the ExecStart line.


(Jonathan Rider) #222

I’ve been using V1 of this for a while, and finally took the plunge to install V2 after muting startup sounds became available. I had no problems with V1, but am getting the below error. Can anyone help? Thanks


(Greg) #223

Did you upgrade or fresh install. Do a fresh install as it looks like you’re missing some files for some reason


(Jonathan Rider) #224

Yes, I did a clean install. I’m quite the beginner on raspian, I only got one to install this!

I have deleted the folder and reinstalled from atratch, is that all I need to do?

I’m getting the same error!