SmartThings Community

[RELEASE] GoControl Smart Wireless Light Switch WA00Z-1

dth_wallswitch
dth_remotes
dth_lighting
#23

Hi @mtnbrit,

The GoControl Smart Wireless Light Switch is just that; a Wireless Light Switch with 2-Buttons and 2-Actions per button. So IMHO/experience you can only perform the actions I listed above. I actually do that. But if you use WebCore, you can also have a Piuston perform actions on the button push/hold based on time of day or mode your house is in.

E.g., Mode morning
Button 1 - PUSH -> Light upstairs is ON @ 30%
Button 1 - HELD -> Light upstairs ON @ 50%

(Aron & Kwang) #24

I’m new to Smartthings. How do I pair this WA00Z-1 with Smartthings to use to control Phillips Hue lights? Any step by step instructions available? Thanks!

(Mike Swallow) #25

I can’t seem to get this one to work. I’ve tried installing from the GitHub repo and also creating manually by pasting the code.

The device pairs, but I don’t see what I expect. When I view the device in SmartThings and go in to the properties, there is a big blue button on the left, two electrical outlet icons on the right. Beneath that is a dimmer slider. When I used this device in SmartLighting or other smartapps, nothing happens. I’ve removed and restarted several times. Am I missing something?

Note, steps I’m taking is as follows.

1.login to IDE, select location and hub.

  1. Add Repo. Owner: ajpri, Name: ST-GoContWirelessSwitch, Branch: master.

  2. Add device handler in IDE… either from code or from GitHub ST-GoContWirelessSwitch. (same result either way). Save and publish for Me.

  3. Add device in SmartThings, press button on GoControl and let them pair. Device adds and is as described above. Does not show two buttons, just the one button, the two electrical outlet icons and a dimmer slider. The device does not function.

#26

Which version of the SmartThings app are you using?

1 Like
(Mike Swallow) #27

I use both apps. The behaviour I described is in the classic app. It’s even more broken in the Samsung app.

(Mike Swallow) #28

Any thoughts? I’m eager to get this working. :slight_smile:

(Mike Swallow) #29

Does anyone actually have this working?