[RELEASE] GoControl Smart Wireless Light Switch WA00Z-1 (see post #79 for Nov 2020 version)

Currently clearanced out at www.zwaveproducts.com for about $10/each!

1 Like

I noticed in shows released only for button 3 yet DTH does not cover that.

I noticed on double press there is only a button 3 released. However, not sure how to access in web code as only shows listing two buttons

Given the time is short for support on the classic app, is there an updated DH or some way anyone has this working in the new Smartthings app?

I made the mistake of migrating and now I can’t update any smartapps that use these switches. I have several of them, and if I try to make any edits, it just says network error. In the history, it still shows a button press, but it can’t tell which button is pressed.

So I’ve read through this thread and I still can’t get this to work properly for both buttons.

I’ve recently moved my hub to the NEW smartthings. I was able to pair the GoControl switch successfully. I then created the Device handler mentioned at the top in the IDE and Self published. I then changed the GoControl to use this device handler.

My issue is that in SmartThings, I only see 1 button. It responds as a button press no matter which button I press. How can I get this to work so that each button can be referenced individually?

1 Like

I’m having the same issue, I upgraded a couple weeks ago and now even with the DH installed it only shows as a single button press or hold. If i set it to “pressed up” or “pressed down” it doesn’t recognize them.

I just noticed that my controls stopped working for this today and only registers as a single button. Is anyone working on updating this?

I am having the same issue previously noted. Only one button being reported.

I know what the problem is, but someone else will have to provide the fix.

On the new platform, buttons are handled differently. There’s a whole bunch of new button capabilities. And this DTH needs to be updated to work with those new button capabilities. since it’s still using old ones, they are being ignored, which is why only one button works.

Because I rely on text to speech, I don’t do any coding. (Trust me, you don’t want to do groovy with text to speech.)

hopefully one of the grandmaster coders who is familiar with the new platform will chime in. I’m going to tag couple of people who might be able to help.

@orangebucket @mwav3 @johnconstantelo @jody.albritton @darwin

It is possible that the stock “Z wave multi button“ DTH will work with this in the new app, but only in automations, not in smartlighting. If it’s similar to the Aeotec wallmote. Might be worth trying.

1 Like

Thanks for the vote of confidence @JDRoberts . I have a switch with electrical tape over it, so this will fit nicely over that for only $15.

I just ordered one, so hopefully I’ll be able to update the code for it. Started working on it now to add the JSON posts that fixed the similar issues with the Jasco switches.

2 Likes

It seems that Smartthings has done something with the newer app that breaks these buttons. I tried the stock “Go Control” device controls, and ajpri’s (which worked fine in v1) - and they only show one button now.

Read my post 2 posts above yours.

SmartThings did, indeed, change the way buttons work on the new platform, so custom DTHs have to be updated to use the new capabilities.

Apparently the author of this particular code is no longer maintaining it. So it only shows one button.

The good news is in the post right above yours: another community member is going to take a look at updating the code.

I bought this switch and was able to update its DTH to work with the new Smarthings/smartlighting apps and support both button presses again. This DTH can be imported into the IDE from my github at mwav3 smartthingscode master or from the link below.

Some notes about the new code:
I added code to directly associate this switch with other Zwave devices. This is in the devices “preferences” section (see screenshot below). The box and manual for this talk about associations repeatedly so I figure this should support them. If you’re unfamiliar with zwave association groups, here is an excellent post from @JDRoberts explaining it FAQ: Zwave Association between 2 devices

Note about associations - they are a nice feature of Zwave. If I was using this as a virtual “3way” switch on an existing zwave 2 way switch, or a zwave smart bulb, I’d probably do a direct association on group 2. This way, if my wife came home in the dark, hit that switch, it would always turn on, regardless of whether the Smarthings hub is online, connected, underwater, whatever. That’s because the association sets up direct communication between the button controller and switch, bypassing the hub. There is a downside to that though. The smarthings hub is like a “boss” that doesn’t like being left out of the loop. So, sometimes since “the boss” doesn’t know what’s going on, the status of a device controlled by association doesn’t always update properly on the hub/app.

I added buttons 3 and 4 for double tap. One problem that I just couldn’t overcome in the code though was that a double tap still initiates a single tap. ie, when you double tap up button 1, Button 3 triggers, but button 1 also triggers. I’m sure someone could write a webcore piston that takes can discard the button 1 press if you meant only for double tap to work, so use those buttons with care. If anyone has suggestions, contributions by PR are welcome.

If you just want basic “button 1 up” and “button 2 down” functions, that will work fine. You can also do “pressed” or “held” to differentiate that. You have to use the smartlighting app or webcore though. The “automations” feature of the new smartthings app just says “button” and currently can’t differentiate between multiple buttons.

This device defaults to sending both association and central scene commands. Advanced users can change that around to support only one or the other, or both. The way the programming works though, button 1 and 2 are controlled by “central scene”, and button 3 and 4 double taps are controlled through “associations” with the hub itself.

I hope this isn’t too confusing, and if you have questions or want to report issues, please ask.

Link to code:

2 Likes

It can, but you have to use the new button capabilities, and I don’t know if they are well documented. I’ll see if I can find a thread reference.

Yeah the last I saw was that there are 3 config options for the different views in the new app- Dashboard, Detail, and Automation. From what I saw in the developer documentation they said the “automation” view can be configured now, but won’t actually work to display the options configured by the developer until the actual App itself is updated.

I’ll wait until the CLI is out of “Alpha” release before messing with that at all. Hopefully they get that ironed out ASAP. At least for now, it can work in the smartlighting app and webcore.

1 Like

Great work on the DTH, btw! I’m sure a lot of people will really appreciate it. With the cost of this device having come down so far since its original release, it’s become an excellent switch cover option. :sunglasses:

One small note, nothing to do with your DTH, but just so people are aware of it: direct zwave association between a device which does not support S2 level security and a device which does mostly doesn’t work. So just something to be aware of if you have brand new latest tech Z wave devices and you want to include this one in the mix. most people won’t have to worry about that, but I just wanted to mention it.

1 Like

Tagging @Jeff_Klein @nicholashead @AnCyberTurtle @Hakarune @drdome @siuengr

image

It looks like @mwav3 ‘s new DTH Should let you use both buttons on the gocontrol WA00Z with smartlighting in the new V3 app, or with Webcore. See his post above. :sunglasses:

2 Likes

Thanks and very good point. If I knew that before testing this would have been out days ago, lol. I kept thinking I was doing something wrong in the coding, then noticed the pattern of it not working with my S2 devices and working with my older ones. Talk about learning things the hard way. :slight_smile:

1 Like

I have tried the new code by @mwav3 but smartthings does not recognize it properly still for anything except single press & single hold.

The detailed info from the cloud shows:
2020-09-28 11:53:27.465 PM PDT
moments ago
DEVICE button pushed GoControl Switch (Entryway) button 2 was pushed

GoControl Switch (Entryway) button 2 was pushed
[2020-09-28 11:53:20.512 PM PDT
*moments ago* ](https://graph-na04-useast2.api.smartthings.com/device/e74aa7f4-1cb0-45cc-b50c-cf470dbb63e7/event/763a3fb0-0220-11eb-af05-0a81c2147ddc?all=&source=&max=25) DEVICE button pushed GoControl Switch (Entryway) button 1 was pushed 

so it sees button 1 & 2, but the automations scripts only see a single button to press and hold and the the associations thing I can’t seem to get it to work right either. Here are the smartthings app reading from the device showing it doesn’t see 2 buttons.

Before @samsung effed up smartthings (under the old app) I could use button 1 & 2 for individual controls (6 variants of press/hold/double) and this is really aggravating that it’s almost useless now (no offense to the awesome peeps trying to unscrew what samsung did)