[RELEASE] GoControl Siren / Linear Siren / Vision Siren

I just released a version 1.2.1 that fixes the beeping problem. A few posts back I mentioned that a fix is in place to prevent the light from staying on, well I forgot to make the beep functionality bypass it which is why it wasn’t working.

The buttons still randomly lose their color, but I’ve modified them so you’ll at least still be able to read them.

Edit: I read your post wrong, I’ll post the correct CoRE example shortly.

that worked :slight_smile:

that works too :slight_smile:

however I found a new problem. :cry: (sorry)
when I click the test beep it works on the first try, but if i try it again nothing and a (WAIT) appears in the button.
the Wait stays there until until I click it again. then it will say (BEEP) in the button again.
then it will only work on the the first try again…
Basically it takes 4 clicks to beep twice.

This seems way better than the Aeotec doorbell for speach actions?

With the aeotec I pre-recorded a bunch of things to say with speach synth online and the play them back by calling them.

Do I read this right that I can have it read a text message, essentially using CoRE, etc?

How is the quality? Any TTS examples with the LinearSiren device recorded anyone can share?

@JH1
see this post

I’d rather find the problems now while I remember the stuff I changed.

I just released version 1.2.3 that fixes that bug with the beep button and adds a new setting for “Always Change Alarm Type”.

If you enable this option, the strobe will always flash once before turning on, but it won’t take so long for it to turn on.

Trying to implement your beep, 15 second strobe, beep 15 second strobe, siren and strobe wasn’t possible without adding this option.

Even with this option, you’re going to have 3+ second gaps between the beep and the strobe starting back up.

If you skip the first beep, you might have better luck implementing it.

Something like this should work:

using siren
strobe
wait 20 seconds
stop
wait 2 seconds
beep
wait 2 seconds
speak text: both 20, 30, true

(both 20, 30, true will make it strobe for 20 seconds, turn on the siren & strobe, and turn off 30 seconds later)

Make sure you disable the auto off feature when testing because if you have it set to 30 seconds and you use the beep feature, the device will turn off 30 seconds later. The timer doesn’t restart if you send another command so if 25 seconds later you decide to test the strobe, it will turn off after a few seconds because its been 30 seconds since the first time it turned on.

Sorry to get your hopes up, but this is just a siren and can only make one sound.

I’m assuming you ended up using my DTH for the AeonDoorbell and that also looks like it supports TTS, but it doesn’t. For that device, the Music Player playText command only allows you to specify a track number to play.

You have solved the beep button.

And thanks for the Piston suggestion, I still cant get this to work but your suggestion has worked better then anything I have done. I may have to abandon the Idea, and just use the delay with strobe.

Thank you, so much for going “Above” and “so far beyond”!!!

I’m working on a few other projects at the moment, but when I get a chance I’ll look into adding a delayed beep feature.

beep(delayInSeconds, beepLengthMilliseconds, strobeDuringDelay)

That should make this a lot more reliable because you’d only be sending 2 commands to the device instead of 4 and you’d only need 1 wait in CoRE.

Using Siren
    Speak Text "beep 15, 100, true"
    Wait 15 Seconds
    Speak Text "both 15, 30, true"

I think this is what you originally requested:

Using Siren
    Speak Text "beep 100"
    Wait 1 Second
    Speak Text "beep 15, 100, true"
    Wait 15 Seconds
    Speak Text "both 15, 30, true"

The examples above won’t work until I’ve had a chance to add the delayed beep feature.

I am really sorry to keep bothering you but apparently there is still a bug in you’re code, with the “delay with flash command”.

I can not have it flash during the delay are there is no siren…

if I send the speak command;
Both 10, 10, True
I get the 10 second flash delay “but no siren”.

But if I send the speak command;
Both 0, 10, True
I get no delay just the siren for 10 seconds (as expected)

And also if I send the speak command;
Both 10, 10, False
I get the 10 second delay then 10 seconds of “siren” (as expected)

here are logs from my testing.

	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:08:44 PM:
debug
Siren: Alarm is off


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:08:21 PM:
debug
Siren: Turning on Alarm for 20 seconds.


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:08:09 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:08:09 PM:
debug
Siren: Executing playText(Both 10, 20, False) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:07:41 PM:
debug
Siren: Alarm is off


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:07:17 PM:
debug
Siren: Turning on Alarm for 20 seconds.


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:07:05 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:07:05 PM:
debug
Siren: Executing playText(Both 10, 20, False) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:03:23 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:03:23 PM:
debug
Siren: Turning on strobe for 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:03:20 PM:
debug
Siren: Executing playText(Both 10, 20, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:59 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:59 PM:
debug
Siren: Turning on strobe for 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:57 PM:
debug
Siren: Executing playText(Both 10, 20, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:22 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:22 PM:
debug
Siren: Turning on strobe for 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:02:20 PM:
debug
Siren: Executing playText(Both 10, 10, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:00:09 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:00:09 PM:
debug
Siren: Turning on strobe for 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

9:00:07 PM:
debug
Siren: Executing playText(Both 10, 10, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:59:01 PM:
debug
Siren: Alarm delayed by 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:59:01 PM:
debug
Siren: Turning on strobe for 10 seconds


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:59:01 PM:
debug
Siren: Executing playText(Both 10, 10, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:57:13 PM:
debug
Siren: Alarm is off


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:57:01 PM:
debug
Siren: Turning on Alarm for 10 seconds.


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:57:01 PM:
debug
Siren: Executing playText(Both 0, 10, True) Command


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:56:44 PM:
debug
Siren: Updating


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:56:32 PM:
debug
Siren: Updating


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:55:47 PM:
debug
Siren: Alarm is off


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:55:34 PM:
debug
Siren: Turning on Alarm for 10 seconds.


	ec287d5d-160e-41a4-9f95-b6f7928b28d8

8:55:32 PM:
debug
Siren: Executing playText(Both 0, 10, True) Command

Also what dose this new setting do?
I really don’t see any difference.

What are you using to execute the speak text commands.

If it’s CoRE, can you post a picture from the dashboard?

I was using the Smart Alarm APP.
Notification option;

EDIT:
Sorry that was the command that works ( no flash during pause)
This is the one that has no siren;

I’m still experiencing random issues with SmartThings right now so I’m going to hold off on trying to fix this until things become a little more stable.

What’s the recommended setting for alarm duration when adding the siren in SHM if one chooses to use the hardware setting instead?

[RELEASED] GoControl Multifunction Siren v1.3

  • Numbered settings to make it easier to explain how to do things.

  • Added Delayed Beep feature with optional strobe.

  • Added the setting “Allow Siren Only Light” that turns the red light on without having it strobe when the siren command is used. (It requires setting #3 to be enabled and it doesn’t work with a delay)

  • Fixed delayed alarm bug.

2 Likes

I just released a new version that should fix this bug and should allow you to do the beep,strobe,beep,strobe,siren thing.

You may have to adjust the wait times a bit and if you skip the first beep and wait it will work a lot better.

Let me know if you notice any other problems.

Edit: Make sure setting #1 in the mobile app is set to at least 60 seconds or the both command won’t get executed.

If you go into the device’s settings through the mobile app, setting #1 determines the hardware setting and it can’t be overridden by a SmartApp.

If the device setting is set to 30 seconds and you set SHM to 15 seconds, the alarm will turn off after 15 seconds, but if you set SHM to 45 seconds, the device will turn off after 30 seconds because of the hardware setting.

If you’re using the delay with strobe feature, the device autooff count down starts when the strobe turns on, so if you set it too low, it can potentially prevent the alarm from going off.

When testing, make sure you disable setting #1 because the device’s timer doesn’t reset when you issue new commands. If you leave it on and you don’t wait the full amount of time in between tests, the device will turn off unexpectedly on a future test.

Great, thanks! I just didn’t know if sending an “off” command to the siren after it was already off via hardware would mess anything up. Only one week into smartthings :p.

1 Like

You sir are a saint, I was using the Monoprice Device Handler and was never able to get a battery status. I load yours and get a battery status instantly. Much love

A suggestion regarding tamper detection – the motion sensor uses Alarm V2 specs (so 0x71: 2 and alarmv2.AlarmReport), and so can distinguish between motion detected and tamper detected via zwaveAlarmEvent:

cmd.alarmType == 7 AND cmd.alarmLevel == 0xff //motion or tamper

cmd.zwaveAlarmEvent == 2 //motion

cmd.zwaveAlarmEvent == 3 //tamper

Then, use any BasicSet message to clear tamper.

Thank you for the DTH’s!!! They are awesome.