[RELEASE] GoControl Siren / Linear Siren / Vision Siren

Edited post, I got it figured out. Thank you

I’m a Smarthings newbie, but a long time mainframe assembler and php programmer, attempting to add WA105DBZ siren code. when clicking “CREATE” get error message.

No signature of method: script1498854418498762072048.metadata() is applicable for argument types: (script1498854418498762072048$_run_closure1) values: [script1498854418498762072048$_run_closure1@74faae11] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

What I did
Went to the github link https://github.com/krlaframboise/SmartThings/blob/master/devicetypes/krlaframboise/gocontrol-multifunction-siren.src/gocontrol-multifunction-siren.groovy
found 1.7.4 version;
clicked RAW
copied code
in the IDE Click My Smartthings; click create in Add from Code
paste code then Click Create
get error message

Assume I’m doing something wrong. Any suggestions appreciated.
Thank you

You need to paste it into the device handlers section of the IDE, not the SmartApps section.

Thank you for the quick response. The code is installed and functioning. Now have set up the device, then update the SmartApps.

BTW for anyone purchasing this device from Amazon: you will likely need a jeweler’s sized flat head screwdriver to install the wires into the terminal block. Place each wire into the bottom of the block (no polarity suggested) then turn the respective screw clockwise until the wire is locked in place.

I managed to get through to tech support (without paying the requested $50 fee by connecting to operator and mentionng I purchased on Amazon) who said “they sell them only with the power wires already connected.” First it showed as a power switch, had to delete it, do a device exclusion followed by an install. It’s been an ‘interesting’ few hours getting this connected.

This is a huge thread please forgive me if these issues have been previously posted, perhaps I missed it.

If like me you are using a WA105DBZ-1 and encountering perpetual “alarm pending” issues when testing the device, or the siren is not firing on an alarm, this may help.

  1. Applies only to non-battery aka wall outlet powered devices. The device (well at least mine) does not have battery backup or if it did it is not working. Pulled the plug during a blink test and it stopped dead after being powered up for a week. This terrible from a security perspective!

2… It seems to have a relatively short connection range. In my house it usually won’t connect to my hub at 32 feet and two walls. It worked when first installed, but not now. Unfortunately it is the only Zwave device in my system (besides the hub). (A Zigbee device is working at 50ft and four walls). I fixed it by moving the device then using the Zwave Network repair to determine if the device is connecting. Zwave Network repair is found in the app by clicking the hamburger on the upper left of the screen; click on the hub; on bottom of hub page click Z-wave Utilities, click Repair Z-Wave Network. The device shows as an error when it does not connect. Move the device and retry until there are no errors.

Thanks to these posts and some minor device surgery my WA105DBZ-1 now functions on backup battery power, however the battery % does not show on the battery tile.


https://www.amazon.com.mx/GoControl-Z-Wave-Siren-Strobe-ZC08-14030016/product-reviews/B00MNYSEKY/ref=dpx_acr_txt?showViewpoints=1

Just FYI. This has stopped working with the last SmartThings firmware update. You need to use the stock DTH until somebody fixes.

I’ll look into it tonight.

I’ll have this fixed later today, but in the meantime can you open the device in the IDE and post the raw description?

There are several versions of this device so while I’m making changes I’d like to fix the fingerprints.

I just released v1.8 which should fix the problem, but let me know if it doesn’t.

If you’re on hub v1 or you installed the device prior to May 2016, make sure you test the device after updating.

Hi @krlaframboise

I was wondering if you knew if the GoControl siren supports z-wave direct association. It’s not really clear if it does or doesnt but since you’re in it deep with coding I thought you might now. I want to be able to hook it up to a manual controller to shut it off right away sometimes.

Thanks!
Jon

P.S. I really love your device handler!

It might depend on the model and there are several of them, but ZM1601US-5 is z-wave plus, secure and says it supports 1 lifeline group with 5 nodes so that one probably does.

I can try it on the older modelt hat I have, but I’m writing a couple of new DTHs right now so I probably won’t have time until next weekend.

Thanks, I’m glad you like it.

I have the WA105DBZ-1 which is plugged into AC power and has the battery backup. I am not seeing the battery %. The tile just shows – and from the IDE I do not show Battery listed in the Current Status.

I looked at the device handler code and it showed a finger print of:
//Linear/GoControl Powered (no battery reporting)

Should I be getting a battery% or does it not get reported for that model?

If you post the raw description I’ll be able to tell you if battery reporting is supported. The raw description can be found on the device’s details screen in the IDE.

This is the link for it from the smarttings forum.
https://raw.githubusercontent.com/krlaframboise/SmartThings/master/devicetypes/krlaframboise/gocontrol-multifunction-siren.src/gocontrol-multifunction-siren.groovy

But I am not sure how to tell if this is actually the code that mine is using since it is one of the devices from the standard dropdown and not one I had to add it does not show up in my devices. The screen looks the same except for Battery mine just shows “–”.

If you post the raw description I can tell you if your device can report the battery level.

Hi @krlaframboise could you help please, I am use the “Left It Open Alarm” so I select only Strobe on you App but Siren still works, how can I fix this?

Sirens have the commands siren, strobe, and both.

Smart Home Monitor executes the both command which is why there’s a setting in the DTH that allows you to specify the behavior of the both command.

The siren is going to turn on if the siren command is executed directly which is probably what you’re running into. The only way to workaround that problem is to use a different SmartApp or modify the device handler.

To modify the device handler replace lines 431-433 with:

def siren() {
	strobe()
}
1 Like

Hi there. I am new to Smartthings. Thank you for the device handler and support that you have been providing. I installed the device handler for the WA105DBZ siren and have some success with it so far. In the app, when I am testing it, when I click “siren” or “beeping” it stays in that mode on the screen, even after I press the “off” button. Is there a setting that I am not doing? Thank you.

Hi

Vision ZM1601-5 Z-Wave Wireless Siren GEN 5

I have been using the device handler for a while. I have 4 Gen 5 Vision batter sirens. When I use the beep with one siren it “beeps” most of the time but other it sets off the siren. I have set the default beep length to 1000ms but it makes no difference.

Sometimes I get better results if I re-pair the devices to the hub.

Any ideas?