RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)


(Isriam) #21

awesome, hopefully this can replace poor mans sonos.

anyone have a suggestion on how to use this with ipad? then i can dock it and use it like poor mans sonos.

also, getting this error on smart app

startup failed: script1424101114980926567127.groovy: 790: The return type of java.lang.Object unsubscribe() in script1424101114980926567127 is incompatible with void unsubscribe() in . At [790:1] @ line 790, column 1. def unsubscribe() { ^ 1 error

(Ule) #22

Hi isriam

I think you are installing the MediaRenderer Player in the My smartApps section, you must install the Media Renderer Connect in My Smart Apps section and the MediaRenderer Player in My Device Type Section.

(Richard) #23

I tried it briefly and it works. Once i get some more time ill run more test.

(Ule) #24

Hi Rog

Please , share your model device to make a working device list, I hope you enjoy the app, thanks


Panasonic Viera VT30 and Squeezebox Boom confirmed working.

(Isriam) #26

thank you that fixed it.

any suggestions on how to play this via ipad app as well as android app?

(Ule) #27

Hi isrian

@chuckc81 has informed that android app “UPnPlay” is working in old Android Devices, I don’t now if in news ones to, you can try, I think ios devices have more strict limitation to make it a dlna media renderer, but this forum is to find a solution

(Isriam) #28

OK so I’m trying to use this with bigtalker, but it doesn’t seem to work just yet.

  1. Marantz receiver player is volume 36 but the app shows it as volume 17. Not sure why they are different.
  2. Coldplay clocks plays if I hit play. i have no sounds or url’s defined. Not sure where that is coming from.
  3. Big Talker doesn’t send any sound to the receiver on event.

(Ule) #29

If the volume is not updated, apply refresh button in smarthing app, the volume must to change each time the mediarenderer has a change or the refresh action is lunched.

Sound/Speaker Automation?
(Robert Heath) #30

First off, thank you for working on this. I’ve been working on a device type for integrating SqueezeBox with SmartThings but have only gotten as far as basic remote control functionality. SqueezeBox Radio is partially working. Play, pause, stop, previous, next, and volume all work. Here are the issues I’ve found so far:

  • The state on the main tile (Playing/Paused) does not reflect the true
    state of the device.
  • The track title/now playing text is not
    updated, even after pressing the refresh tile
  • Playing a sound when a
    trigger happens, i.e. a door opens, does not work

Also, my Samsung Smart TV and Plex Media Server were found however I have not yet tested playback or remote control functionality.


(Robert Heath) #31

Basic control of my Plex server is working. Stop/Play actions are properly triggered on Plex and on SqueezeBox when I tested them with my garage door open/closed contact.


I’m having problems with the discovering media renderers.

First things first, I can’t follow the instructions as posted on github:

Open the SmartThings app in your smartphone.

Select the (+) icon to install new things

Go to My Apps section and select MediaRenderer Connect

The MediaRenderer Connect will start to search Your players.

There is no “My Apps” section when I select the (+) icon in my android app. There is “Things”, “Alerts”, “Actions”, and “More”. Browsing through them does not show me the MediaRenderer Connect app. Nor does searching turn it up.

If I set the location in the IDE, I can get the app to appear on my Dashboard under “SmartThings Labs”, but after opening it, it does not find anything. Not sure if the cause is b/c I’m installing it wrong or not.

While viewing the log after installation (via setting location) I see it is searching for media renderer devices, but nothing ever returns. Well actually it appears as if my xbox one would respond, but it continually tries to fetch something from the Xbox without updating the UI with any details. I’ve since turned off the xbox since I am trying to get it to work on a tablet with the UPnPlay app.

(Isriam) #33

hit the + and scroll to the far right. It will be there. If not, you dont have it installed in IDE correctly.

(Chuck) #34

I have not tried BigTalker yet, but using the Sonos code, I have setup notifications for people coming and going. Used Events to Trigger Alerts, and Custom Messages (which appears to create a instant TTS mp3 routed from amazon servers, played on your device). Have not cared to try any music streams yet.

When looking at your DLNA device, the lower PLAY button activates a internet radio station. It is easy to confuse that with the above PLAY button.

On my Fiance’s iPhone, i installed the program ULE recommended “Browse UPnP” for iOS on the App Store and it showed many of the devices around my house that were DLNA. You then click on the item and it states the schemas. You need to look for “urn:schemas-upnp-org:device:MediaRenderer:1”

I did not have any luck with various Free iOS apps for sending custom notifications to iPhone or iPad yet.

After some searching, and testing, i can recommend a similar app for Android, its called “UPnP Tool” on the Google Play Store.

That will allow you to verify if your device states MediaRenderer:1.

Glad to hear it’s working on the Squeezebox. Id love to buy some cheap $40 Android tablets and mount them in various rooms however none seem to have very good speakers.

Hopefully I can make some time this weekend to play some more, you guys are making me jealous!

Portable speakers - mid range - restricted to sonos for a long time?
Alarm that plays a song or sound on the mobile device
(Greg) #35

Anyone know of an iOS app that will act as a DLNA renderer? This would work perfectly with my current setup of old iPhone Manything security cameras.

(Ule) #36

New version available v 1.5

(Isriam) #37

thank you for the update! if anyone can find an ios app that is a dlna renderer that would be awesome

(Greg) #38

@ule @chuckc81 I installed the UPnPlay app on a 2-3 year old Galaxy3 Tablet, but have’t had any luck discovering it as a media renderer. Do you have any tips for getting this app to work? If it’s an os limitation, any thoughts on how far I’ll have to roll back android to get it to work?


(Brian S. Lowrance) #39


I have the devicetype and smartapp installed. When I launch the app, it just continuously scans without finding anything.
My UPNP player is on and here is what Live Logging shows when it scans that IP:

10:54:41 PM: debug Executing GET /MediaRenderer/desc.xml HTTP/1.1

That’s it, it shows others hosts as well that are not media renderer’s, but it doesn’t request /MediaRenderer/desc.xml for those like it does the expected device ( Here is a log from another host that is not a DLNA / MediaRenderer device:

10:54:37 PM: debug Executing GET / HTTP/1.1

The DLNA MediaRenderer device is a Yamaha RX-V671 and lists it is DLNA 1.5 certified. UPNP Browser did show "urn:schemas-upnp-org:device:MediaRenderer:1"

When I visit in my browser, I get the following XML:

<root xmlns="urn:schemas-upnp-org:device-1-0" xmlns:ms="urn:microsoft-com:wmc-1-0" xmlns:pnpx="" xmlns:df="" xmlns:yamaha="urn:schemas-yamaha-com:device-1-0">
<device ms:X_MS_SupportsWMDRM="true">
<dlna:X_DLNADOC xmlns:dlna="urn:schemas-dlna-org:device-1-0">DMR-1.50</dlna:X_DLNADOC>
<pnpx:X_deviceCategory>MediaDevices Multimedia.DMR MediaDevice.DMC</pnpx:X_deviceCategory>
<microsoft:magicPacketWakeSupported xmlns:microsoft="urn:schemas-microsoft-com:WMPNSS-1-0">0</microsoft:magicPacketWakeSupported>
<microsoft:magicPacketSendSupported xmlns:microsoft="urn:schemas-microsoft-com:WMPNSS-1-0">1</microsoft:magicPacketSendSupported>
<manufacturer>YAMAHA CORPORATION</manufacturer>
<modelDescription>AV Receiver</modelDescription>

UPnP DimmableLight Device
(Ule) #40

HI rayzubock

I have updated the media renderer conect, now show in logs the MR found

Update the MR connect , the new file is in github

Launch the connect from phone app , and verify the logs in IDE

The logs can show me the problem and I can fix it.

Send me the logs.


MediaRenderer device found [devicetype:04, mac:00077777777, ip:C0A8778C, port:1F62, ssdpPath:/description.xml, ssdpUSN:uuid:5f9ec1b3-ed59-2365-4530-0008f31f8854::urn:schemas-upnp-org:device:MediaRenderer:1, ssdpTerm:urn:schemas-upnp-org:device:MediaRenderer:1, hub:b323a0c3-2c0d-495c-46d6-12d3bb66676c]