[RELEASE] GE Motion Switch (26931) and Motion Dimmer (26933)

dth_motionsensor

(Micheal ) #82

I don’t have the new app so I can’t really reproduce what you are seeing. I have heard there is a revision to the DTH that is needed. Try this:

In your IDE, go to Device Handler
Open the code for the 26931
On line 25, the line will be:

     definition (name: "GE Motion Switch 26931", namespace: "MichaelStruck", author: "Michael Struck") {

Change it to:

  definition (name: "GE Motion Switch 26931", namespace: "MichaelStruck", author: "Michael Struck", vid: "generic-dimmer") {

Save and publish…I will be interested if this fixes it.


(Roger Gibbs) #83

I made the change. Before I did that I had tried deleting and re-pairing the device. However, now it won’t pair. I tried resetting the device but It still won’t pair.

I have to use the new app because I have a Samsung Home Connect wi-fi extender hub. The old (classic) app has been updated and you can no longer add this hub to it.

I’m getting a couple of plain GE Z-Wave switches tomorrow so I’ll see if they pair.

I had expected the switch to show up on the web and give me the opportunity to change the device handler to be the custom one but I never see this device on the web.


(Nathan Curtis) #84

You don’t have to use. New app. Once your wifi is setup you can continue to use old app and use new. Only if you heed to adjust wifi settings.


(Micheal ) #85

Also, if you have trouble pairing I have found resetting the hub from the IDE sometimes helps. Also, you do not have to remove the device to change the DTH. Simply change the code, save, publish, then exit your mobile app, then come back in. If the change was effective it would show immediately.


(Roger Gibbs) #86

I did the reboot; still won’t pair.

Sent from my Verizon 4G LTE Droid


(Micheal ) #87

OK…the DTH doesn’t have anything to do with this unless you changed the fingerprint profile. I recommend removing the DTH and trying to natively pair it. If that doesn’t work, then you may not have reset the switch properly and it may think it is already paired.


(Roger Gibbs) #88

I assumed the new DTH didn’t have any effect on the pairing; I was just documenting the order in which I had made changes. I’ve reset the 26931 several times since then and it still won’t pair. I’ve also downloaded older versions of the classic app but the motion switch isn’t listed in the GE products and the newest version isn’t compatible with my hub. I’ve written a couple of notes to Jasco tech support.

I just deleted the DTH, reset the 26931 and it paired in the new app. I readded the DTH. The 26931 shows up on the website and in the app. This is some progress but I still get the same error that"Can’t connect to device…" and I don’t get the interface. However, the device will toggle on/off in Alexa. I don’t really think I need any other remote capabilities but if there is an explanation of how to use them I’ll give them a try.


(Daniel Marcotte) #89

This is what i had to do for the 26933 to work in the new app with the DTH of @MichaelS Long but do not skip any line.

For a device to work with the new Samsung Connect app (2018)

Login to https://graph-na04-useast2.api.smartthings.com
My Device Handlers
Click on the Namespace/Name to modify is code
After the field :: author: "xxxxx" add these word: , vid: "generic-dimmer"

It will become: author: "Michael Struck", vid: "generic-dimmer")
Save
Publish For Me

To do on EVERY Devices who use the DH / Device Handlers that you just edit
My devices
Click on the : Display Name to update
Edit
Update (if you received an error “Access to graph-na04-useast2.api.smartthings.com was denied” close the webCoRE tab)

That’s it for the web page

On your phone you need to clear the cache of the App
(“translate from my french Android Phone, if someone can give the good word, i will edit my post)
parameter, Applications,
Find SmartThings (Samsung Connect)
Force Stop
Data/storage
Delete data, back, back…

Open SmartThings (Samsung Connect) and WAIT for the app to load all your device.
Give a like if it worked…


(Roger Gibbs) #90

I’ve made a lot of progress with everybody’s help but still not quite there. It seems that by installing an older version of the Classic app, the app was able to see my Samsung Home Connect Hub. Then, as the app was updated it kept the hub so it shows all of my devices. When I paired the 26931 I left the name as “Z-Wave Device Multichannel”. That device provides on/off capability. I created a new device “Master Closet” using the custom DTH. That device appears to have the correct interface appearance but doesn’t function. That is, not even on/off works. I’m assuming I don’t understand what needs to go in some of the device fields like maybe the Device Network ID. Can somebody provide their device fields or make another suggestion?
The new app shows both devices. The native “Z-Wave Device Multichannel” still doesn’t connect. The Master Closet tries to work but doesn’t toggle the switch saying it can’t connect.


(Micheal ) #91

The proper way to do this if it pairs as a multi function device is to simply switch out the DTH in the devices area of the IDE. No need to change any parameters…just change the ‘driver’ as it were.


(Roger Gibbs) #92

As soon as I figured out the parameter is ‘Type’ it worked like you said. I think I’m done with this for now. On to installing two simpler GE products and maybe a more difficult one (scene controller).
Thanks to all!


#93

I can not for the life of me get the Triple Press Timeout to work. I press the on/top button 3 times on the switch, the light starts flashing blue but the value will absolutely not change in the app or on the smartthings website. I have the timeout set to 1 minute but want the triple press to change it to 15 minutes. It always remains 1 minute.


(Micheal ) #94

The blue light flashing means you pressed it too many times and have activated something in the switch directly.

This does work, but requires a bit of timing to get it right. I recommend watching the Live Logging and filter just for that switch. Press it, wait for the log to stop populating, press again, again wait, then press a final time. If it doesn’t work, turn the light off and try again. Pressing the top button multiple times may end up resetting the switch. Something you don’t want to do.


(Tony Fleisher) #95

I noticed on my 26931 that the triple press is both difficult to trigger and sometimes triggers when not intended. It appears that often (but not always) events are recorded as two or sometimes 3 button pushes (including on via motion in occupancy mode).


(Tony Fleisher) #96

@MichaelS I noticed that the dth appears to subscribe the hub to all 3 association groups and wonder if this might be related to this behavior.


(Micheal ) #97

I am not sure what you mean about subscriptions. Can you share an image? This isn’t something I do in the DTH.

I think most of this is due to the delays in the signal propogration and the SmartThings processing. I am working on removing the logging and resetting the counter I put in for counting the presses. Will probably have something later next week.


(Micheal ) #98

I did some additional testing and found that while the triple press works, there was also a logic error that didn’t reset the counter. I fixed that and actually show the press count within live logging. I also added some additional logic that wasn’t present before, such as resetting the counter when the opposite button is pressed, and resetting it after the 10 seconds has passed. Overall, a MUCH improved logic. I will be releasing this by the end of the week for both the switch and dimmer code.


(Micheal ) #99

Version 1.0.5: GE Motion Switch (26931) and Motion Dimmer (26933)

I have released version 1.05 of the DTHs for these devices. Here is the change log:

  • Updated the triple push to show information about ‘push number’ in the live logging. Also changed the logic to better capture the triple push.
  • Reduced logging of actions as that seems to have created latency within the system when doing triple pushes
  • Updated the DTH to have better compatibility with the new Samsung Mobile app (Thanks to @DanQcCa) for the tip!

The documentation has been updated and the files are now in GitHub.

Enjoy!

http://thingsthataresmart.wiki/index.php?title=GE_Z-Wave_Motion_Sensor_Switch

http://thingsthataresmart.wiki/index.php?title=GE_Z-Wave_Motion_Sensor_Dimmer_Switch