[RELEASE] GE Motion Switch (26931) and Motion Dimmer (26933)

Thanks so much for your response and your contributions here. I did actually change the DTH to yours and it seems to work, mostly. It doesn’t recognize the switch as being dimmable within ST app, for some reason, but it does report the dim level back to it. It looks like some of the custom settings (vacancy mode, etc; i have not tried them all) you enabled also work for the switch.
One issue I am noticing is that setting the “Default level” in the ST app results in different values in the “current states” for the device. Eg, if I set the “Default level” in the app to “0”, the ST Current states → defaultLevel shows “10”.

Just an FYI for others.

He has two DTHs - one for dimmers and one for switches - make sure you’re using the right one.

I am using the “GE Motion Dimmer Switch 26932” handler that he published, and it still results in just on/off options; no dimming option. This is the same behavior I got with the default “Z-wave device multichannel” handler. I’m not sure why, because it does report the dim level accurately in the history.

OK - in that case you may be hitting the device handler ‘caching’ issue.

You should see this:

If it doesn’t then you may need to do a procedure to force the device handler to ‘take’

  • rename the device in the mobile app. (I add an x at the end, it’s temporary)
  • CLOSE the mobile app
  • Go to the IDE, devices, find your device. Edit
  • Change the device type to ZWave Device (It’s a generic ZWave handler)
  • Save
  • Open mobile App, open the device in question. You should see it change to only have an on off button, it should show as online but very ‘vanilla’
  • Once it’s changed - close the mobile app.
  • Go BACK to the IDE, open your device, change the Device type BACK to the 26933 Motion Dimmer DTH AND Change the device Label BACK to it’s original name) [this name change part is necessary - there’s something about changing the device label that causes the mobile app to ask about the device handler and break through any caching]
  • Save and close ID
  • Open Mobile App,
  • Open your device.
  • See the device type change back to motion dimmer and see if the ui looks like above.
2 Likes

Many thanks for the details. I went through each step as mentioned, and still just see a standard on/off button for the motion sensor - no dimming option. Device still shows the “level” (Current States) in the web interface, though. Would be nice to get this solved, but I am happy that it works as well as it does. I can deal without the ST UI dimming, if needed!

I have your GE Motion Dimmer Switch 26933 installed and works perfectly. No issues at all.
Having motion controlled on/off light is incredibly useful. Not only because it saves electricity but because I can use it as the trigger for many other interactions.

However, if I want to sit still and read a book for a while, or if I want to move around a lot while making a video, I need to be able to override the auto on/off controls. How do I do that? In the settings I can see that a triple press is supposed to do it, but it doesn’t work. I tried writing a webcore script to force control, but that failed too. Anyone know how I can have a button somewhere in the app that controls the sensor?

thanks

The triple press does indeed work. You really have to time it properly, however. You can watch the IDE log to determine the proper pacing but it it Tap.wait.tap.wait.tap.

Please note you have to save a preference (i.e occupancy setting) in the settings page for this to work properly.

Hope that helps.

1 Like

thanks, that does help. I managed to triple tap to turn off the sensor, and then after a lot of frustration, I managed to turn it back on. There has to be a better way. Have you considered making the motion sensor indicator in the app also act as an on/off switch?

He doesn’t have control of that UI element yet - SmartThings only allows certain things in UI customization and that isn’t one of them yet unfortunately. What you’ve got right now is already very carefully worked around what the new app allows at this point in time.

things I did not know. Thank you.

Does anyone know if it’s possible to write a webcore routine that will trigger this? I’ve written a bunch and they’re easy to do, but they all have a trigger - time of day, event, etc. I’d need to find a way of adding a button to manually trigger the routine. Any ideas?

Not sure what you mean by that…after the switch eventually goes off (either through timeout or physically press) the occupancy mode goes back to the the state you had it originally.

I am not sure what you mean here as well, but the dimmer can act as a switch (i.e. either on or off) in the current DTH (Enable Switch Mode). Therefore you don’t have to worry about dim level. It doesn’t appear that is what you are referring to, but thought I would bring it up.

Without knowing the trigger for “I am reading a book” I am only guessing here, but the occupancy mode is exposed to webcore. So, you could set your condition to set the book reading mode, set the occupancy, then when it goes off (another trigger) it sets it back to the way it was. In my home, it is set with Alexa and a virtual switch.

Hope that helps.

1 Like

@ MichaelS I’ve installed your custom DTH for my 26931 switch and it’s working wonderfully! Thank You for your hard work. The stock DTH left a lot to be desired. I’ll definitely find your PayPal link send a little something in appreciation and mentioned it in my Amazon review.

I do have a question, is it possible to restrict triggering to time of day (to avoid turn lights on during day time)?

With webCore I change the mode at a certain time so that the light does not turn on with motion at night. Sounds like what you are wanting to do, just the inverse (no light during the day).

1 Like

Thanks for the comments! As @aruffell mentioned, WebCore is the best place to do that. I use it that way; in the day I set some of the lights to ‘occupied’ while at night they go into "vacant’…this works very well and keeps the code for the DTH rather straightforward.

Hope that helps.

1 Like

@miker2069 This is the piston I use but keep in mind it does the opposite of what you are trying to do so you would need to adjust the timing and/or vacancy/occupancy.

I’m having the same issue for both this custom DH, and multiple attempts using other canned DHs (I excluded each time to start fresh). Right now, with the custom DH, I get the occupancy switch cloud with a slash and no dimming control. I’ve confirmed the switch works fine without ST. I now have the ability to manually turn on and dim the switch, and it will time off, but occupancy does not work. Via ST, I can turn on/off only. I’ve used the renaming trick and this has not changed anything, except the name/label. I’ve previously used the same model switch in another location and thought I had the custom DH, but it shows up as Z wave MF device- it seems to work well, but I cannot re-create that. Any troubleshooting suggestions?

The other option with renaming it (which does work about 75% of the time) is to change the device DTH to a standard dimmer, change the name, then change them both back after going into the interface on your phone to verify they actually changed.

I stopped messing with it quite honestly as I hate fighting a SmartThings interface I can’t control. I never use the SmartThings app to control my lights, instead automations and voice control all of my devices. I have never heard of a situation where the device’s actual capabilities (i.e. the dimming) doesn’t show up in automations, and voice is much faster than trying to navigate the app just to dim a switch.

Hope that helps.

1 Like

So I changed the device and the labels and that changed the DH. The problem is that I’m still not getting the dimmer function in the app or automations and the occupancy function does not work. I did try the z wave MF device and in this mode, I get the dimmer, but no settings. Any I agree the app, is painfully slow, although sometimes faster than google trying to understand what I said… Any other ideas?

I have never tried it, but sometimes I think has to do with the phone itself and the ‘cache’ in the app itself. I would recommend you do the process again, but after changing everything back clear the cache and storage on the app, then re-login and see if it ‘rebuilds’ properly. A long shot, but I have also seen doing nothing and then weeks later it changes on its own.