[RELEASE] GE Motion Switch (26931) and Motion Dimmer (26933)

So this is embarrassing, because I’m not a developer or all that tech savvy. I don’t know how to use WebCore. I was barely able to get through the instructions for loading your DTH in the Smartthings EDI. Are you telling me I should bypass the Smartthings app and use this WebCore application? Sorry if this sounds elementary…

And by automations, I’m referring to the Smartthings app.

Decided to go on an adventure of discovery. Registered to both WebCore and GitHub. Now I have to learn how to use the piston capability…

Below is the piston I use to do what you want to do:

You can replace the global variables (@xxxxxxxxxxxxxxxx) with actual times if you want to keep it simpler. I used global variables as I use the same settings for a number of pistons.

The restriction switch is just a “Virtual Switch” I created in the IDE to be able to turn off all webCore automations without having to get into webCore to do so. Say I want to temporarily pause the piston… I can go to my “Settings” room and turn off the virtual switch that controls “Night Light Dimming”.

Last, you need to add your motion switch/dimmer in the list of devices you allow webCore to access from within the webCore smartapp.

If you use the wmw9r backup code to import this piston, you will have most of it done for you. You just need to adjust it per my instructions above. Hopefully this gets you started.

Also, the webCore community is very helpful: https://community.webcore.co/

1 Like

Alex,

Thanks so much! I’ve been tinkering with writing a piston, but I don’t have the confidence or experience to know if I’m doing things correctly or not. I will use your template and go from there. Much appreciated!

1 Like

You are on the right track…Alex’s script should get you going into the correct direction.

1 Like

Sooo…when I try to import the piston using the code, I get an unpopulated piston. What am I doing wrong? Is this a question for the WebCore forum?

Blank piston? I’ve seen that before. I am not sure what the issue is but a suggestion I’ve been given, and tested successfully, is to close all tabs pointing to webCore and the IDE in all browsers (including your phone). This may be overkill but it has apparently resolved a number of weird issues I’ve seen. Maybe it was just a coincidence, maybe not… worth a try. Either way, I would report it in the webCore community. I haven’t as I always managed to get past the import issue by doing some or all of what I wrote above.

Alex, just tried importing two other pistons with codes and they successfully imported. Could there be something amiss with your import code?

When I tried importing the code it did not work for me either. I modified the piston by simply adding a note and then tried again. After the minor modification I was able to import the piston using the same code shown above. Please try again now.

Yep, worked this time. Thanks, much!

1 Like

I know this thread is a little old now, but how were you able to get the switch to recognize the new DTH? I’m new to this and like you already had the dimmer installed. I added the device handler on the IDE, but the switch remained the same “generic” switch in my classic ST app. I then excluded it and readded it, but it is still the generic version without options. My goal is to get the motion sensor for the light in my bathroom to turn on the fan when it senses motion. Currently the ST app only senses it being on or off when the manual buttons are pressed.
Thanks!

Nevermind I found the issue in this thread…should’ve read further. For those with a similar issue go to the device under my devices, click edit at the bottom, then change the device type to the custiom DTH you added.

1 Like

I’m surprised that Smartthings don’t support the motion switch out of the box but also very impressed with your solution. Thank you.

The instruction mentioned to “go through the normal process of adding devices to SmartThings” once the code is submitted and published. I got stuck a bit as I thought adding the code might add the motion switch to the devices list, but turns out it doesn’t. I ended up adding a “GE light switch” and during the discovery process, Smartthings identified the correct motion switch. Perhaps the instruction should ask for you to do exactly that.

Thanks again!

I will look at clarifying that… Thanks!

Anybody know if I can connect two 26931 to the same light (want motion sensing at both switch locations, instead of doing a 26931 and 12723)?

No. it would probably make more sense to add a motion sensor and then you could either use the add-on (if you want physical switch) or remove the second switch.

Shoot. So 26931 at one end, then the other end 12723 with a separate motion sensor? Was hoping to avoid that so I could avoid battery changing and the aesthetics of a motion sensor on the wall.

I have tried several times adding the DTH, deleting it, deleting the GE Motion Switch. The best I get is a light switch. No motion sensing. No configuration option. The NEW DTH is selected just has no affect. What am I missing?

I would recommend discovering it and ensure it works with whatever DTH it autoselected, then change the DTH on the IDE. I assume you are using the classic app. When you change the DtH the interface in the mobile app should change.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.