SmartThings Community

[RELEASE] Fully Kiosk Browser Controller (DTH)

All my tablets work great, But the don’t show in Big Talker or any speech programs. Am I missing something?

Please go to the documentation at the top of this thread, then scroll down to “Notes”.

When using SHM Delay, that is correct.
However, it should be easily accomplished with a single WebCore piston

BigTalker 2.0 is a SmartApp that must be installed into SmartThings

I have big talker installed it shows all my other devices, how ever when I go to configure devices the tablets do not show up. I currently have 9 devices in Big Talker.

Got it !!! I was reluctant to put “sdcard” in the path ( file:///sdcard/Download/filename.mp3) because my tablet does not have an sd card :slight_smile: - turns out that “sdcard” is actually a valid symlink to Android storage and I really should learn to follow instructions :slight_smile:
Thanks - Steve

1 Like

Each tablet or smartphone using Fully that will be a target device, requires a Smarthings Fully Browser DTH be created. The Smarthings devices may then be selected as destinations for BigTalker’s output messages. So nine tablets, means nine ST devices. Suggest starting with one and getting it to work before working on the remaining eight.

One critical part of the setup is to adjust your router to permanently reserve the IP Addresses assigned to the tablet/smartphones that are coded on the DTH settings. Otherwise your system will misbehave when the router is rebooted, or any of the devices fall off the network.

I totally understand. I am also new with this app to coding Android file names and initially shared your concerns with coding “sdcard” without having one in the device. The triple /// also does not feel right :crazy_face:

Ok so let me start over, I have always had Big Talker installed and working, I have 3 samsung tab tablets with Fully Kiosk installed with pro features set up and static ip’s assigned. I have created separate device types for each one and all the functions work in the app screen off, beep, speak all works no problems there. works well actually, but they will not show as speech devices in any smart app other then WebCoRe.

Make sure BigTalker is set up for Speech Synthesis not Music Player. If need be install a second instance of Big Talker.

It also appears the Fully Kiosk Browser DTH may need an update.

It should work as a speech synthesis device (it does for me), it’s always had this coded
capability “Speech Synthesis”
Very early versions had capability “SpeechSynthesis” which is used on Hubitat, but may not work on ST

I have jumped into the WebCore world and created a Piston to chime on any door opening, but I am not clear on the syntax to pass the request (and chime filename) over to Fully Browser Controller (DTH). I “can” push the “Beep” button in the App so I know at least that part is working. Thoughts ?
Thanks -
Steve

Set the DTH’s tone file name to mp3 file copied to the target device as defined in notes in the documentation, save it, test it with the DTH Beep or Chime tile. That seems to be working.

The piston executes the device or multiple devices beep or chime command when any defined contact sensor opens.

The speak function also works in WebCoRe.

1 Like

Device commands are now defined at the top of this thread.

How do you change the Load URL to something other than Goggle?

This was added yesterday as a documentation update in the new Commands section, then “URL to Load” was added after initially posting the response, so I understand it may have been missed.

Note when a url is not included with the command, setting “URL to Load” is used when available, otherwise error message “loadURL no url provided” is generated.

Groovy
devicename.loadURL(‘URL’) where device name is an input setting pointing to one or more FKBC virtual ST devices.

WebCore (don’t hold me this, I rarely use WebCore)
loadURL -->parameter --> string, enter a “URL”

Using the DTH tiles
Adjust setting “URL to Load”

Edited to reflect new settting “URL to Load” added Mar 31, 2019 12:15PM EDT. Update the app, Save, Publish for me. Then adjust “URL to Load” and save the DTH settings.

Thanks, That worked…:sunglasses:

1 Like

Thanks for posting this, it works great so far. I was using LANnouncer before, but had similar problems that you described. I have now updated all of my webCoRE pistons to use Fully TTS instead of LANnouncer.

That got me thinking… is it possible to have different sounds play in different pistons? I have the chime.mp3 saved and it works great, but it would be cool to have the ability to pick different sounds too.

I’m guessing this is probably the right way to do it, but playSound is not an option in webCoRE. Thoughts?

1 Like

playSound is a custom device defined command, I have no idea why WebCore does not see it.

Someone in the WebCore forum would be able to provide you with the answer.

Edit: If you have the time and want to try something add
Capability “Audio Notification”

add near playSound
playTrack (track) {playSound(track)}

Then try using the system defined playTrack “Url” command in WebCore

1 Like

Finally had a few minutes to test both playSound and playTrack with WebCore, both work.
Will likely eliminate playSound, since it is redundant.

tag @J_B_1

1 Like

That’s awesome, thanks for looking into it. Sorry I didn’t have time to test it for you, work keeps getting in the way, LOL. I will try to give it a shot over the next couple days.