SmartThings Community

[RELEASE] Free Ecobee Suite, version 1.6.**

askalexa
thermostat
smartapp_hvac
dth_hvac
project_hvac

(Barry) #124

Please tell me more - there are multiple ways that setpoints get set, and there are multiple setpoints:

  • heat/cool/humidify/dehumidify setpoints
  • Up/down arrow in the device
  • Setpoint sliders in the device
  • Or perhaps one of the Helper apps

Once I know where to look, I’ll try to track down your problem…

Oh, and when did you last update your code - please provide the version number for the Manager, the Thermostat Device and for the Helper SmartApp (if that’s where your problem is)


(Barry) #126

Ecobee reported that they had problems with schedules and premature timeouts yesterday - can you both please check whether your respective issue persists today?


#127

No luck this morning on the mode of smartthings changing with the mode change of the thermostat with the helper app.

One more thing when I look at the notifications in the SmartThings app under messages I see the message:

“Changing Mode to Away because Ecobee Therm: Taylor changed to Away”

But the mode of the hub is still: Home


(Barry) #128

OK, so I’m going to need a bit more detail from you, because I can’t reproduce this.

  1. Please turn DebugLevel 4 on (in Ecobee Suite Manager/Preferences)
  2. Turn on live logging
  3. Run your test
  4. I need to see the live logs for each of these at the time of your test
    • Ecobee Suite Manager
    • you Ecobee Suite Thermostat device
    • your Ecobee Suite Mode/Routine/Program SmartApp

I’m pretty sure you will see an error in at least one of those, but please send me the segment surrounding your test for all three. (NB - best to send via PM).


#129

I can confirm that I am no longer having the issue. I tried setting the setpoint every way imaginable in the device handler. Normally, it is automated via webcore. I could set the thermostat via the ecobee app but not the device handler, so I figured it was an issue with the device handler. Didn’t seem to be the case. Do you know if ecobee leverages some other api/path in their app? I figured if the entire public api was having issues that both would fail.


(Barry) #130

It wasn’t an Ecobee API problem, SmartThings admitted that they broke their scheduler AND screwed up the execution timeout so that schedules would run immediately AND they would then be shut down prematurely for using too much CPU.

FWIW - I expect you would have seen the same thing using the stock ST Ecobee support as well. All kinds of apps and devices were failing all across ST-land (for certain users on certain shards). Not just an Ecobee issue…


#131

i’m having an issue where all of my sensors are unavailable, when i attempt to remove all of the devices it get an “oops” error, and when I try and “remove this instance” i get “an unexpected error has occurred”


(Barry) #132

Removing the devices when they are showing as unavailable isn’t recommended.

Because these are all child SmartApps and Devices of Ecobee Suite Manager, the appropriate way to remove everything is to reverse the order of how you installed them:

Edit: added FIRST: Edit/Remove ALL SmartApps that are using the Thermostat/Sensor devices. Easiest way is to go to the device page on your mobile device and tap the SmartApps tab - you need to make sure that there are NO SmartApps using the device…THEN

  1. In Ecobee Suite Manager (ESM), Remove each Helper SmartApp you have installed
  2. Exit ESM
  3. In ESM, unselect all the sensors
  4. Exit ESM
  5. In ESM, unselect all the thermostats
  6. Exit ESM
  7. In ESM, scroll down and select “Remove this instance”

If you tried to remove the devices from within the device itself, you won’t be able to uninstall everything. You can try deleting the Helper SmartApps and Devices in the IDE, but usually your only recourse is to send a note to SmartThings support asking them to delete your devices and SmartApps.


(Daniel Ionescu) #133

Smartthings has been having problems since yesterday. I wouldn’t troubleshoot anything until all problems there are solved. Example: Alexa integration does not work.


#134

when I try and do this at the select thermostats step it says "“device still in use. remove from any smartapps or dashboards. then try again” when i try and save.


(Barry) #135

Yes, because there are still other SmartApps using the device. These could be Helper apps, or other automations (like WebCoRE). You can try selecting the “SmartApps” tab on the thermostat/sensor devices and then deleting each of the SmartApps that reference them. Or, you may have to look at the device in the IDE to see which apps are using it, and try deleting them from there.

But sometimes, if you didn’t follow the aforementioned / proscribed procedure, you won’t be able to see/find/delete those SmartApps. That’s when you need to ask Support@SmartThings.com for help…


(Scott Silence) #136

I am using Webcore to set my Ecobee to Away and then Resume program based on the house Alarm being set and/or proximity sensors from Family members cell phones. This works great, no real issues to report. However, I do have one question. I noticed last night that if I manually set a hold at the Thermostat, and then the webcore fires because of setting the alarm, that it resumes the program. So, it is working as it should. But, is there anyway of knowing if away was set by the user at the Thermostat or by your app (or webcore through your app for my case). I would only want to resume if it was set by your app, if someone did a manual override at the thermostat I would want to ignore it. Thoughts?


(Barry) #137

Scott -

That’s a tricky one, as you can’t really tell where a change was made from the API.

That said, changing the setpoint manually (either in the app or at the device) will set a “Hold: Temp” program, whereas overriding with another program will set “Hold: Away” or “Hold: Home” as the program.

I supposed it might be possible for the thermostat to note that it wasn’t involved in making a change (all operations from the ST device and/or WebCoRE et al are effected as commands on the device). But there are LOTS of ways that the setpoints change that aren’t initiated by the ST Device - e.g., scheduled Program changes, etc., so this would be really tricky.

Let me think about it for a bit…


(Barry) #138

Ecobee Suite Mode/Routine/Program Helper updated 11 September, 2018 at 1:15pm EDT

  • Fixes Mode Change action in Ecobee Suite Routine v1.6.12

Long-standing bug which evidences the fact nobody was using this feature - it would never work!

I guess that most users would choose to run the “Goodbye!” routine instead of simply changing the Location Mode to “Away”. No matter, bug squashed…


(Scott Silence) #139

Yeah, I figured that would be a tricky request. :grin:

One thing I can do on my end is in Webcore carry a global variable that I set internal when it changes in Webcore and track it that way. Ignore if it wasn’t set by Webcore. The only issue with that is if I change it using your app on my phone, than that doesn’t apply. But, maybe that is ok.

It’s almost where you need a Hold with a force override flag. If the flag is not set then it will only resume what was set by your app, if the flag is set to true then it would resume regardless of where it was set.

This is really just nit picking…not a big deal at all. Just a thought I had last night. Thanks.


(Barry) #140

Oddly, that is pretty much what the reservation system does, except now it only “reserves” off events.

It’s possible that I could figure a way to use reservations that way, but I still need to think about it…


(Barry) #141

Minor update to Ecobee Thermostat released on 11 September 2018 at 3:05pm EDT

  • Fixes error in coolingSetpoint display in Thermostat v1.6.18

This fix is recommended for ALL users


(Barry) #142

Minor update for Ecobee Suite Manager release 14 September 2018 at 8:15am EDT

  • Corrects capitalization of currentProgram when currentProgramName is either Auto Home or Auto Away.

This fix is recommended for anyone using automations based on thermostat.currentProgram (e.g., via WebCoRE).


#143

Not sure if this is the correct place to ask this but how can I only use Smart Circulation when the Ecobee is in Sleep Mode? In other words I only want the fan to run when the AC or heat is on, except when the Ecobee is in sleep mode. I then want it to run and adjust how long it runs based on 2 sensors.

Sorry I’m a little confused on how to do this. Thanks!


(Barry) #144

Easy-peasy. If you scroll down almost to the bottom of the configuration page for Smart Circulation, you will see options to adjust only when:

  • SmartThings Location Mode is…
  • Thermostat’s Mode is…
  • Thermostat’s Program is…

In your case, you want to set the last one to ‘Sleep’.