SmartThings Community

[RELEASE] Free Ecobee Suite, version 1.6.**

askalexa
thermostat
smartapp_hvac
dth_hvac
project_hvac

(Barry) #333

Nope = welcome to the confusing world of Samsung vs. SmartThings.

The Classic app supports lots of developer extensibility, and so you will find some very robust DTHs and SmartApps that work only in the land of SmartThings Classic.

Then there’s the world of Samsung’s “new” app. In this world, attributes are quite limited - pretty much to the basic capabilities that ALL similar devices support. No big deal for switches and such, but more complex devices like Smart Thermostats, Weather Stations and the like simply cannot be rendered in the New App. I have enabled the basic set of features that the New App supports, but you will find far more flexibility and capability when you use SmartThings Classic.

That said, I’ll check to verify that I’ve enabled all the currently supported features in the new app…


(T Q) #334

So is the latest version working?
Issue #1. Installed with the Community Installer. Installed ok but wasn’t showing up. Found that it did not auto-publish like other apps do…So I published only the Ecobee Suite Manager and that got me in.
Issue #2: I logged in and authorized my ecobee login… now it says “Please click ‘Done’ to save your credentials then re-open the SmartApp to continue the setup”

But there is no ‘done’ there… there is a save… but that gives an error about “Device still in use”.
Also tried fully exiting the app and coming back… but the only option is to connect by ecobee account still. There are no other options.


(Barry) #335

Sorry about that…

It should say “Done or Save” because the SmartThings app sometimes screws this up.

The error indicates that the test devices that were created were not properly deleted. Happens from time to time. To fix it, go into the IDE and find the (probably two) devices that have names that start with “dummyThermDNI” and “dummySensorDNI”. Then go back into Ecobee Suite Manager to continue the setup.


(T Q) #336

That dummy device bit was right on! Working now! Thanks!


(Barry) #337

Testing a fix that should put an end to this error once and for all…


(Barry) #338

Update: Ecobee Suite Manager v1.6.18 released 2018/12/21 at 2pm EST

  • Cleans up the removal of temporary test/dummy devices created during initial installation process.

This update is not required for existing users


(David Wheeler) #339

Looking for a little help with the “smart circulation helper”
I used the the circulation app last winter with no issues. I created 2 separate instance: one to run the fan and night during sleep mode with 5 min minimum and 30 min max fan, then a instance for the home mode with 0 min minimum and 0 min max (so fan doesn’t run durning this time). This setup worked before but now it just stays at 5 min fan run time. Any ideas ?


(Sneak X2018) #340

Hi,

I’m kind of new to the Smart Things world but I really appreciate the work you did, it integrates really well with my Ecobee 3 and it adds some interesting custom features lacking from the original product.

One question about digits though. If I set 0 digit in the settings my ecobee3 tstat reports an integer value as supposed but my wireless sensors shows a 1 digit value (20.1 deg). If I set 1 digit, the tstat reports the 1 digit value but the wireless sensors reports a 2 digit value (20.12 deg)… Any reason for that behavior ?

Besides that, it works fine !

Thank you for your good work !


(Barry) #341

I’ll have a look…stay tuned.


(Barry) #342

Does the circulation time change during the 5-30 minute Sleep mode? Or is it stuck on 5 minutes during both Sleep and Home mode?

I’ll have a look to see if I created an issue over the past year’s worth of updates…


(David Wheeler) #343

It appears to be stuck at 5 minutes during sleep and home. The app is only sending the home instance though and it stays at 5 min.


(Barry) #344

Found my problem - I till post a fix in a few minutes (I want to find the other reported problem, then I’ll post both fixes at the same time).


(Barry) #345

Updated Sensor device & Smart Circulation helper on 2018-12-23 at 8:48am EST

Fixes include:

  • Cleaned up Celsius digits display in Sensor device
  • Fixed fanMinOnTime reset when configured min == max

(David Wheeler) #346

It does reset it to Zero now, but it keeps sending the Off (0 min min & o min max run) command when the thermostat is in program that it should be On (5 min min & 30 min max)


(Jeremy Stewart) #347

I’m having a really difficult time getting this to run after install. I was able to install the device and the smart apps, but when I go to the mobile app, I start having issues.

When I configure the credentials, it works, but it won’t let me finish the process. Something about not being authorized. After that, the app hangs everytime I try to access the Ecobee Suite and creates two test devices which quickly multiply. I was able to uninstall by removing as many smart apps as possible, removing the test devices, and then the app would open just for me to remove it. I removing everything including the device handlers and start over, but I had the same issues.


(Barry) #348

Weird - I just re-verified that a clean install still works, so it sounds like you might have a problem with the installation. Please double check that:

  • both the Thermostat and the Sensor DTH code is installed in the Device Handlers sections of your IDE and published - you need both, even if you aren’t using the sensors.
  • ALL of the supplied SmartApps are installed in the SmartApps section of your IDE - there are 10 in total: Ecobee Suite Manager and 9 helpers - again you need them all

Before you restart from scratch again, go into Live Logging. When you start Ecobee Suite Manager to do the initial connect to Ecobee, click on Ecobee Suite Manager in the Live Log and watch to see if any errors occur.


(Jeremy Stewart) #349

Thank you Barry. I removed the SmartApps and re-added(confirmed all 10). Also confirmed I have both Device Handlers. Went to My Apps and opened Ecobee Suite Manager and I see this in the live log. Note that the Ecobee Suite Manager app never opened and just hung with spinning wheel. It also added a Test Sensor and a Test Themostat

e1d71b58-fee2-446c-a013-5b230fc9ada9 3:37:38 PM: trace Notify: BinaryState = off, 0

e1d71b58-fee2-446c-a013-5b230fc9ada9 3:37:38 PM: debug Parsing ‘index:43, mac:58EF68D91491, headers:Tk9USUZZIC8gSFRUUC8xLjENCkhPU1Q6IDE5Mi4xNjguMS4xNTg6Mzk1MDANCkNPTlRFTlQtVFlQRTogdGV4dC94bWw7IGNoYXJzZXQ9InV0Zi04Ig0KQ09OVEVOVC1MRU5HVEg6IDEzMg0KTlQ6IHVwbnA6ZXZlbnQNCk5UUzogdXBucDpwcm9wY2hhbmdlDQpTSUQ6IHV1aWQ6OTYyMTQyNjgtMWRkMS0xMWIyLWJiZDMtZjI2Y2JlZThlYzBkDQpTRVE6IDA=, body:PGU6cHJvcGVydHlzZXQgeG1sbnM6ZT0idXJuOnNjaGVtYXMtdXBucC1vcmc6ZXZlbnQtMS0wIj4KPGU6cHJvcGVydHk+CjxCaW5hcnlTdGF0ZT4wPC9CaW5hcnlTdGF0ZT4KPC9lOnByb3BlcnR5Pgo8L2U6cHJvcGVydHlzZXQ+CgoN’

e1d71b58-fee2-446c-a013-5b230fc9ada9 3:37:38 PM: debug Parsing ‘index:42, mac:58EF68D91491, ip:C0A801A9, port:C002, requestId:033398a6-83f7-409f-a118-98d0b2cd9541, headers:SFRUUC8xLjEgMjAwIE9LDQpEQVRFOiBTdW4sIDIzIERlYyAyMDE4IDIwOjM3OjM4IEdNVA0KU0VSVkVSOiBVbnNwZWNpZmllZCwgVVBuUC8xLjAsIFVuc3BlY2lmaWVkDQpDT05URU5ULUxFTkdUSDogMA0KWC1Vc2VyLUFnZW50OiByZWRzb25pYw0KU0lEOiB1dWlkOjk2MjE0MjY4LTFkZDEtMTFiMi1iYmQzLWYyNmNiZWU4ZWMwZA0KVElNRU9VVDogU2Vjb25kLTU0MDA=, body:’

e1d71b58-fee2-446c-a013-5b230fc9ada9 3:37:38 PM: debug Using ip: C0A801A9 and port: C002 for device: e1d71b58-fee2-446c-a013-5b230fc9ada9

e1d71b58-fee2-446c-a013-5b230fc9ada9 3:37:38 PM: debug Executing ‘resubscribe()’

ea87f6ef-9edb-4d8b-bf76-9df0ac53a9bc 3:37:25 PM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Long#minus.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @line 1337 (scheduleWatchdog)

f01c901c-8fd4-4609-adaa-0f949c41dc58 3:37:25 PM: debug Code updated: Ecobee Suite Manager, version 1.6.18

ea87f6ef-9edb-4d8b-bf76-9df0ac53a9bc 3:37:25 PM: info refresh() - calling pollChildren (forced)

f01c901c-8fd4-4609-adaa-0f949c41dc58 3:37:25 PM: debug Code updated: Ecobee Suite Manager, version 1.6.18

f01c901c-8fd4-4609-adaa-0f949c41dc58 3:37:22 PM: error physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again @line 564 (doCall)

f01c901c-8fd4-4609-adaa-0f949c41dc58 3:37:22 PM: trace Removing child devices

f01c901c-8fd4-4609-adaa-0f949c41dc58 3:37:22 PM: debug getChildDevices(true), children=2

7b961ced-35db-4a73-85f9-e45611cfd3dd 3:37:21 PM: info Subscribing to Device Health events for device Ecobee Suite Thermostat:TestingForInstall (ea87f6ef-9edb-4d8b-bf76-9df0ac53a9bc) using DeviceWatch-DeviceStatus event

ea87f6ef-9edb-4d8b-bf76-9df0ac53a9bc 3:37:21 PM: debug parse() --> Parsing ‘updated’

ea87f6ef-9edb-4d8b-bf76-9df0ac53a9bc 3:37:21 PM: trace Ecobee Suite Thermostat, version 1.6.18 updated

d5584d63-d2b4-4d90-822e-72564b7d6626 3:37:13 PM: debug Parse returned {{ linkText }} has arrived


(Jeremy Stewart) #350

I think I may have found the solution here:


(Barry) #351

Could be, but I think that Health Check is also a possible problem…


(Barry) #353

Updates released on 2018-12-23 @ 6:10pm EST

  • Ecobee Suite Manager v1.6.20
    • Include hubId for created devices
    • Better management of errors around add/delete/remove devices
    • Fix unintentional recursion
  • Ecobee Suite Thermostat v1.6.20
    • Short-cut the install process for test devices
    • Log uninstalls also
  • Ecobee Suite Sensor v1.6.16
    • Short-cut the install process for test devices
    • Log uninstalls also

NOTE: The general idea of the above fixes is to delete the temporary test devices as quickly as possible after creating them, in hopes that the SmartThings ecosystem (e.g., Health Monitoring and/or Alexa) don’t have time to subscribe to them. In the process, I found a race condition in the ST ecosystem that I’ve tried to code around. Hopefully the issues with initial setup will be significantly reduced as a result.

These updates affect only new installs - not required for all users.