SmartThings Community

[RELEASE] Free Ecobee Suite, version 1.6.**

askalexa
thermostat
smartapp_hvac
dth_hvac
project_hvac

#313

After reading about that other paid suite and the attitude that developer had, I was happy to test this one out and then to find so much integration! Still finding my way around but the documentation seems to be pretty good too, so I just wanted to give a big thumbs up!


(Barry) #314

Alas, the answer to the 2nd question is"Nope" - the thermostat waits for what it thinks is a reasonable time after the last occupancy sensor reports nobody is present. (Note that I said “occupancy sensor” and not “motion sensor” - these things work with a slow fuse - it takes up to 15 minutes of motion before it registers “occupied”, and I think 30 minutes of no motion before it goes “unoccupied.” Then an hour wait - just in case - before going into Smart Away.

For this reason, I never really persued enabling/disabling Smart Away/Smart Home. As a SmartThings user, you are better off using other sensors to determine if anyone is Home or Away, then simply use the supplied Smart Routine/Mode/Program Helper SmartApp to set the thermostat into the appropriate program. Much quicker and much more predictable.

For extra credit, consider how you might pre-heat/cool your home before you get there for lunch. Using Life360, you can activate your HVAC when you leave a location (like work). I even use Automatic Pro in my car (connected to IFTTT) to start the pre-heating/cooling whenever I enter the 5 mile radius around my home - IFTTT turns on a virtual switch (named “Almost Home”) which in turn activates my “Almost Home!” Routine, for which I have a Smart Routine helper watching that sets my thermostats back to Home well before I get there.

The possibilities are endless!

EDIT: Sorry, forgot to answer the first question. Apparently there is no Ecobee API call that will enable/disable the Auto Home, Auto Away or Follow Me features.


(Alex) #315

Thanks for such a detailed response! I was trying to keep the Smart Away/Smart Home since setting the program would lead to an indefinite hold and would cause a cold house if my MIL were over watch the kid while I was at work, etc. That said, using the ST sensors like you mentioned might be a good way around this. I could simply use those sensors instead of the Ecobee sensors to determine motion and set the Ecobee myself. I might play around with that method. Thanks!


(Barry) #316

Your holds don’t have to be indefinite unless you want them to be.


(Alex) #317

If I tell Ecobee to switch to away until the next program, do you know if Smart Recovery will still work? What’s the easiest way to tell Ecobee to hold until the next program in WebCore using your device class?


(Barry) #318

Yes, Smart Recovery will still work if you use Until Next Program.

The easiest way to accomplish what you want is to use the Helper SmartApps, because they handle all the intricacies of setting schedules and hold time/type. To accomplush the same in WebCoRE, you will need to specify the Hold Type in the call to Set the Hold type you want. You will need to review the code for the Helper apps, the DTH and for Ecobee Suite Manager to understand what you need to do with WebCoRE. All the commands/API entry points that my Helper Apps use are in fact exposed to WeBCoRE.


(Alex) #319

Thanks, I’ll give it a shot!


(model flyer) #320

Hi,

I am currently having issues with my Ecobee connection to Free Ecobee Suite. It was working fine and then I noticed today that the sensors were offline and then also noticed the thermostat was not reflecting what was actually happening on the physical therm. The polling was also timing out. I removed everything and started the installation from scratch but now it will not authorize the API connection. I tried the free ST version of the Ecobee and same thing! Is this a ST issue? or some sort of outage?

{“error”:true,“type”:“java.lang.reflect.UndeclaredThrowableException”.“message”:“An unexpected error occured.”}


(Paul Nielsen) #321

I’m see the same thing. I’m on a chat with EcoBee support. They first said everything is good. I shared the same error you are getting, they haven’t responded yet.


(Paul Nielsen) #322

Noticed that my direct connection from Alexa to Ecobee connection is down too.


(Paul Nielsen) #323

So they are pushing new firmware to my Thermostat… I keep telling them the API gateway is down. We shall see.


(model flyer) #324

OK… thanks for the info. If the FW resolves the issue, is there a way to update it ourselves?

H


#325

I’m having the same problems. I’m new to ecobee and spent a long time setting things up with ST last night and thought I did something wrong. It was working last night and now it’s not.


#326

Same issues. I’m getting these errors in the log. I generated this error by just clicking save in the smart app…but I’m having the same issues of none of my sensors refreshing in the app. Assuming it is connected. On chat with ecobee as well.

3:58:13 PM: error java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 77669896827613 @line -1 (LOG)

3:58:03 PM: error ___exception getEcobeeThermostats(): org.apache.http.conn.ConnectTimeoutException: Connect to api.ecobee.com:443 [api.ecobee.com/216.220.61.235] failed: connect timed out


#327

It appears to be working now…


(Paul Nielsen) #328

So it seems to be fixed… Ecobee support is looking into what happened. Since the Alexa interface and the Smartthings interface were down at the same time, I’m guessing it was their API gateway. The only other thing I did was reboot my phone. The FW upgrade was not successful - aka I’m on the same code when the problem started.


(model flyer) #329

It works! I guess was some sort of outage. Thank you all for contributing. I’m glad I wasn’t alone!

H


#330

New guy here. I installed the device handler and the smart app, but how do I add this new custom device to my ST infrastructure? I added my original Ecobee using the app, but I assume I have to add and authorize this custom handler via the ST site?
I should add that I don’t see a marketplace area on the app to add it from there.


(Barry) #331

You have to use the Classic App. Just follow the instructions for installing it from the Marketplace/My Apps…


#332

Excellent. That worked, thanks. I was able to setup a simple routine where certain lights are turned off based on the “Quiet down” trigger for the Ecobee motion sensor.

Is there a reason I can do this in the classic app, but not in the new one?

In the new one, I see your Ecobee device, but when I try to select a trigger condition, my only options are “Temperature” and “State”.
“Motion sensor” is still absent. The tile in the new app indicates it has the motion sensor data, and when I click on your Ecobee device in the IDE I see the “motion” data.

Is this just a compatibility issue in your code? Is this anything I could tweak in my local copy?