SmartThings Community

[RELEASE] Free Ecobee Suite, version 1.6.**

askalexa
thermostat
smartapp_hvac
dth_hvac
project_hvac

#206

I am seeing an issue where the smart mode helper changes my modes to the incorrect ones. I am using Smart Mode Helper to change the comfort setting of my thermostat when the hub mode changes. Under “recently” for the thermostat I see the mode change to the correct one (Home) and then it switches to wrong one (sleep) within milliseconds of each other. Since the sleep mode change occurred last the heat doesn’t kick on. I have attached a screenshot of what I’m talking about.


(Barry) #207

Odd. We need to find out what is changing the program to Sleep.

Can you please turn on Debug Level 5, start Live Logging , and then reproduce the event? I wil need to see the log for both Ecobee Suite Manager, and the Thermostat itself - both showing the entire time from the change to Hold: Home to the change back to Sleep…


(Tobin Smail) #208

I am trying to set a smart mode that switches to aux heat mode (my gas furnace) when the smarthings outside temperature sensors is below 35 and switches to auto mode (heat pump) when the same smarthings outside temperature sensors is above 35. When I select the ecobee3 thermostat the acceptable ranges of temperature change from 0…99 to 45…92. This will not allow me to save my smart mode and says the values are out of range. What am I missing?

The reason I want to do this is because ecobee internet temp is terribly inaccurate for my location and even with ecobee support assistance we can not find a good temperature stream. This smart mode switch would allow a better temperature for switching from aux to heatpump heating.

Extra Information - (Free Ecobee Suite, version 1.6.16 : Android : Ecobee3 lite : Fahrenheit)


(Barry) #209

Silly me - I’m using the min/max setpoint controls on the thermostat to limit the external temperatures. Obviously, that’s wrong.

New version will be posted momentarily, but you can just comment out lines 757–>764 in Ecobee Suite Smart Mode code if you’re in a hurry…


(Tobin Smail) #210

Excellent

Thank you


(Barry) #211

Updated Smart Mode Helper published October 19, 2018 at 3:50pm EDT

  • Ecobee Suite Smart Mode v1.6.15 now allows wider range of external temperature selections (-5.0…105.0°F)
  • Now supports metric temperature range (-20.0…40.0°C)

N.B. The original use case for Smart Mode was to turn on/off the A/C (cooling) when the temperature was moderate outside. With this latest edit, you can also use it to control your Heat Pump/Aux Heat when the temperature falls to the freezing levels.


#212

Hi Barry - I’m on vers 1.6.16. In the Contacts & Switches Helper in Android, when I go to Select the Ecobee Thermostat, select it, then save, when I go into it again, the Ecobee Thermostat is again not set. It again says to Tap to set. Is this just a display problem, or is the thermostat really being deselected each time?


#213

Also, everytime I redo it, another instance of Contacts & Switches is added to the Ecobee Suite Manager screen. I now have 5.


#214

Actually I see the problem. The upper Configured section is the what happens when set it up. The lower section is to setup another set of Contacts & Switches. Sorry, I was confused by that. I now deleted the other 4 upper part entries, and only now have 1.

Type - Avalable.


(Barry) #215

Sorry for the confusion. SmartThings gives me very little ability to customize the list of child Helper SmartApps.

I do suggest that you rename each Helper SmartApp as you create them - this will help a little.


#216

Any reason why the thermostat keeps reporting 451°? It also incorrectly reports that my inside temp is set to 62°.


(Barry) #217

As explained in the documentation, you have lost your connection to the Ecobee Cloud. If it doesn’t self correct (it should), simply re-login to Ecobee from Ecobee Suite Manager.

Thanks!
Barry


#218

Yes but when it reconnects it still says 62 when the house is at 75


(Barry) #219

I see that you are in Auto mode, with the low setpoint at 45 and the high at 79. Due to an idiosyncrasy of the ST UI, 62 is the average of those two setpoints. Scroll down to see the actual setpoint for heat and cool…


#220

Interesting webcore is using the value of 62 incorrectly instead of the actual current temp


#221

Feature request idea:

For the smart circulation device handler, can the section that has Only if mode is … add an additional ‘only if relative humidity is greater or equal to .’

My workaround is to create a virtual switch ‘humidity over 55’ then use webcore to check ecobee’s relative humidity and if >= relative humidity then turn on virtual ‘humidity over 55’ then use quiet mode section:

.

Or if possible since this is my specific use case what is the groovy code that I can copy/paste into the smart circulation child handler’s ‘only if section.’ Trying to have a tighter flow vs webcore+virtual switch.


(Barry) #222

Alas, this is the problem with WebCoRe - there is no way to enforce that webcore apps follow the defined usage models for “compound” variables. “currentSetpoint” means something different based on the current “thermostatMode.”

One solution is to avoid Auto mode - use the Smart Mode Helper to switch between Heat/Cool based on the outside Temperature - then the currentSetpoint meaning will be unambiguous.


(Barry) #223

Try this: https://raw.githubusercontent.com/SANdood/Ecobee-Suite/master/smartapps/sandood/ecobee-suite-smart-circulation.src/ecobee-suite-smart-circulation.groovy

Note that for logic simplicity, I implemented as “only when relative humidity is higher than…”

Copy/Paste over the 1.6.12 version in your IDE, Save and Publish. Please let me know ASAP if this meets your needs…


(Barry) #224

FWIW, I suggest you double check that your WebCoRE piston is actually specifying that it wants the current ‘temperature’ and not asking for current ‘setpoint’.


#225

As expected the smart circulation handler hasn’t engaged since the relative humidity on ecobee is showing 50 and my cutoff is set at 55. So far it’s working perfectly :slight_smile: . Thank you for the quick turnaround!

Nice to see this on the Smart Circulation handler !