[RELEASE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

Good Morning,

I just installed the app but my FI9901EP is having a user access problem as reported above. Can someone please suggest a solution?

MrMacca

Apr 14

Yes, that’s what I thought but the username/password combination is definitely correct, I’ve double checked. I’m wondering if it’s because the FI9901EP doesn’t use the same method for defining the motion detection area. In all my other Foscams, a grid is used. In this one, you draw 3 boxes on the screen (see screenshot)

HI @RBoy,

I cant get streaming to work when i am not home (i have tried many times using cell network, wifi, etc) . I can get everything else to work including taking snapshots, turning motion monitoring on and off, etc. But no streaming… Can you suggest anything?

I have an R2, shield link hub, and note 8 (in case its relevant).

Thanks!

Any word on the issue that is preventing snapshots from taking place?

I like the added features of the Rboy Foscam ST App, but missing the SnapShot feature is disappointing.

Here is an email response from Maddie at Rboy Technical Support:

There is a bug introduced in the SmartThings platform which prevents it from automatically discovering the camera. Please send an eMail to support@smartthings.com quoting ticket no 594098, “Missing Body in response which is preventing communication with UDP devices” so they can prioritize fixing the issue.

As for the take picture issue that’s a bug with the ST hub firmware where some cameras cause the hub to overload while processing the picture response. It has been reported to ST and they will likely fix it in the next hub firmware release.

On Wed, Aug 29, 2018 at 8:36 AM

Dear Support,

I have a Foscam R2C installed on my local lan at 10.0.0.72:88. I have installed both the Rboy Foscam device and smartAPP. I have configured the Rboy Foscam SmartAPP to be a HD Model camera, and Camera Model (Other). I have verified all settings in the things device preferences section as well. Could you look at the logs below and see what I might have missed that is preventing a “Take Picture” from being displayed?

@RBoy, hello, everything has been working perfect for over a year. All the sudden in the last few days I can no longer get live video, it just says there is a problem retreiving the live video stream. Any ideas?

Yea! With a little mod, I was able to correct the missing picture from Foscam RC… I wish the picture could be shown in Landscape mode, since cropping cuts off major areas of my kitchen pan.

@rboy, any response to my issue>

I would start by rebooting the phone, camera, hub and wifi router.
You want to go back to the troubleshooting link on the installation instructions page and see what may have changed.

Thank you very much, followed the trouble shooting, all is fixed now.

1 Like

Just purchased a Foscam R2C camera, have it setup and running in the Foscam app and the Foscam web gui. I have purchased and installed the Foscam DH and the smartapp per the instructions. I can get the smartapp to communicate with the camera, shows on and motion when motion is detectedin the smartapp but I have been unable to get video in the Smartthings Classic App. I have looked at the logs and I see the request for a RTSP stream from the camera with my camera’s username, password, ip address and http port number, but I cannot see a livestream. I have cut and pasted the rtsp link into a VLC player and I can see the video stream. My phone, laptop, and camera are all on the same 2.4G network. In addition, I have connected the camera directly to the hub via RJ45 cable but this didn’t change anything. I have rebooted the smartthings hub, router, and camera while on wifi. Still no video. I have tried the onvif settings with port number 554 and have included that in the smartapp under rtsp port number. NADA. Not sure if I am doing something incorrect or not. I do not have port forwarding turned on just yet. I figured if I could get it on the LAN then I could try to get the stream outside my LAN. Am I missing something. I have gone through this thread but it is difficult to read everyone of the 1275 posts.

Thanks for any help,

mdavidthomas

So I get up from where I have been sitting all day and walk outside which is near the camera and the video starts working. Still connected directly to my router with a RJ45 connection. WIFI on phone had full bars at all times.

mdavidthomas

Camera Model: R2C
Firmware: 1.13.1.6_2.91.2.9_92

ST Hub Model: V2
Firmware: 000.022.00014

Iphone 8 plus
iOS: 11.4.1

ST App Classic
Version: 2.17.0

Back again. Video livestream has been hit or miss but mostly miss for me. But I do have other issues that I am trying to sort out while I evaluate the cameras. I have realized that I would probably be ok if the alarm function and the motion alarm being turned off/on via ST would work. Quiet honestly Foscam’s iphone app works pretty well.

Motion Detection before cloud turned on:

Yesterday, I did not turn on Foscam’s free 8 hour cloud service, nor did I have an FTP server setup or a SD card inserted into the Camera. With the Foscam web GUI motion detector set to enabled and sensitivity set to medium. I could set off the motion detector 70% of the time by walking in the camera’s Field of View (FOV). I noticed that ~5 seconds later the Smartthings Motion Detector Icon would change from Blue/On to Amber/Motion. When I left the cameras FOV, ~50% of the time the Amber/Motion would return to Blue/On. Th e other 50% of the time, the motion tile would stay in the Alarm/Motion state. This was fairly repeatable throughout the afternoon. All other buttons seemed to function normally (i.e. LED, PTZ functions, Refresh, and Reboot).

Early evening, I left the house for about 2 hours from 6:30 pm to 8:30 pm where the camera sent Motion Detection pushes to my phone ~ every 15 minutes while there was no one in the house. Video was still mostly a miss throughout the evening hours. The room illumination was from daylight bright to mostly dark during this time, I don’t know if the lighting changes were throwing false motion detections or not.

This morning at 6:30 am, I connected to the camera through ST app and the video worked amazingly the first time I tried. I had reduced the camera’s motion detector sensitivity to Low and the last alert I received was around 1:30 am when I left the room for bed. This morning the camera seems to not show motion even if I move around in the camera’s FOV. The Motion (blue/on) button doesn’t seem to work either. Most of the time when toggled, I get a red/error symbol or the gray/… symbol. The logs show a red remark (-3 access denied).

I went further and activated the free 8 hour cloud service and the foscam notifications/recordings seem slow to register at the low sensitivity setting. Moved up to Medium sensitivity and so far the motion icon in smartthings shows current status of alarm correctly without hanging on. I wonder if changing the motion sensitivity cause something to update?

So my biggest problem is that I cannot manually toggle the motion detector from on to off in SmartThings. When I do press the button, I sometimes see the motion tile toggle to Red/error then back to Blue/On motion tile, or a Gray/… motion tile which hangs until I refresh. In all cases, during livelogging, I see a -3 access denied message. All of this assumes that I understand the intention of this smartapp. I have been through all 1277 messages in this thread. I have administrator privileges on the only account that I have setup on the Foscam camera.

IMG_5972
Image1. Blue/On Motion Tile

IMG_5971
Image2. Amber/Motion Motion Tile

IMG_5974
Image 3. Gray/… Motion Tile

Thanks for any help,

mdavidthomas

As the logs mentions, your camera is rejecting your credentials to modify settings (enable/disable motion detection etc) because your most likely the camera thinks that your user doesn’t have administrative rights on the camera. See this post for troubleshooting help.

Your intent/understanding is correct. Just that your camera doesn’t seem to allow your user to change settings remotely(which is why you can see live video but cannot enable features).

Also check your password. Some special characters have an issue with some firmwares when using through API. Try using a simple password and if it works isolate which character may be causing the issue.

@RBoy I have installed a second camera (FI9900P) and it is working as expected with toggling the Motion button. So, I deleted the R2C camera from the ST app and went back through the install using the same username, password. Motion tile sets to Amber/Motion immediately and never changes back to Motion (Blue/On) . So, I deleted the camera from the ST app, the Foscam app, and did a factory reset on the camera. Reinstalled device using same ip address, port, username, and password. Same issues. I have gone into the camera gui and changed the user password to M12345 and I still have the same issues. Could there be any differences between the R2 and R2C cameras or a firmware issue on the camera stops external toggling of the Motion detector?

Thanks,

mdavidthomas

Can you capture the camera device settings screenshot from your ST mobile app and also the IDE logs from your camera and PM them to me when you click on the refresh tile. It working here so I’m guessing it’s something in the configuration.

The only difference as per Foscam’s engineers is the antenna. One has a 3db high gain antenna.

Also I hope you’re installing it through the Foscam Camera Manager and not directly as a device as that could explain why it never switches back. The Foscam Camera Manager SmartApp is a critical component for motion detection.

Just created a new administrator username=mdt password m12345. I toggled the Motion detector enable to off within the camera gui. Entered data through the ST app for username and password and clicked on refresh. ST reported the Motion as (Gray/Off) tried to toggle, get Red/Error smart tile for a second then the Motion tile goes back to Gray/OFF. Toggle on in Camera GUI, same issue with new administrator. Interestingly, I can send you the configuration from the ST app but livelogging is not updating on the hub right now. Worked all day up till an hour or so and now no logging. I will send details as soon as I can.

Thanks again. Sorry to be a hassle.

mdavidthomas

1 Like

Have a noob question: the Foscam smartapp can’t detect any foscams despite my cam being wired into my router. What am i doing wrong?

If you are talking about the smartthings smartapp from RBoy , it will not autodetect currently due to a firmware release by smartthings that broke that function. You will have to hit next in the upper righthand corner of the screen while it is searching and manually enter the ip address, port number, username, and password that you setup on the camera using the Foscam app or gui. If this is your issue it was discussed early this year but not super evident unless you read the 1283 posts :wink:

Here is an email response from Maddie at Rboy Technical Support:

There is a bug introduced in the SmartThings platform which prevents it from automatically discovering the camera. Please send an eMail to support@smartthings.com quoting ticket no 594098, “Missing Body in response which is preventing communication with UDP devices” so they can prioritize fixing the issue.

As for the take picture issue that’s a bug with the ST hub firmware where some cameras cause the hub to overload while processing the picture response. It has been reported to ST and they will likely fix it in the next hub firmware release

Best regards,

mdavidthomas

@RBoy Is it possible to start a closed discussion on this board for this Smartapp where you can update with current bugs and update status without discussions capability. Info only to keep people from having to search through 1286 posts to find an answer. Previous question post 1285 from Peter_Crocitto seems to be good support for having a thread with known bugs/update statuses. Could reduce the number of questions from the community.

Just a suggestion, not sure if it is even possible.

mdavidthomas

1 Like

We can definitely start a new thread to discuss pending issues.
The UDP issue is being tracked here and the snapshot issue being tracked here