[RELEASE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

It an issue with the ST Android app. Please report it to ST support so they can prioritize fixing it. See this

1 Like

Does this work with an amcrest camera? I read foscam and am crest are pretty much the same thing.

Only if your amcrest has the same API’s/SDK that Foscam uses. There’s a difference between same hardware and same API’s. Your camera need to be API compatible with foscam for this to work.

Ah I see thank you for clarifying.

I have setup the device handler and created a foscam device. I can see the video feed from my camera in the smart things app, but when i click the buttons for activation motion or turn on night vision, the button just turns to 3 dots and doesnt do anything. I also cannot rotate the camera using the arrow keys. I am using a Foscam R2 camera. Anyone have any ideas why this is not working?

Open IDE Live Logging and take a look at the communication between the hub and the camera when you click on a button. If there’s a username/password or permission problem it will show up in the response from the camera. If you don’t see any response from the camera (light BLUE INFO messages, NOT dark blue Debug messages) either the ST/Camera configuration is incorrect or your hub cannot reach the camera (that’s a networking issue, firewalls, routes, subnets etc).

See this post for installation instructions:

1 Like

I followed those instructions, even changed the HTTP port as a test, still only get the live video but no control, I am not sure if there is a common setting that I am missing or what is happening.

Feel free to PM me your logs, if you seeing live video then your configuration is likely correct and your phone can reach the camera (video is directly from phone to camera) but your ST hub can’t reach your camera. Your router firewall or something on your network is preventing the two from talking.

#enhancement_request: provide option to select a light color when motion is detected on the foscam (use case: turn Halo smoke/co detector to purple when there is motion in daughters room and blue when there is motion in sons). NOTE: The functionality is currently available in the ST Smart Lighting App.

1 Like

Questions before I dive into the app:

  1. Is the app compatible with Foscam C1 cameras and Foscam FI9803P;
  2. From my research neither of these cameras support a direct method to stream via http:// url. You can obtain image capture or you can stream via RSTP… would your device type remedy this situation for something like smart titles or action tiles.
  1. Yes it does
  2. Yes it does support RTSP for non http cameras. See the configuration guide in the above posts
  3. SmartTiles does not have any way to support RTSP or Image files. You need to contact smarttiles support for that feature request

@OMFGitsJUSTIN… I’m curious if you ever got this working? I just spent a couple days getting my FI8910W to work. I am a complete amateur so reading through MANY posts, I finally found this one and at the begining of the post there is a gray section called, “Instructions for installing Device Type:” I followed those and re-did everything. It still didn’t work at first and after reading more, I realized that I was expecting too much. Just a note, ST with or without these apps does not yet support streaming via Foscam. Having found that out, I finally tried taking a picture. Still no love. I reset the app and the camera and finally I can take a snapshot and make the camera “cruise” (or “patrol” as Foscam calls it). You won’t see active streaming video, but everything else seem to work. I do notice however that when viewing the camera controls (and any pic I have taken) the screen is refreshing every few seconds (~10). For reference I am using an iPhone 6S with OS version 10.2.1. , ST iPhone app Version 2.3.0. I have 21 Z-wave devices and 1 Foscam 8910W.
Here are a couple of screenshots from my phone when the Foscam is selected:


Had to take 2 shots to get it all.

Thanks @RBoy for the work on the apps and instructions. I am constantly adding things to my home automation so I paid for the lifetime access… I am sure I will be using more of your apps as I expand my hubs abilities.

Regards

1 Like

So streaming does work but it needs patience because of the moving parts. There are many posts above on it.

  1. Configuration first - try MJPEG if not without MJPEG and if you camera supports RTSP then enter that. Also use the default RTSP port since Foscam has trouble using other ports. Finally make sure your camera can reach the phone and nothing in the network is blocking it since it’s a direct connection
  2. The video tile is very phone dependent as it uses the phones codecs
  3. The ST video tile is very sensitive to errors and delays. So your network needs to be very responsive and try rebooting the camera and hub as it often fixes almost all timing issues

Top 3 tips if you’re having streaming trouble :slight_smile:

Thanks! I’ll give that a shot!

1 Like

I have an FI9821W V2 and a R2 camera that I just switched over to using the HTTPS ports instead of the http ones. Changed my port forwarding to forward these instead of the HTTP ones, and updated the devices in the app to these new ports. Viewing the stream in the app works fine, but issuing commands to change the motion detection status on/off no longer seems to work. Any ideas why that is/what I may have screwed up?

ST hub doesn’t support HTTPS communication for local devices (hubAction), this is a feature requested we have requested ST staff. @slagle any word on this?

If you want to use HTTPS you will need to use an external IP address with port forwarding enabled, that goes through the ST cloud and not through hubAction.

I’m a bit new around here and with Smartthings - what does that mean exactly? Is there an example of something that can do that? Would that be like… issuing the https call through a device handler or something?

Sounds like I’ll be switching back to http :slight_smile:

Hmmm, any reason that the standard: http://xxx.xxx.x.xx:xx/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=USERNAME&pwd=PASSWORD would not be working in ActionTiles? Everything is working fine on the end of the smartthings app. Any tips gladly appreciated. Thanks!

Put it into the browser first directly and see if it works. If it isn’t working then either configuration is wrong (did you enable MJPEG in your ST camera settings and then press Refresh?) or your browser doesn’t support MJPEG.
If it’s working in the bowser then try it in ActionTiles. If it doesn’t work in action Tiles but works in the browser you should contact action Tiles support.

###Foscam Camera Universal Device Handler - version 03.04.04

  • Updated UI colors to match ST recommendation
  • Added ability to retrieve image from ST (for future compatibility)

###Foscam Motion Alarm Monitor SmartApp - version 02.07.01

  • < no change >
1 Like