[RELEASE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

@RBoy @emilijanus I have the same issues. I just downloaded the handerlers and the smart app. I have everything installed correctly because it works in smartthings but just with a video with a green screen . I also have the FI9821P. I have 2 of them and both have the green video issue. Kind of a bummer but the only reason I purchased RBBoy was for my Foscams. I have another Android app that I have been using with my Foscams for a couple of years and it works great and not 1 green screen. The green video is something never seen before ever from my cameras. Any help would be appreciated.

Yes the green screen is an artifact of the ST mobile and phone codec combination. See the posts above for more details.

Best solutions that have worked for the community so far:

  1. Reboot hub, camera and phone (all three)
  2. Toggle IR Led On/Off
  3. Vary light intensity (dark / light) around the camera

This this post for troubleshooting help:

We have a really nice surprise and breakthrough coming shortly :slight_smile:

5 Likes

ok, now you have my interest peaked!

2 Likes

I hope i includes a fix to the green screen issue many including me are having.

You’ve been asking for it and it’s finally here after months of development and testing.
Foscam cameras now support automatic discovery, installation and configuration. Welcome to the future!

Foscam Camera and Motion Alarm Manager SmartApp - v03.00.00

  • Now support automatic discovery, configuration and installation of Foscams
  • Single app used to discover and/or manually add Foscam cameras
  • Now supports separate motion detection actions for each camera

Foscam Camera Universal Device Handler - v04.00.00

  • Support for automatic discovery and installation through the Foscam Camera Manager SmartApp
  • Support for real time streaming AND control/movement of the cameras for both iOS and Android
  • Automatic discovery of presets for and cruises for HD and SD cameras (no more manual configuration required)
  • Optimized user interface with additional panning controls (9 directional control)
  • Up to 6 presets and support for additional 4 presets for HD cameras (automatic discovery)
  • Dynamic tiles that appear/update/hide based on camera configuration
  • Support for external and internal (LAN) IP address for streaming video on the go
  • Improved responsiveness of cameras operations
  • Added support for simultaneous flip/mirror for cameras
  • Added support for Audio to live streaming (for HD and SD cameras)
  • Added support for blank passwords

This is a whole new way to integrating Foscam cameras with SmartThings. Live video streaming now inside and outside the home. You can add your external IP address/DNS name in additional to your internal LAN IP address for seamless transition. (if you’re having trouble connecting kill your SmartThings app and restart it)

See the screenshots below:

NOTE: You CANNOT migrate your existing setup to this version. You will need to REMOVE/UNINSTALL your existing Cameras and SmartApp in SmartThings.

Once you delete your SmartApp and Cameras, follow the instructions here to upgrade the Code and ReInstall the Foscam Camera Manager SmartApp which will then discover and install your Foscam cameras.

http://www.rboyapps.com/InstallFoscam.htm

1 Like

Great !! @RBoy any recommendation as which camera works better with your app?

Thanks

Hi. They all work great. Each has its own pros and cons.

For E.g. If you’re looking at mounted cameras which rotate then the R2 and 9821 are excellent options. R2 supports 1080p where as the 9821 supports MJPEG video which is required for ActionTiles steaming.

It really comes down to your personal preference and requirements.

Wow, nice update. after removing everything and starting from scratch, the only thing I cant get to work is the “take picture” when I click take picture there is no preview and I can not view the shot. I am using an F19821P v2 .
I am using the “other Foscam” driver.

Any thoughts?

Just tested it on the 9821 and it’s working fine. Reboot your camera/ST hub, kill your ST mobile app and restart it. That pretty much fixes 99% of every issue we’ve seen, including with the video streaming. If something doesn’t work in the ST mobile app just kill the app and restart it.

Thank you, I restarted everything and I am still having issues. I am going to wipe out everything and try one more time. Probably user error :slight_smile:

Working now… Thanks again. Full remove and reinstall worked. Maybe I messed something up the first time.

2 Likes

Hi,

Thanks for your efforts…

Discovery Issue: I didn’t had your previous apps. I just configured your device handler and app. How long the discovery steps takes? Is C1 model supported for auto discovery? I have 4 foscam cams up which I just made sure that I can connect via Foscam app and via direct IP url. Do I have to do anything else to get them discovered?

I waited on discovery steps 15 mins 1st time, and started again and waiting for another 15 mins.

Update: In live logging I found this when discovery was on for Cam’s IP:

error java.lang.NumberFormatException: For input string: "02009B1F"
trace GOT LOCATION EVT: index:1C, mac:E**********, ip:C0********, port:2711, type:LAN_TYPE_UDPCLIENT, payload:Seems an ID of 258 chars

Hi @neelp

Yes it supports all Foscam cameras, it takes a few minutes to discover depending on your network setup and camera response time.

Have you set the camera name on your camera in your camera web settings? It looks like it isn’t able to parse the name your camera is reporting.

Can you eMail us the entire data you’re seeing in your Live Logging including the 258 byte data and I’ll take a look at it.

@maddie Yes had the camera name setup. I have setup the camera manually for now. I’ll email the error.

@maddie
I installed this by the directions 3 times. I have a Foscam FI8910W and the app does find the the camera.Everything install correctly but i just get a black screen most of the time for the preview.I did at one point get a feed but it massively delayed.I do the have the feed setup with actiontiles and the feed is fast. (so the connection is good) no erros in the app under recently.

Ideas?

Edit:1 I have rebooted both the app and hub
Edit 2: The camera is connected because I can I can move the camera with the controls.
edit: 3 motion seems to be working and screenshots are good, but not the preview.

Just received a new F19821P and it is a V3… I have 2 V2 cameras that work fine. I have copied all the settings exactly and I am getting the following error in SmartThings

"Camera responded with result -1- > CGI request string format error, your Username or Password may contain invalid character. The only allowed special characters are ~!@^*()_ "

I have made sure my password follows the rules. It will take a picture, but just not video.

Any thoughts?

The video feed goes from the camera to the hub to the SmartThings platform to your phone (which is why you can access it from outside your house as well now). It’s likely somewhere along the chain that things had slowed down for you or it’s getting delayed to a point where your ST mobile app isn’t able to connect reliably. Try to reboot your router and check your internet connection. It’s possible that that platform itself may be running slow.

Hi @maddie I have the access to the the camera from outside of my network. (port forward). Inside of actiontiles, the speed it just fine. Inside the “Thing” is really delayed. It seems to be “hit or miss”. I just connected to the camera in “things” and it the best I’ve seen for speed- Maybe a 1-2 second delay between frames. Before it was 10-15 second…between frames.

Motion is super delayed as well. maybe 15 seconds before it reads motion. That could just be a limitation of the camera with the software

Yes George, as I mentioned in my earlier post this is how SmartThings video feed is setup in the mobile app. It traverses the entire chain and the slowest component determines the speed/delay. Port forwarding works differently and it’s a direct connections between the app and the camera. SmartThings mobile doesn’t support port forwarding, video streams go through the hub hence it can work outside the house even without port forwarding now.

The 5-10 second notification time for the Foscam cameras is normal as that’s about the time the camera takes to report the information to ST and make it’s way back to the mobile app. Again it depends on your setup (hub, internet, ST account etc). In our lab setup we see maybe a 2-3 second round trip delay in the video feed about 5-10 seconds to get the motion notification.

If you have a low latency connection that helps a lot, but if the hub/ST is running slow the best you can do it reboot the hub, router, camera and kill your ST mobile app and restart it.

1 Like