SmartThings Community

[RELEASE] Foscam Camera Device Handler Universal DTH with Discovery, Live Video Streaming, Motion Sensor/Alarm Integration - SD (FI89xx), HD (FI98xx, FI99xx), Cx, Rx, Ex, Fosbaby

This is slightly off topic but I have a Foscam F19928P - It constantly triggers, around every minute! A branch blows a security light comes on, ete, etc. I cant see a way in the Foscam web interface to either select area its monitoring or reduce sensitivity. Any ideas?

Just a tip, Foscam has a different plugin for Internet Explorer. When using IE, it uses an older ActiveX plugin which has more features available then the newer plugin used by other browsers.

In IE you will many additional features which aren’t available in Chrome/Firefox/Safari including the option to set the Motion Detection area:

Here is an example of the web interface for IE 11 v/s Chrome for the same camera in the Motion Detection settings page:

You can also use the new native Foscam app available on the iOS store where in the camera settings, you can set the detection area under Alarms -> Motion Detection:

Wow, Thats better! Thanks a million. My Android app doesn’t have any of those settings its simply a viewer. IE did it for me though. Thanks again

1 Like

I have it set to “lowest sensitivity” and am getting an alert at least once per minute. Any advice appreciated.

I didn’t see a fix to this problem. I am pretty confident the user and password is correct. What I found is that if I use “other Foscam” as the model it works fine. If I select “C2/R2/R2E/R4/FI9900P” I have the exact problem described. I can’t toggle the motion on and off. I have the R4S camera.

That sounds about right. Unless your model is listed, use Other Foscam. The R4S is not the same as R4, they used different chipsets.

How fast can pictures be taken if I want the camera to take pics if a separate motion sensor is triggered?
How many pictures can it take and save and where is it saved (downloadable?)?

Depends on your SmartThings server, hub and network latency. Also do note that there is a rate limitation built in on request from ST’s engineers so that it doesn’t negatively impact the platform. Some people put it in a loop (accidentally or otherwise) and that should not be done.

You can however take a burst of pictures say 5 or 10 in a minute. The pictures are uploaded to your SmartThing server and be viewed through the ST Classic app in your device page by clicking on the Picture tile or in the Recently tab. I believe you can then save the pictures from the picture tile onto your mobile phone (depending on version of the ST Classic app you’re using).

1 Like

Yes the DTH can differentiate between 3 different types of events (if supported and reported by the camera)

  • Motion
  • Sound
  • Human detection (PIR) (e.g. R2 foscams)

ST doesn’t explicitly support different types of motion, so the DTH will report a type: motion and value: active event for all of them, however it also adds a little description text which can help you differentiate between the source of the event.

If you’re using an app like CoRE or WebCoRE, you can create a rule to inspect the descriptionText field of the motion event and if it contains:

  • detected motion, it’s a regular motion detection
  • detected human motion then it’s a PIR motion detection
  • sound motion then it’s a sound detection
2 Likes

try this DH


i adapted it wor k with a smart cam connect

it take 10 photos 2 seconds apart

this it the bit you need if the DH you might need to look at the “path” in the take section as it set up for a tenvis

` def burst(){
delayBetween([
take(),
take(),
take(),
take(),
take(),
take(),
take(),
take(),
take()
], 2000)
}
def take() {
log.trace “take”
def parts = settings.unamepass.split(":")
def uname = parts[0]
def pass = parts[1]

    //TENVIS JPT3815
    	//def path = "/media/?action=snapshot"
	def path = "/snapshot.cgi?user=${uname}&pwd=${pass}"
	//TENVIS JPT3815
	doCmd(path, true) //true to save image
}

new app purchaser, I see potential in software but not functioning yet to its advertised potential hence this post:

Background:
Intermediate user here. Have been in contact with Maddie who provided some answers however still no C1 working with the instructions above. no network issues, tried on muiltple devices including i0s, did troubleshooting, rtsp port. no video stream with any of the 6 C1 cameras. 9805E, C2 and R2b work though.
IDE smartthings showing cameras, just no video stream.
running linksys acs1900, with tx >400mbs throughout all corners

Anyone else having issues with getting a video feed in their home lan? of course remotely C1 not working amidst ipcamviewer working beautifully for all cameras.

Also wanting to use cameras microphone to send alert through smarrtthings v2 hub. Maddie mentionned April 30th: *

You can see the forum post on how to capture sound events (if reported by the camera) and use WebCoRE to create custom actions for those events.

I have not yet heard from Maddie regarding a link that provides this setup info of webcore. does anyone have this information, a link that outlines step by step how to do this?

Thank you,

Lucas

It’s literally @maddie last post, skip one post above your post:

You can check out the WebCoRE community on how to use WebCoRE to capture custom events, it’s a slight learning curve. Personally I prefer CoRE since it’s easier to setup initially using just the ST mobile app.

The C1 camera uses RTSP and that can be tricky because of port forwarding and network issues. Assuming you’ve already seen this post on how to setup video streaming for the C1, if you’re still having trouble then the ST app/hub is having issues with reaching your RTSP port. Check firewalls, routing issues and anything that could block the packets between the ST app, hub and camera. I would definitely recommend only using port 554 for RTSP because the camera can be finicky with other ports. Since your other cameras are working and you’re just having trouble with your C1 streaming I’m going to guess it’s a RTSP network issue where you ST mobile app/hub aren’t able to reach it.
You could try using your LAN IP instead of an external IP, that works better for some folks. C1 stream is working for users but each network setup is different (to use an external IP your router must support local loopback routing). Maybe folks can share how they configured their C1’s or tips they may have that worked for their setup.

Sorry to jump in but I wanted to buy the c1 and use it in ST (Your app) and also on ActionTiles (using tinycam ) .
Is this problematic version for ST or Actiontiles ?
Does Foscam G4 complaint with your app ?

AFAIK ActionTiles only support MJPEG streams and not RSTP due to limitations of the browser, @tgauchat can confirm if that’s changed

Some HD Foscam’s support dual mode streams, MJPEG and RTSP. The DTH allows you to switch the camera video streaming format to MJPEG for supported cameras (through the camera preferences page), then you can use the camera with Action Tiles using the MJPEG URL. The DTH works with all Foscam cameras, the features available may vary from model to model, you just need to select the appropriate option in the camera model settings.

I’m going to use it with tinycam pro so the address will be the tiny web server and it will manage all my cameras .
I Also bought the G4 because of their human detection feature which I need and I want ST (using your app) to trigger when human detected .
Is that compatible ?

I bought the Foscam Camera and Motion Alarm Manager. Right now I’m using version 03.01.000 which I believe is the latest.
I had to manually add IP etc because it would never detect my cameras but I’m not able to configure them to record when the alarm is tripped etc. Can you help @RBoy

I’ve downloaded and installed the device handler and Smart App in the IDE, but have stopped there with a question.

I’ve got a v2 hub at my home and a v3 hub at my warehouse and various models of Foscam cameras at both locations. Both locations are under one Samsung account and using the “classic app”.

I want to view one camera at each location, but is there an issue with installing a copy of the SmartApp at each location and on different hubs? Will one OAuth work for both locations?

Thanks in advance.

Trying to follow the installation process in this link : http://www.rboyapps.com/InstallFoscam.htm

  • however - clicking the first link in the installation process requires a username/password???